summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2007-05-11 08:51:15 +0000
committerMatti Bickel <mabi@gentoo.org>2007-05-11 08:51:15 +0000
commit9307bc2ccc7b6d527ff56d2094a6704c575a4e35 (patch)
treeba0b586a6ae79d61c22b4b29357f498cba55b9de /x11-libs
parentStable on alpha wrt bug #166805 (diff)
downloadgentoo-2-9307bc2ccc7b6d527ff56d2094a6704c575a4e35.tar.gz
gentoo-2-9307bc2ccc7b6d527ff56d2094a6704c575a4e35.tar.bz2
gentoo-2-9307bc2ccc7b6d527ff56d2094a6704c575a4e35.zip
Drop fox-1.2 support in fxscintilla-1.71 (fox-1.2 will be removed soon)
(Portage version: 2.1.2.7)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/fxscintilla/ChangeLog7
-rw-r--r--x11-libs/fxscintilla/files/digest-fxscintilla-1.71-r13
-rw-r--r--x11-libs/fxscintilla/fxscintilla-1.71-r1.ebuild90
3 files changed, 99 insertions, 1 deletions
diff --git a/x11-libs/fxscintilla/ChangeLog b/x11-libs/fxscintilla/ChangeLog
index 587efd33d48e..99f9c975afb8 100644
--- a/x11-libs/fxscintilla/ChangeLog
+++ b/x11-libs/fxscintilla/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/fxscintilla
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fxscintilla/ChangeLog,v 1.30 2007/04/19 13:02:00 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fxscintilla/ChangeLog,v 1.31 2007/05/11 08:51:15 mabi Exp $
+
+*fxscintilla-1.71-r1 (11 May 2007)
+
+ 11 May 2007; Matti Bickel <mabi@gentoo.org> +fxscintilla-1.71-r1.ebuild:
+ Drop fox-1.2 support in fxscintilla-1.71 (fox-1.2 will be removed soon)
19 Apr 2007; Ferris McCormick <fmccor@gentoo.org>
fxscintilla-1.62-r2.ebuild:
diff --git a/x11-libs/fxscintilla/files/digest-fxscintilla-1.71-r1 b/x11-libs/fxscintilla/files/digest-fxscintilla-1.71-r1
new file mode 100644
index 000000000000..592428ddb273
--- /dev/null
+++ b/x11-libs/fxscintilla/files/digest-fxscintilla-1.71-r1
@@ -0,0 +1,3 @@
+MD5 302b5a3d54a259e3bfea2ab1f4040d49 fxscintilla-1.71.tar.gz 887017
+RMD160 83e8eb50c7ee98d83600eda846a71ce90896ae4e fxscintilla-1.71.tar.gz 887017
+SHA256 882c91f025699ee2496d0dfd37ef21dda40e9a7fff796d0f4091c03390716d7d fxscintilla-1.71.tar.gz 887017
diff --git a/x11-libs/fxscintilla/fxscintilla-1.71-r1.ebuild b/x11-libs/fxscintilla/fxscintilla-1.71-r1.ebuild
new file mode 100644
index 000000000000..fb00750f274b
--- /dev/null
+++ b/x11-libs/fxscintilla/fxscintilla-1.71-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fxscintilla/fxscintilla-1.71-r1.ebuild,v 1.1 2007/05/11 08:51:15 mabi Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="A free source code editing component for the FOX-Toolkit"
+HOMEPAGE="http://www.nongnu.org/fxscintilla/"
+SRC_URI="http://savannah.nongnu.org/download/fxscintilla/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="=x11-libs/fox-1.4*
+ =x11-libs/fox-1.6*"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/1.71-shared-libs.patch || die
+ epatch ${FILESDIR}/1.71-fox-SLOT.patch || die
+
+ einfo "Running autoreconf..."
+ touch NEWS AUTHORS
+ autoreconf --install --force || die "autoreconf error"
+}
+
+src_compile () {
+ # Borrowed from wxGTK ebuild
+
+ einfo "Building ${PN} for FOX-1.4..."
+ mkdir ${S}/build_1_4
+ cd ${S}/build_1_4
+ ../configure \
+ --prefix=/usr \
+ --includedir=/usr/include \
+ --libdir=/usr/$(get_libdir) \
+ ${EXTRA_ECONF} \
+ --enable-nolexer \
+ --with-fox-1-4 \
+ --with-foxinclude=/usr/include \
+ --with-foxlib=/usr/lib \
+ || die "configure error"
+ emake || die "make error"
+
+ einfo "Building ${PN} for FOX-1.6..."
+ mkdir ${S}/build_1_6
+ cd ${S}/build_1_6
+ ../configure \
+ --prefix=/usr \
+ --includedir=/usr/include \
+ --libdir=/usr/$(get_libdir) \
+ ${EXTRA_ECONF} \
+ --enable-nolexer \
+ --with-fox-1-6 \
+ --with-foxinclude=/usr/include \
+ || die "configure error"
+ emake || die "make error"
+}
+
+src_install () {
+ cd ${S}/build_1_4
+ emake DESTDIR="${D}" install || die "make install error"
+
+ cd ${S}/build_1_6
+ emake DESTDIR="${D}" install || die "make install error"
+
+ cd ${S}
+ dodoc README
+ if use doc ; then
+ dodoc scintilla/doc/Lexer.txt
+ dohtml scintilla/doc/*
+ fi
+}
+
+pkg_postinst() {
+ elog "New as of 1.71-r1:"
+ elog "FXScintilla is now built separately against FOX-1.4 and -1.6."
+ elog "Support for FOX-1.0 has been dropped upstream."
+ elog "Support for FOX-1.2 has been dropped by gentoo."
+ elog "The Librarys are named for the FOX-release they correspond to, for"
+ elog "example: For FOX-1.4, the library is called libfxscintilla-1.4."
+ elog "Anything linked against previous releases of FOX and fxscintilla"
+ elog "may need to be rebuilt."
+ elog
+ elog "The nolexer libraries are now included in this release as well."
+}