summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-03-08 16:56:28 +0000
committerJustin Lecher <jlec@gentoo.org>2012-03-08 16:56:28 +0000
commit6cf5bba5ffef2dae9a6995e69ba037b6f8dce772 (patch)
tree5745c66007348ae0ce8179972d7bf9931fefa892 /x11-libs
parentAdd sys-apps/whdd, thanks to Andrey Utkin <andrey.krieger.utkin@gmail.com> (diff)
downloadgentoo-2-6cf5bba5ffef2dae9a6995e69ba037b6f8dce772.tar.gz
gentoo-2-6cf5bba5ffef2dae9a6995e69ba037b6f8dce772.tar.bz2
gentoo-2-6cf5bba5ffef2dae9a6995e69ba037b6f8dce772.zip
Add fix for qt4.8, #407385; move to EAPI=4 and qt4-r2.eclass
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qwtplot3d/ChangeLog10
-rw-r--r--x11-libs/qwtplot3d/files/qwtplot3d-qt48.patch19
-rw-r--r--x11-libs/qwtplot3d/metadata.xml4
-rw-r--r--x11-libs/qwtplot3d/qwtplot3d-0.2.7-r2.ebuild60
4 files changed, 89 insertions, 4 deletions
diff --git a/x11-libs/qwtplot3d/ChangeLog b/x11-libs/qwtplot3d/ChangeLog
index 7bca38de5747..6efafc223b97 100644
--- a/x11-libs/qwtplot3d/ChangeLog
+++ b/x11-libs/qwtplot3d/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qwtplot3d
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwtplot3d/ChangeLog,v 1.22 2011/07/20 16:09:40 pacho Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwtplot3d/ChangeLog,v 1.23 2012/03/08 16:56:28 jlec Exp $
+
+*qwtplot3d-0.2.7-r2 (08 Mar 2012)
+
+ 08 Mar 2012; Justin Lecher <jlec@gentoo.org> +files/qwtplot3d-qt48.patch,
+ +qwtplot3d-0.2.7-r2.ebuild, metadata.xml:
+ Add fix for qt4.8, #407385; move to EAPI=4 and qt4-r2.eclass
20 Jul 2011; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, bug #70723
diff --git a/x11-libs/qwtplot3d/files/qwtplot3d-qt48.patch b/x11-libs/qwtplot3d/files/qwtplot3d-qt48.patch
new file mode 100644
index 000000000000..4e558eda7c96
--- /dev/null
+++ b/x11-libs/qwtplot3d/files/qwtplot3d-qt48.patch
@@ -0,0 +1,19 @@
+ include/qwt3d_openglhelper.h | 5 +++++
+ 1 files changed, 5 insertions(+), 0 deletions(-)
+
+diff --git a/include/qwt3d_openglhelper.h b/include/qwt3d_openglhelper.h
+index e5499c2..a7ecddc 100644
+--- a/include/qwt3d_openglhelper.h
++++ b/include/qwt3d_openglhelper.h
+@@ -8,6 +8,11 @@
+ #include <QtOpenGL/qgl.h>
+ #endif
+
++#if QT_VERSION < 0x047999
++#include <GL/glu.h>
++#endif
++
++
+ namespace Qwt3D
+ {
+
diff --git a/x11-libs/qwtplot3d/metadata.xml b/x11-libs/qwtplot3d/metadata.xml
index b055177b6ece..6f8987dcdef7 100644
--- a/x11-libs/qwtplot3d/metadata.xml
+++ b/x11-libs/qwtplot3d/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <longdescription>
+ <herd>sci</herd>
+ <longdescription>
QwtPlot3D isa feature-rich Qt/OpenGL-based C++ programming library,
providing essentially a bunch of 3D-widgets for programmers.
</longdescription>
diff --git a/x11-libs/qwtplot3d/qwtplot3d-0.2.7-r2.ebuild b/x11-libs/qwtplot3d/qwtplot3d-0.2.7-r2.ebuild
new file mode 100644
index 000000000000..3fdba4685646
--- /dev/null
+++ b/x11-libs/qwtplot3d/qwtplot3d-0.2.7-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwtplot3d/qwtplot3d-0.2.7-r2.ebuild,v 1.1 2012/03/08 16:56:28 jlec Exp $
+
+EAPI=4
+
+inherit qt4-r2
+
+DESCRIPTION="Qt4/OpenGL-based 3D widget library for C++"
+HOMEPAGE="http://qwtplot3d.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="ZLIB"
+SLOT="0"
+IUSE="doc examples"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="x11-libs/qt-gui:4
+ x11-libs/qt-opengl:4
+ x11-libs/gl2ps"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+S=${WORKDIR}/${PN}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-profile.patch
+ "${FILESDIR}"/${PN}-examples.patch
+ "${FILESDIR}"/${PN}-doxygen.patch
+ "${FILESDIR}"/${PN}-sys-gl2ps.patch
+ "${FILESDIR}"/${PN}-gcc44.patch
+ "${FILESDIR}"/${PN}-qt48.patch
+ )
+
+src_prepare() {
+ qt4-r2_src_prepare
+ cat >> ${PN}.pro <<-EOF
+ target.path = /usr/$(get_libdir)
+ headers.path = /usr/include/${PN}
+ headers.files = \$\$HEADERS
+ INSTALLS = target headers
+ EOF
+}
+
+src_compile() {
+ qt4-r2_src_compile
+ if use doc ; then
+ cd doc
+ doxygen Doxyfile.doxygen || die "doxygen failed"
+ fi
+}
+
+src_install () {
+ qt4-r2_src_install
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r examples
+ fi
+ use doc && dohtml -r doc/web/doxygen/*
+}