summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-07-01 21:11:52 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-07-01 21:11:52 +0000
commit3e88fd4feef6ab415504a39d00705bb948355ea0 (patch)
treecd62b5237d824c3e82521e58b273e414f4dfe887 /x11-libs
parentVersion bump, wrt security bug #322857. (diff)
downloadgentoo-2-3e88fd4feef6ab415504a39d00705bb948355ea0.tar.gz
gentoo-2-3e88fd4feef6ab415504a39d00705bb948355ea0.tar.bz2
gentoo-2-3e88fd4feef6ab415504a39d00705bb948355ea0.zip
Revbump to fix firebird linking wrt bug #326473
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-sql/ChangeLog8
-rw-r--r--x11-libs/qt-sql/qt-sql-4.6.3-r2.ebuild74
2 files changed, 81 insertions, 1 deletions
diff --git a/x11-libs/qt-sql/ChangeLog b/x11-libs/qt-sql/ChangeLog
index 38e558c83b84..f849657d47ec 100644
--- a/x11-libs/qt-sql/ChangeLog
+++ b/x11-libs/qt-sql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-sql
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/ChangeLog,v 1.84 2010/06/24 17:37:18 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/ChangeLog,v 1.85 2010/07/01 21:11:52 hwoarang Exp $
+
+*qt-sql-4.6.3-r2 (01 Jul 2010)
+
+ 01 Jul 2010; Markos Chandras <hwoarang@gentoo.org>
+ +qt-sql-4.6.3-r2.ebuild:
+ Revbump to fix firebird linking wrt bug #326473
24 Jun 2010; Markos Chandras <hwoarang@gentoo.org> -qt-sql-4.6.1.ebuild:
Drop Qt-4.6.1
diff --git a/x11-libs/qt-sql/qt-sql-4.6.3-r2.ebuild b/x11-libs/qt-sql/qt-sql-4.6.3-r2.ebuild
new file mode 100644
index 000000000000..218f544b1dba
--- /dev/null
+++ b/x11-libs/qt-sql/qt-sql-4.6.3-r2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/qt-sql-4.6.3-r2.ebuild,v 1.1 2010/07/01 21:11:52 hwoarang Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The SQL module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="firebird freetds iconv mysql odbc postgres qt3support +sqlite"
+
+DEPEND="~x11-libs/qt-core-${PV}[aqua=,debug=,qt3support=]
+ firebird? ( dev-db/firebird )
+ freetds? ( dev-db/freetds )
+ mysql? ( virtual/mysql )
+ odbc? ( dev-db/unixODBC )
+ postgres? ( dev-db/postgresql-base )
+ sqlite? ( dev-db/sqlite:3 )"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/sql src/plugins/sqldrivers"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/Qt/
+include/QtCore/
+include/QtSql/
+include/QtScript/
+src/src.pro
+src/corelib/
+src/plugins
+src/3rdparty
+src/tools"
+
+PATCHES=(
+ "${FILESDIR}/qt-4.6-nolibx11.patch"
+)
+
+pkg_setup() {
+ if ! (use firebird || use freetds || use mysql || use odbc || use postgres || use sqlite ); then
+ ewarn "You need to enable at least one SQL driver. Enable at least"
+ ewarn "one of these USE flags: \"firebird freetds mysql odbc postgres sqlite \""
+ die "Enable at least one SQL driver."
+ fi
+
+ qt4-build_pkg_setup
+}
+
+src_prepare() {
+ qt4-build_src_prepare
+
+ sed -e '/pg_config --libs/d' -i "${S}"/configure \
+ || die "sed to fix postgresql usage in ./configure failed"
+}
+
+src_configure() {
+ # Don't support sqlite2 anymore
+ myconf="${myconf} -no-sql-sqlite2
+ $(qt_use mysql sql-mysql plugin) $(use mysql && echo "-I${EPREFIX}/usr/include/mysql -L${EPREFIX}/usr/$(get_libdir)/mysql ")
+ $(qt_use postgres sql-psql plugin) $(use postgres && echo "-I${EPREFIX}/usr/include/postgresql/pgsql ")
+ $(qt_use sqlite sql-sqlite plugin) $(use sqlite && echo '-system-sqlite')
+ $(qt_use odbc sql-odbc plugin)
+ $(qt_use freetds sql-tds plugin)
+ $(qt_use firebird sql-ibase plugin)
+ $(qt_use qt3support)"
+
+ myconf="${myconf} $(qt_use iconv) -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility -no-fontconfig
+ -no-glib -no-opengl -no-svg -no-gtkstyle"
+
+ qt4-build_src_configure
+}