summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-05-22 15:26:40 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-05-22 15:26:40 +0000
commit2e13ae72ed671eb4ea519e698fd0f87f168c745e (patch)
tree0c78151055293d29d7735bf565003bf34a32acfe /x11-libs
parentRemove stray comment, thanks to johu for noticing that. (diff)
downloadgentoo-2-2e13ae72ed671eb4ea519e698fd0f87f168c745e.tar.gz
gentoo-2-2e13ae72ed671eb4ea519e698fd0f87f168c745e.tar.bz2
gentoo-2-2e13ae72ed671eb4ea519e698fd0f87f168c745e.zip
Version bump.
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-svg/ChangeLog7
-rw-r--r--x11-libs/qt-svg/qt-svg-4.8.2.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/x11-libs/qt-svg/ChangeLog b/x11-libs/qt-svg/ChangeLog
index 2067fb7769ac..00303e345611 100644
--- a/x11-libs/qt-svg/ChangeLog
+++ b/x11-libs/qt-svg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-svg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.109 2012/05/20 13:18:34 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.110 2012/05/22 15:26:40 pesa Exp $
+
+*qt-svg-4.8.2 (22 May 2012)
+
+ 22 May 2012; Davide Pesavento <pesa@gentoo.org> +qt-svg-4.8.2.ebuild:
+ Version bump.
20 May 2012; Agostino Sarubbo <ago@gentoo.org> qt-svg-4.8.1.ebuild:
Stable for x86, wrt bug #414241
diff --git a/x11-libs/qt-svg/qt-svg-4.8.2.ebuild b/x11-libs/qt-svg/qt-svg-4.8.2.ebuild
new file mode 100644
index 000000000000..9d142a5c59e6
--- /dev/null
+++ b/x11-libs/qt-svg/qt-svg-4.8.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/qt-svg-4.8.2.ebuild,v 1.1 2012/05/22 15:26:40 pesa Exp $
+
+EAPI=4
+
+inherit qt4-build
+
+DESCRIPTION="The SVG module for the Qt toolkit"
+SLOT="4"
+if [[ ${QT4_BUILD_TYPE} == live ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+fi
+IUSE="+accessibility"
+
+DEPEND="
+ sys-libs/zlib
+ ~x11-libs/qt-core-${PV}[aqua=,c++0x=,debug=,qpa=]
+ ~x11-libs/qt-gui-${PV}[accessibility=,aqua=,c++0x=,debug=,qpa=]
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/svg
+ src/plugins/imageformats/svg
+ src/plugins/iconengines/svgiconengine"
+
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ include/QtSvg
+ include/Qt
+ include/QtGui
+ include/QtCore
+ include/QtXml
+ src/corelib
+ src/gui
+ src/plugins
+ src/xml
+ src/3rdparty"
+
+ QCONFIG_ADD="svg"
+ QCONFIG_DEFINE="QT_SVG"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf+="
+ -svg
+ $(qt_use accessibility)
+ -no-xkb -no-xrender
+ -no-xrandr -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm
+ -no-opengl -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff
+ -no-fontconfig -no-glib -no-gtkstyle"
+
+ qt4-build_src_configure
+}