summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-05-27 14:59:14 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-05-27 14:59:14 +0000
commit04b8ff87e53938bc37a19233b67acaaf1ded35b5 (patch)
treed309bd2a84783d1ddf093417b3b6fd35748ed9c5 /x11-libs
parentbumping to 1.5.1.2, keywording for all arches, removing from package.mask (diff)
downloadgentoo-2-04b8ff87e53938bc37a19233b67acaaf1ded35b5.tar.gz
gentoo-2-04b8ff87e53938bc37a19233b67acaaf1ded35b5.tar.bz2
gentoo-2-04b8ff87e53938bc37a19233b67acaaf1ded35b5.zip
Added patch to allow compilation of qt on non-linux systems (specifically Gentoo/FreeBSD).
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt/ChangeLog6
-rw-r--r--x11-libs/qt/qt-3.3.4-r4.ebuild43
2 files changed, 34 insertions, 15 deletions
diff --git a/x11-libs/qt/ChangeLog b/x11-libs/qt/ChangeLog
index 1453b73d28af..9b010c81b3e3 100644
--- a/x11-libs/qt/ChangeLog
+++ b/x11-libs/qt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.218 2005/05/27 13:51:10 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.219 2005/05/27 14:59:14 flameeyes Exp $
+
+ 27 May 2005; Diego Pettenò <flameeyes@gentoo.org> qt-3.3.4-r4.ebuild:
+ Added patch to allow compilation of qt on non-linux systems (specifically
+ Gentoo/FreeBSD).
*qt-3.3.4-r4 (27 May 2005)
diff --git a/x11-libs/qt/qt-3.3.4-r4.ebuild b/x11-libs/qt/qt-3.3.4-r4.ebuild
index a3ff85b862d6..73b791f48989 100644
--- a/x11-libs/qt/qt-3.3.4-r4.ebuild
+++ b/x11-libs/qt/qt-3.3.4-r4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.3.4-r4.ebuild,v 1.1 2005/05/27 13:51:10 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.3.4-r4.ebuild,v 1.2 2005/05/27 14:59:14 flameeyes Exp $
-inherit eutils flag-o-matic
+inherit eutils flag-o-matic toolchain-funcs
SRCTYPE="free"
DESCRIPTION="QT version ${PV}"
@@ -49,15 +49,30 @@ pkg_setup() {
export QTDIR=${S}
- if useq ppc-macos ; then
- export PLATFORM=darwin-g++
- export DYLD_LIBRARY_PATH="${QTDIR}/lib:/usr/X11R6/lib:${DYLD_LIBRARY_PATH}"
- export INSTALL_ROOT=""
- else
- # probably this should be 'linux-g++-64' for 64bit archs
- # in a fully multilib environment (no compatibility symlinks)
- export PLATFORM=linux-g++
+ PLATCXX="notsupported"
+ CXX=$(tc-getCXX)
+ if [[ ${CXX/g++/} != ${CXX} ]]; then
+ PLATCXX="g++"
+ elif [[ ${CXX/icc/} != ${CXX} ]]; then
+ PLATCXX="icc"
+ fi
+
+ PLATNAME="notsupported"
+ if use kernel_linux; then
+ PLATNAME="linux"
+ elif use kernel_FreeBSD && use elibc_FreeBSD; then
+ PLATNAME="freebsd"
+ elif use ppc-macos; then
+ PLATNAME=macx
+# export DYLD_LIBRARY_PATH="${QTDIR}/lib:/usr/X11R6/lib:${DYLD_LIBRARY_PATH}"
+# export INSTALL_ROOT=""
+ elif use kernel_Darwin && use elibc_Darwin; then
+ PLATNAME="darwin"
fi
+
+ # probably this should be '*-64' for 64bit archs
+ # in a fully multilib environment (no compatibility symlinks)
+ export PLATFORM="${PLATNAME}-${PLATCXX}"
}
src_unpack() {
@@ -65,8 +80,7 @@ src_unpack() {
cd ${S}
- cp configure configure.orig
- sed -e 's:read acceptance:acceptance=yes:' configure.orig > configure
+ sed -i -e 's:read acceptance:acceptance=yes:' configure
epatch ${FILESDIR}/qt-no-rpath-uic.patch
epatch ${FILESDIR}/qt-no-rpath.patch
@@ -287,9 +301,10 @@ src_install() {
sed -e "s:${S}:${QTBASE}:g" \
${S}/.qmake.cache > ${D}${QTBASE}/.qmake.cache
+ sed -i -e "s:linux-g++:${PLATFORM}:" ${D}/etc/env.d/45qt3
+
if use ppc-macos ; then
- dosed "s:linux-g++:${PLATFORM}:" /etc/env.d/45qt3 \
- "s:\$(QTBASE):\$(QTDIR):g" ${QTBASE}/mkspecs/${PLATFORM}/qmake.conf \
+ dosed "s:\$(QTBASE):\$(QTDIR):g" ${QTBASE}/mkspecs/${PLATFORM}/qmake.conf \
"s:${S}:${QTBASE}:g" ${QTBASE}/mkspecs/${PLATFORM}/qmake.conf ${QTBASE}/lib/libqt-mt.la || die
fi