summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-10-01 20:13:14 +0000
committerBen de Groot <yngwin@gentoo.org>2008-10-01 20:13:14 +0000
commit00f9841be892b74b6a7c6dd987286760891256b9 (patch)
tree67627d76023bd49b1965e598d45226b86d5c3d75 /x11-libs
parentVersion bump. (diff)
downloadgentoo-2-00f9841be892b74b6a7c6dd987286760891256b9.tar.gz
gentoo-2-00f9841be892b74b6a7c6dd987286760891256b9.tar.bz2
gentoo-2-00f9841be892b74b6a7c6dd987286760891256b9.zip
Adding webkit support and useflag, using patch supplied by Manuel Nickschas in bug 237055.
(Portage version: 2.2_rc11/cvs/Linux 2.6.26.5 i686)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-assistant/ChangeLog7
-rw-r--r--x11-libs/qt-assistant/metadata.xml8
-rw-r--r--x11-libs/qt-assistant/qt-assistant-4.4.1.ebuild17
-rw-r--r--x11-libs/qt-assistant/qt-assistant-4.4.2.ebuild17
4 files changed, 35 insertions, 14 deletions
diff --git a/x11-libs/qt-assistant/ChangeLog b/x11-libs/qt-assistant/ChangeLog
index ace17bd2fb76..db2b63d77f28 100644
--- a/x11-libs/qt-assistant/ChangeLog
+++ b/x11-libs/qt-assistant/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-assistant
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.14 2008/09/19 00:09:10 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.15 2008/10/01 20:13:13 yngwin Exp $
+
+ 01 Oct 2008; Ben de Groot <yngwin@gentoo.org> metadata.xml,
+ qt-assistant-4.4.1.ebuild, qt-assistant-4.4.2.ebuild:
+ Adding webkit support and useflag, using patch supplied by Manuel
+ Nickschas in bug 237055.
*qt-assistant-4.4.2 (18 Sep 2008)
diff --git a/x11-libs/qt-assistant/metadata.xml b/x11-libs/qt-assistant/metadata.xml
index 01a5c2875e0d..1f3569cb838d 100644
--- a/x11-libs/qt-assistant/metadata.xml
+++ b/x11-libs/qt-assistant/metadata.xml
@@ -1,5 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>qt</herd>
+ <herd>qt</herd>
+ <use>
+ <flag name='webkit'>
+ Enable <pkg>x11-libs/qt-webkit</pkg> support, for more
+ sophisticated online help display using webkit’s HTML renderer.
+ </flag>
+ </use>
</pkgmetadata>
diff --git a/x11-libs/qt-assistant/qt-assistant-4.4.1.ebuild b/x11-libs/qt-assistant/qt-assistant-4.4.1.ebuild
index b63180a84c8b..9f2630a73e67 100644
--- a/x11-libs/qt-assistant/qt-assistant-4.4.1.ebuild
+++ b/x11-libs/qt-assistant/qt-assistant-4.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.4.1.ebuild,v 1.1 2008/08/11 12:56:22 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.4.1.ebuild,v 1.2 2008/10/01 20:13:13 yngwin Exp $
EAPI="1"
inherit qt4-build
@@ -11,10 +11,11 @@ HOMEPAGE="http://www.trolltech.com/"
LICENSE="|| ( GPL-3 GPL-2 )"
SLOT="4"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
+IUSE="webkit"
DEPEND="~x11-libs/qt-gui-${PV}
~x11-libs/qt-sql-${PV}
+ !alpha? ( !ia64? ( !ppc? ( webkit? ( ~x11-libs/qt-webkit-${PV} ) ) ) )
!<=x11-libs/qt-4.4.0_alpha:${SLOT}"
RDEPEND="${DEPEND}"
@@ -36,13 +37,17 @@ pkg_setup() {
src_compile() {
local myconf
-
myconf="${myconf} -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
-no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
-no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
- -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
- -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility -no-fontconfig
- -no-glib -no-opengl -no-qt3support -no-svg"
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-phonon
+ -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-glib -no-opengl -no-qt3support -no-svg"
+ if use webkit; then
+ myconf="$myconf -assistant-webkit"
+ else
+ myconf="$myconf -no-webkit"
+ fi
qt4-build_src_compile
}
diff --git a/x11-libs/qt-assistant/qt-assistant-4.4.2.ebuild b/x11-libs/qt-assistant/qt-assistant-4.4.2.ebuild
index aec305778c96..81eeac29f296 100644
--- a/x11-libs/qt-assistant/qt-assistant-4.4.2.ebuild
+++ b/x11-libs/qt-assistant/qt-assistant-4.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.4.2.ebuild,v 1.1 2008/09/19 00:09:10 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.4.2.ebuild,v 1.2 2008/10/01 20:13:13 yngwin Exp $
EAPI="1"
inherit qt4-build
@@ -11,10 +11,11 @@ HOMEPAGE="http://www.trolltech.com/"
LICENSE="|| ( GPL-3 GPL-2 )"
SLOT="4"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
+IUSE="+webkit"
DEPEND="~x11-libs/qt-gui-${PV}
~x11-libs/qt-sql-${PV}
+ !alpha? ( !ia64? ( !ppc? ( webkit? ( ~x11-libs/qt-webkit-${PV} ) ) ) )
!<=x11-libs/qt-4.4.0_alpha:${SLOT}"
RDEPEND="${DEPEND}"
@@ -36,13 +37,17 @@ pkg_setup() {
src_compile() {
local myconf
-
myconf="${myconf} -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
-no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
-no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
- -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
- -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility -no-fontconfig
- -no-glib -no-opengl -no-qt3support -no-svg"
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-phonon
+ -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-glib -no-opengl -no-qt3support -no-svg"
+ if use webkit; then
+ myconf="$myconf -assistant-webkit"
+ else
+ myconf="$myconf -no-webkit"
+ fi
qt4-build_src_compile
}