summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-12-18 15:00:47 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-12-18 15:00:47 +0000
commit628e24e75f46a9c81a08f0908c32cde0697b9c07 (patch)
tree23b0d9081fd727325d0807f48095ea58f40431e9 /x11-libs/wxGTK
parentChanged econf||die to econf (diff)
downloadgentoo-2-628e24e75f46a9c81a08f0908c32cde0697b9c07.tar.gz
gentoo-2-628e24e75f46a9c81a08f0908c32cde0697b9c07.tar.bz2
gentoo-2-628e24e75f46a9c81a08f0908c32cde0697b9c07.zip
resurrected the old version, as it is required for audacity
Diffstat (limited to 'x11-libs/wxGTK')
-rw-r--r--x11-libs/wxGTK/ChangeLog15
-rw-r--r--x11-libs/wxGTK/files/digest-wxGTK-2.2.9-r11
-rw-r--r--x11-libs/wxGTK/wxGTK-2.2.9-r1.ebuild91
3 files changed, 104 insertions, 3 deletions
diff --git a/x11-libs/wxGTK/ChangeLog b/x11-libs/wxGTK/ChangeLog
index 5ad396d50dbf..8a0b86e4bbcc 100644
--- a/x11-libs/wxGTK/ChangeLog
+++ b/x11-libs/wxGTK/ChangeLog
@@ -1,11 +1,20 @@
# ChangeLog for x11-libs/wxGTK
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.17 2002/12/13 11:00:51 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.18 2002/12/18 15:00:47 seemant Exp $
+
+
+*wxGTK-2.2.9-r1 (18 Dec 2002)
+
+ 18 Dec 2002; Seemant Kulleen <seemant@gentoo.org> wxGTK-2.2.9-r1.ebuild
+ files/digest-wxGTK-2.2.9-r1 :
+
+ This version is REQUIRED for audacity. If you are NOT the audacity or
+ wxGTK maintainer, please do NOT touch these files.
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-
*wxGTK-2.3.3 (26 Oct 2002)
+ 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+
05 Dec 2002; Mike Frysinger <vapier@gentoo.org>
It would seem optional zlib support isnt optional ;)
diff --git a/x11-libs/wxGTK/files/digest-wxGTK-2.2.9-r1 b/x11-libs/wxGTK/files/digest-wxGTK-2.2.9-r1
new file mode 100644
index 000000000000..176a5207dbac
--- /dev/null
+++ b/x11-libs/wxGTK/files/digest-wxGTK-2.2.9-r1
@@ -0,0 +1 @@
+MD5 f9bf738050fca93e33a65081b1c55905 wxGTK-2.2.9.tar.bz2 3829283
diff --git a/x11-libs/wxGTK/wxGTK-2.2.9-r1.ebuild b/x11-libs/wxGTK/wxGTK-2.2.9-r1.ebuild
new file mode 100644
index 000000000000..452032a2c176
--- /dev/null
+++ b/x11-libs/wxGTK/wxGTK-2.2.9-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.2.9-r1.ebuild,v 1.8 2002/12/18 15:00:47 seemant Exp $
+
+IUSE="gif nls odbc opengl"
+
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="GTK+ version of wxWindows, a cross-platform C++ GUI toolkit."
+
+SRC_URI="mirror://sourceforge/wxwindows/${P}.tar.bz2"
+
+HOMEPAGE="http://www.wxwindows.org/"
+
+LICENSE="GPL"
+
+SLOT="0"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ dev-libs/libunicode
+ media-libs/libpng
+ media-libs/jpeg
+ media-libs/tiff
+ media-libs/netpbm
+ nls? ( sys-devel/gettext )
+ odbc? ( dev-db/unixODBC )
+ gif? ( media-libs/giflib )
+ opengl? ( virtual/opengl )"
+
+#Possible future dependancies
+# motif? ( x11-libs/openmotif )
+# ungif? ( media-libs/libungif )
+
+
+KEYWORDS="x86 -ppc -sparc "
+
+src_compile() {
+
+
+ #cp configure.in configure.in.orig
+ #sed '1610i\ /usr/include/freetype2 \\' configure.in.orig > configure.in
+
+
+ local myconf
+ #--with-gtk enabled by default, if you want to build against motif,
+ #replace --with-gtk with --with-motif and --without-gtk. You will
+ #also need openmotif installed. Unfortunately, the package build tools
+ #only support installation of one currently.
+
+ myconf="--with-gtk"
+
+ #Build static library too, shared library is enabled by default.
+ #Enable useful config options that don't have USE flags
+ myconf="$myconf --enable-static --with-zlib --with-unicode"
+
+ #Note: png,jpeg,tiff,pnm, and pcx image support enabled by default if found.
+ #Also, all wxWindows gui features are enabled by default. If you
+ #want to build a smaller library you can disable features by adding
+ #the appropriate flags to myconf (see INSTALL.txt).
+
+ #The build tools include a --with-freetype option, however it doesn't
+ #seem to be implemented in the source yet.
+
+ #configure options that have corresponding USE variable.
+
+ use odbc && myconf="$myconf --with-odbc" #disabled by default
+ use gif || myconf="$myconf --disable-gif" #enabled by default
+ use opengl && myconf="$myconf --with-opengl" #disabled by default
+
+ #apply the patch to get compiled with GCC-3.1
+ gunzip < ${FILESDIR}/${P}.diff.gz | patch -p1
+
+ CFLAGS="${CFLAGS} -DZEXPORT=''"
+ CXXFLAGS="${CXXFLAGS} -DZEXPORT=''"
+
+ econf ${myconf} || die "configuration failed"
+
+ make || die "compilation failed"
+
+}
+
+src_install () {
+
+ einstall || die "installation failed"
+
+ dodoc CHANGES.txt COPYING.LIB INSTALL.txt \
+ LICENCE.txt README.txt SYMBOLS.txt TODO.txt
+
+}
+