summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2007-12-22 15:55:38 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2007-12-22 15:55:38 +0000
commit7f1f2279714bda88aaff8fabba0bfec9906f077a (patch)
tree0627b8f90c3863a0076264db20c06f68e8f15cf1 /x11-libs/vte
parentBump to 20070815 (diff)
downloadgentoo-2-7f1f2279714bda88aaff8fabba0bfec9906f077a.tar.gz
gentoo-2-7f1f2279714bda88aaff8fabba0bfec9906f077a.tar.bz2
gentoo-2-7f1f2279714bda88aaff8fabba0bfec9906f077a.zip
bump to 0.16.11
(Portage version: 2.1.4_rc10)
Diffstat (limited to 'x11-libs/vte')
-rw-r--r--x11-libs/vte/ChangeLog7
-rw-r--r--x11-libs/vte/files/digest-vte-0.16.113
-rw-r--r--x11-libs/vte/vte-0.16.11.ebuild68
3 files changed, 77 insertions, 1 deletions
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index b40e97193a29..064c7bdf9ab9 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/vte
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.187 2007/12/05 22:34:33 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.188 2007/12/22 15:55:37 eva Exp $
+
+*vte-0.16.11 (22 Dec 2007)
+
+ 22 Dec 2007; Gilles Dartiguelongue <eva@gentoo.org> +vte-0.16.11.ebuild:
+ bump to 0.16.11
*vte-0.16.10 (05 Dec 2007)
diff --git a/x11-libs/vte/files/digest-vte-0.16.11 b/x11-libs/vte/files/digest-vte-0.16.11
new file mode 100644
index 000000000000..c8982317f13f
--- /dev/null
+++ b/x11-libs/vte/files/digest-vte-0.16.11
@@ -0,0 +1,3 @@
+MD5 61deb2386eeadc4ba6f1a8b5190d45bd vte-0.16.11.tar.bz2 1113624
+RMD160 61392e201efe3ef2f1c3a96df84dc4ce8dfeb865 vte-0.16.11.tar.bz2 1113624
+SHA256 27af11a28edebdb13a641d7a1c04fc427fba83c6141aa42566a7ec35cf7d3434 vte-0.16.11.tar.bz2 1113624
diff --git a/x11-libs/vte/vte-0.16.11.ebuild b/x11-libs/vte/vte-0.16.11.ebuild
new file mode 100644
index 000000000000..eb902e0cbd91
--- /dev/null
+++ b/x11-libs/vte/vte-0.16.11.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.16.11.ebuild,v 1.1 2007/12/22 15:55:37 eva Exp $
+
+inherit eutils gnome2 autotools python
+
+DESCRIPTION="Gnome terminal widget"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+# pcre is broken in this release
+IUSE="debug doc python opengl"
+
+RDEPEND=">=dev-libs/glib-2.9
+ >=x11-libs/gtk+-2.6
+ >=x11-libs/pango-1.1
+ >=media-libs/freetype-2.0.2
+ media-libs/fontconfig
+ sys-libs/ncurses
+ opengl? (
+ virtual/opengl
+ virtual/glu
+ )
+ python? (
+ >=dev-python/pygtk-2.4
+ >=dev-lang/python-2.4.4-r5
+ )
+ x11-libs/libX11
+ virtual/xft"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.0 )
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ sys-devel/gettext"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable debug) $(use_enable python)
+ $(use_with opengl glX) --with-xft2 --with-pangox"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ epatch "${FILESDIR}/${PN}-0.13.2-no-lazy-bindings.patch"
+ cd "${S}/gnome-pty-helper"
+
+ # eautoreconf will break on systems without gtk-doc
+ eautomake
+}
+
+pkg_postinst() {
+ if use python; then
+ python_version
+ python_mod_optimize "${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0"
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_version
+ python_mod_cleanup "${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0"
+ fi
+}