summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-03-12 23:46:01 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-03-12 23:46:01 +0000
commit627a1b542f393dae23f50d1b982e7f9b34aee0d4 (patch)
treee9d0b516ca56839662b4404aed1528211b076ceb /x11-libs/vte
parentwork around more unnecessary configure checking for dedicated (bug #213159) (diff)
downloadgentoo-2-627a1b542f393dae23f50d1b982e7f9b34aee0d4.tar.gz
gentoo-2-627a1b542f393dae23f50d1b982e7f9b34aee0d4.tar.bz2
gentoo-2-627a1b542f393dae23f50d1b982e7f9b34aee0d4.zip
bump to 0.16.13
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-libs/vte')
-rw-r--r--x11-libs/vte/ChangeLog7
-rw-r--r--x11-libs/vte/vte-0.16.13.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index eefc8ec84afd..c94fec8173f9 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/vte
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.194 2008/02/04 04:21:51 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.195 2008/03/12 23:46:01 eva Exp $
+
+*vte-0.16.13 (12 Mar 2008)
+
+ 12 Mar 2008; Gilles Dartiguelongue <eva@gentoo.org> +vte-0.16.13.ebuild:
+ bump to 0.16.13, removed useless python inherit and pkg_{postrm,postinst}
04 Feb 2008; Jeroen Roovers <jer@gentoo.org> vte-0.16.12.ebuild:
Stable for HPPA (bug #208366).
diff --git a/x11-libs/vte/vte-0.16.13.ebuild b/x11-libs/vte/vte-0.16.13.ebuild
new file mode 100644
index 000000000000..14ff69b95922
--- /dev/null
+++ b/x11-libs/vte/vte-0.16.13.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.16.13.ebuild,v 1.1 2008/03/12 23:46:01 eva Exp $
+
+inherit eutils gnome2 autotools
+
+DESCRIPTION="Gnome terminal widget"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+# pcre is broken in this release
+IUSE="debug doc python opengl"
+
+RDEPEND=">=dev-libs/glib-2.9
+ >=x11-libs/gtk+-2.6
+ >=x11-libs/pango-1.1
+ >=media-libs/freetype-2.0.2
+ media-libs/fontconfig
+ sys-libs/ncurses
+ opengl? (
+ virtual/opengl
+ virtual/glu
+ )
+ python? (
+ >=dev-python/pygtk-2.4
+ >=dev-lang/python-2.4.4-r5
+ )
+ x11-libs/libX11
+ virtual/xft"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.0 )
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ sys-devel/gettext"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable debug) $(use_enable python)
+ $(use_with opengl glX) --with-xft2 --with-pangox"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ epatch "${FILESDIR}/${PN}-0.13.2-no-lazy-bindings.patch"
+ cd "${S}/gnome-pty-helper"
+
+ # eautoreconf will break on systems without gtk-doc
+ eautomake
+}