summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-06-08 12:20:47 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-06-08 12:20:47 +0000
commit4a59d2c4a197026e9821c319e0aa20a0458e33ec (patch)
treed82b007dbe1da70b79e7c4250908f97dd50712c8 /x11-libs/qt-script
parentQt release version bump (diff)
downloadgentoo-2-4a59d2c4a197026e9821c319e0aa20a0458e33ec.tar.gz
gentoo-2-4a59d2c4a197026e9821c319e0aa20a0458e33ec.tar.bz2
gentoo-2-4a59d2c4a197026e9821c319e0aa20a0458e33ec.zip
Qt release version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-script')
-rw-r--r--x11-libs/qt-script/ChangeLog8
-rw-r--r--x11-libs/qt-script/qt-script-4.6.3.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/x11-libs/qt-script/ChangeLog b/x11-libs/qt-script/ChangeLog
index 8e9bd7928774..b378984600b6 100644
--- a/x11-libs/qt-script/ChangeLog
+++ b/x11-libs/qt-script/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-script
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.67 2010/05/22 09:31:49 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.68 2010/06/08 12:20:47 hwoarang Exp $
+
+*qt-script-4.6.3 (08 Jun 2010)
+
+ 08 Jun 2010; Markos Chandras <hwoarang@gentoo.org>
+ +qt-script-4.6.3.ebuild:
+ Version bump
22 May 2010; Raúl Porcel <armin76@gentoo.org> qt-script-4.6.2.ebuild,
+files/qt-script-4.6.2-alpha.patch:
diff --git a/x11-libs/qt-script/qt-script-4.6.3.ebuild b/x11-libs/qt-script/qt-script-4.6.3.ebuild
new file mode 100644
index 000000000000..88c45b395120
--- /dev/null
+++ b/x11-libs/qt-script/qt-script-4.6.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/qt-script-4.6.3.ebuild,v 1.1 2010/06/08 12:20:47 hwoarang Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The ECMAScript module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="iconv"
+
+DEPEND="~x11-libs/qt-core-${PV}[aqua=,debug=]"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/script/"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/Qt/
+include/QtCore/
+include/QtScript/
+src/corelib/
+src/3rdparty/javascriptcore/
+"
+
+PATCHES=(
+ "${FILESDIR}/qt-4.6-nolibx11.patch"
+)
+
+src_configure() {
+ myconf="${myconf} $(qt_use iconv) -script -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-glib -no-opengl -no-svg -no-gtkstyle"
+ qt4-build_src_configure
+}