summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2009-12-01 14:52:23 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2009-12-01 14:52:23 +0000
commit4d786d1cd10def5f56b2128769d30bf34364a45d (patch)
tree7ea0fe3e8123699b13bbbca9f0f025c2e41c15c2 /x11-libs/qt-opengl
parentVersion bump to 4.6.0 (diff)
downloadgentoo-2-4d786d1cd10def5f56b2128769d30bf34364a45d.tar.gz
gentoo-2-4d786d1cd10def5f56b2128769d30bf34364a45d.tar.bz2
gentoo-2-4d786d1cd10def5f56b2128769d30bf34364a45d.zip
Version bump to 4.6.0
(Portage version: 2.2_rc54/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-opengl')
-rw-r--r--x11-libs/qt-opengl/ChangeLog8
-rw-r--r--x11-libs/qt-opengl/qt-opengl-4.6.0.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/x11-libs/qt-opengl/ChangeLog b/x11-libs/qt-opengl/ChangeLog
index 86e8980aaee8..1ce463cc70cf 100644
--- a/x11-libs/qt-opengl/ChangeLog
+++ b/x11-libs/qt-opengl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-opengl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/ChangeLog,v 1.53 2009/11/18 20:51:11 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/ChangeLog,v 1.54 2009/12/01 14:52:23 tampakrap Exp $
+
+*qt-opengl-4.6.0 (01 Dec 2009)
+
+ 01 Dec 2009; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-opengl-4.6.0.ebuild:
+ Version Bump to 4.6.0
*qt-opengl-4.6.0_rc1 (18 Nov 2009)
diff --git a/x11-libs/qt-opengl/qt-opengl-4.6.0.ebuild b/x11-libs/qt-opengl/qt-opengl-4.6.0.ebuild
new file mode 100644
index 000000000000..80be1427f9f0
--- /dev/null
+++ b/x11-libs/qt-opengl/qt-opengl-4.6.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/qt-opengl-4.6.0.ebuild,v 1.1 2009/12/01 14:52:23 tampakrap Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The OpenGL module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="qt3support"
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=,qt3support=]
+ ~x11-libs/qt-gui-${PV}[debug=,qt3support=]
+ virtual/opengl
+ virtual/glu"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="
+src/opengl
+src/plugins/graphicssystems/opengl"
+
+QT4_EXTRACT_DIRECTORIES="
+include/QtCore
+include/QtGui
+include/QtOpenGL
+src/corelib
+src/gui
+src/opengl
+src/plugins
+src/3rdparty"
+
+QCONFIG_ADD="opengl"
+QCONFIG_DEFINE="QT_OPENGL"
+
+src_configure() {
+ myconf="${myconf} -opengl
+ $(qt_use qt3support)"
+
+ qt4-build_src_configure
+
+ # Not building tools/designer/src/plugins/tools/view3d as it's
+ # commented out of the build in the source
+}