summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2005-08-15 19:22:56 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2005-08-15 19:22:56 +0000
commit4602b5a47da1b744ed718bd6a51c87e23d776409 (patch)
tree779b8cb2d319f25a0aa23e66a29c776d92246678 /x11-libs/pango
parentRemoving obsolete ebuilds. (diff)
downloadgentoo-2-4602b5a47da1b744ed718bd6a51c87e23d776409.tar.gz
gentoo-2-4602b5a47da1b744ed718bd6a51c87e23d776409.tar.bz2
gentoo-2-4602b5a47da1b744ed718bd6a51c87e23d776409.zip
Added patch to pango-1.9.1 to fix compilation with latest cairo.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'x11-libs/pango')
-rw-r--r--x11-libs/pango/ChangeLog6
-rw-r--r--x11-libs/pango/files/pango-1.9.1-example_update.patch127
-rw-r--r--x11-libs/pango/pango-1.9.1.ebuild7
3 files changed, 137 insertions, 3 deletions
diff --git a/x11-libs/pango/ChangeLog b/x11-libs/pango/ChangeLog
index 61356734bede..c72d1552ca82 100644
--- a/x11-libs/pango/ChangeLog
+++ b/x11-libs/pango/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/pango
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.101 2005/08/13 23:27:47 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.102 2005/08/15 19:22:56 leonardop Exp $
+
+ 15 Aug 2005; Leonardo Boshell <leonardop@gentoo.org>
+ +files/pango-1.9.1-example_update.patch, pango-1.9.1.ebuild:
+ Added patch from upstream's CVS to fix compilation with latest cairo.
13 Aug 2005; Michael Hanselmann <hansmi@gentoo.org> pango-1.8.1-r1.ebuild:
Stable on ppc.
diff --git a/x11-libs/pango/files/pango-1.9.1-example_update.patch b/x11-libs/pango/files/pango-1.9.1-example_update.patch
new file mode 100644
index 000000000000..7f4a62d00669
--- /dev/null
+++ b/x11-libs/pango/files/pango-1.9.1-example_update.patch
@@ -0,0 +1,127 @@
+diff -NurdB pango-1.9.1/examples/cairoview.c pango-1.9.1-patched/examples/cairoview.c
+--- pango-1.9.1/examples/cairoview.c 2005-07-26 08:44:07.000000000 -0500
++++ pango-1.9.1-patched/examples/cairoview.c 2005-08-15 14:05:15.000000000 -0500
+@@ -33,9 +33,8 @@
+
+ #include <pango/pangocairo.h>
+ #include <cairo-xlib.h>
+-#include <pixman.h>
+
+-static pixman_region16_t *update_region = NULL;
++static Region update_region = NULL;
+ static PangoContext *context;
+ static Display *display;
+ int screen;
+@@ -131,18 +130,14 @@
+ cairo_t *cr;
+ Pixmap pixmap;
+ GC gc;
+- pixman_box16_t *extents;
++ XRectangle extents;
+ int width, height;
+- int n_rects;
+- pixman_box16_t *rects;
+- XRectangle *xrects;
+- int i;
+
+ /* Create a temporary pixmap and a Cairo context pointing to it */
+- extents = pixman_region_extents (update_region);
++ XClipBox (update_region, &extents);
+
+- width = extents->x2 - extents->x1;
+- height = extents->y2 - extents->y1;
++ width = extents.width;
++ height = extents.height;
+
+ pixmap = XCreatePixmap (display, window, width, height,
+ DefaultDepth (display, screen));
+@@ -155,26 +150,13 @@
+ cr = render_data.cr = cairo_create (surface);
+ cairo_surface_destroy (surface);
+
+- render_data.x_offset = - extents->x1;
+- render_data.y_offset = - extents->y1;
++ render_data.x_offset = - extents.x;
++ render_data.y_offset = - extents.y;
+
+ do_cairo_transform (context, NULL, &render_data);
+
+ /* Clip to the current update region and fill with white */
+- n_rects = pixman_region_num_rects (update_region);
+- rects = pixman_region_rects (update_region);
+- xrects = g_new (XRectangle, n_rects);
+-
+- for (i = 0; i < n_rects; i++)
+- {
+- xrects[i].x = rects[i].x1;
+- xrects[i].y = rects[i].y1;
+- xrects[i].width = rects[i].x2 - rects[i].x1;
+- xrects[i].height = rects[i].y2 - rects[i].y1;
+-
+- cairo_rectangle (cr, xrects[i].x, xrects[i].y,
+- xrects[i].width, xrects[i].height);
+- }
++ cairo_rectangle (cr, extents.x, extents.y, extents.width, extents.height);
+
+ cairo_clip (cr);
+ cairo_set_source_rgb (cr, 1.0, 1.0, 1.0);
+@@ -187,29 +169,30 @@
+
+ /* Copy the updated area onto the window */
+ gc = XCreateGC (display, pixmap, 0, NULL);
+- XSetClipRectangles (display, gc, 0, 0, xrects, n_rects, YXBanded);
+
+ XCopyArea (display, pixmap, window, gc,
+ 0, 0,
+- extents->x2 - extents->x1, extents->y2 - extents->y1,
+- extents->x1, extents->y1);
++ extents.width, extents.height, extents.x, extents.y);
+
+- g_free (xrects);
+ XFreeGC (display, gc);
+ XFreePixmap (display, pixmap);
+
+- pixman_region_destroy (update_region);
++ XDestroyRegion (update_region);
+ update_region = NULL;
+ }
+
+ void
+ expose (XExposeEvent *xev)
+ {
++ XRectangle r;
+ if (!update_region)
+- update_region = pixman_region_create ();
++ update_region = XCreateRegion ();
+
+- pixman_region_union_rect (update_region, update_region,
+- xev->x, xev->y, xev->width, xev->height);
++ r.x = xev->x;
++ r.y = xev->y;
++ r.width = xev->width;
++ r.height = xev->height;
++ XUnionRectWithRegion (&r, update_region, update_region);
+ }
+
+ int main (int argc, char **argv)
+@@ -281,12 +264,17 @@
+ goto done;
+ else if (xev.xkey.keycode == borders_keycode)
+ {
++ XRectangle r;
+ show_borders = !show_borders;
++
+ if (!update_region)
+- update_region = pixman_region_create ();
++ update_region = XCreateRegion ();
+
+- pixman_region_union_rect (update_region, update_region,
+- 0, 0, width, height);
++ r.x = 0;
++ r.y = 0;
++ r.width = width;
++ r.height = height;
++ XUnionRectWithRegion (&r, update_region, update_region);
+ }
+ break;
+ case Expose:
diff --git a/x11-libs/pango/pango-1.9.1.ebuild b/x11-libs/pango/pango-1.9.1.ebuild
index 18ce0d22fb89..d3b43a97b17c 100644
--- a/x11-libs/pango/pango-1.9.1.ebuild
+++ b/x11-libs/pango/pango-1.9.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.9.1.ebuild,v 1.2 2005/07/31 14:46:14 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.9.1.ebuild,v 1.3 2005/08/15 19:22:56 leonardop Exp $
-inherit gnome2 eutils
+inherit eutils gnome2
DESCRIPTION="Text rendering and layout library"
HOMEPAGE="http://www.pango.org/"
@@ -34,6 +34,9 @@ src_unpack() {
epatch ${FILESDIR}/pango-1.0.99.020606-xfonts.patch
epatch ${FILESDIR}/${PN}-1.2.2-slighthint.patch
+ # Patch from upstream CVS to fix compilation with latest cairo
+ epatch ${FILESDIR}/${P}-example_update.patch
+
# make config file location host specific so that a 32bit and 64bit pango
# wont fight with each other on a multilib system
use amd64 && epatch ${FILESDIR}/pango-1.2.5-lib64.patch