summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-03-18 17:58:16 +0000
committerMarinus Schraal <foser@gentoo.org>2004-03-18 17:58:16 +0000
commit0b91d0818fda4e66f392219a52c8b9dc45f8cc75 (patch)
tree7441e93366a5accbe943ace4d99af56ea3865573 /x11-libs/pango/pango-1.4.0.ebuild
parentFresh release (Manifest recommit) (diff)
downloadgentoo-2-0b91d0818fda4e66f392219a52c8b9dc45f8cc75.tar.gz
gentoo-2-0b91d0818fda4e66f392219a52c8b9dc45f8cc75.tar.bz2
gentoo-2-0b91d0818fda4e66f392219a52c8b9dc45f8cc75.zip
fresh release
Diffstat (limited to 'x11-libs/pango/pango-1.4.0.ebuild')
-rw-r--r--x11-libs/pango/pango-1.4.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/x11-libs/pango/pango-1.4.0.ebuild b/x11-libs/pango/pango-1.4.0.ebuild
new file mode 100644
index 000000000000..a23490ef0965
--- /dev/null
+++ b/x11-libs/pango/pango-1.4.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.4.0.ebuild,v 1.1 2004/03/18 17:58:16 foser Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="Text rendering and layout library"
+HOMEPAGE="http://www.pango.org/"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.4/${P}.tar.bz2"
+
+LICENSE="LGPL-2 FTL"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~hppa ~amd64 ~ia64"
+IUSE="doc"
+
+RDEPEND="virtual/x11
+ virtual/xft
+ >=dev-libs/glib-2.4
+ >=media-libs/fontconfig-1.0.1
+ >=media-libs/freetype-2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ # Some enhancements from Redhat
+ epatch ${FILESDIR}/pango-1.0.99.020606-xfonts.patch
+ epatch ${FILESDIR}/${PN}-1.2.2-slighthint.patch
+
+}
+
+DOCS="AUTHORS ChangeLog COPYING README INSTALL NEWS TODO*"
+
+src_install() {
+
+ gnome2_src_install
+ rm ${D}/etc/pango/pango.modules
+
+}
+
+pkg_postinst() {
+
+ einfo "Generating modules listing..."
+ pango-querymodules > /etc/pango/pango.modules
+
+}