summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-10-09 14:04:27 +0000
committerUlrich Müller <ulm@gentoo.org>2010-10-09 14:04:27 +0000
commite7719e438ea61f267321be36a9eb8533e9f167f6 (patch)
treede0f6d6c4cf7950bd560e1c144a18edb5e1a8e47 /x11-libs/openmotif-compat
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-e7719e438ea61f267321be36a9eb8533e9f167f6.tar.gz
gentoo-2-e7719e438ea61f267321be36a9eb8533e9f167f6.tar.bz2
gentoo-2-e7719e438ea61f267321be36a9eb8533e9f167f6.zip
Fix buffer overflow in libmrm, bug 340249.
(Portage version: 2.1.9.13/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/openmotif-compat')
-rw-r--r--x11-libs/openmotif-compat/ChangeLog10
-rw-r--r--x11-libs/openmotif-compat/openmotif-compat-2.2.3-r1.ebuild75
2 files changed, 83 insertions, 2 deletions
diff --git a/x11-libs/openmotif-compat/ChangeLog b/x11-libs/openmotif-compat/ChangeLog
index 8b01042536a7..af3abd6ab32b 100644
--- a/x11-libs/openmotif-compat/ChangeLog
+++ b/x11-libs/openmotif-compat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/openmotif-compat
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif-compat/ChangeLog,v 1.7 2009/12/15 09:23:41 ulm Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif-compat/ChangeLog,v 1.8 2010/10/09 14:04:26 ulm Exp $
+
+*openmotif-compat-2.2.3-r1 (09 Oct 2010)
+
+ 09 Oct 2010; Ulrich Mueller <ulm@gentoo.org>
+ +openmotif-compat-2.2.3-r1.ebuild:
+ Fix buffer overflow in libmrm, bug 340249.
15 Dec 2009; Ulrich Mueller <ulm@gentoo.org>
openmotif-compat-2.2.3.ebuild:
diff --git a/x11-libs/openmotif-compat/openmotif-compat-2.2.3-r1.ebuild b/x11-libs/openmotif-compat/openmotif-compat-2.2.3-r1.ebuild
new file mode 100644
index 000000000000..5cf50e2d44da
--- /dev/null
+++ b/x11-libs/openmotif-compat/openmotif-compat-2.2.3-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif-compat/openmotif-compat-2.2.3-r1.ebuild,v 1.1 2010/10/09 14:04:27 ulm Exp $
+
+WANT_AUTOMAKE="1.6"
+
+inherit eutils flag-o-matic multilib autotools
+
+MY_P=openMotif-${PV}
+DESCRIPTION="Legacy Open Motif libraries for old binaries"
+HOMEPAGE="http://www.motifzone.net/"
+SRC_URI="ftp://ftp.ics.com/openmotif/2.2/${PV}/src/${MY_P}.tar.gz
+ mirror://gentoo/openmotif-${PV}-patches-4.tar.bz2"
+
+LICENSE="MOTIF MIT"
+SLOT="2.2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!x11-libs/motif-config
+ !x11-libs/lesstif
+ !=x11-libs/openmotif-2.2*
+ x11-libs/libXmu
+ x11-libs/libXp"
+
+DEPEND="${RDEPEND}
+ x11-libs/libXaw
+ x11-misc/xbitmaps"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ EPATCH_SUFFIX=patch epatch
+
+ # This replaces deprecated, obsoleted and now invalid AC_DEFINE
+ # with their proper alternatives.
+ sed -i -e 's:AC_DEFINE(\([^)]*\)):AC_DEFINE(\1, [], [\1]):g' \
+ configure.in acinclude.m4
+
+ # Build only the libraries
+ sed -i -e '/^SUBDIRS/{:x;/\\$/{N;bx;};s/=.*/= lib clients/;}' Makefile.am
+ sed -i -e '/^SUBDIRS/{:x;/\\$/{N;bx;};s/=.*/= uil/;}' clients/Makefile.am
+
+ eautoreconf
+}
+
+src_compile() {
+ # get around some LANG problems in make (#15119)
+ unset LANG
+
+ # bug #80421
+ filter-flags -ftracer
+
+ # multilib includes don't work right in this package...
+ has_multilib_profile && append-flags "-I$(get_ml_incdir)"
+
+ # feel free to fix properly if you care
+ append-flags -fno-strict-aliasing
+
+ econf --with-x || die "econf failed"
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install-exec || die "emake install failed"
+
+ # cleanups
+ rm -Rf "${D}"/usr/bin
+ rm -f "${D}"/usr/$(get_libdir)/*.{so,la,a}
+
+ dodoc README RELEASE RELNOTES BUGREPORT TODO
+}