summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-10-06 20:53:44 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-10-06 20:53:44 +0000
commit85753dbc8d4b7690c4c1afe264dead15c17ebfa6 (patch)
tree5ba2a793555ba960cfaf3d0f9a89ef37ec0a48ed /x11-libs/libxcb
parentVersion bump, remove old (diff)
downloadgentoo-2-85753dbc8d4b7690c4c1afe264dead15c17ebfa6.tar.gz
gentoo-2-85753dbc8d4b7690c4c1afe264dead15c17ebfa6.tar.bz2
gentoo-2-85753dbc8d4b7690c4c1afe264dead15c17ebfa6.zip
Add patch to fix wine deadlock, bug #436780.
(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/libxcb')
-rw-r--r--x11-libs/libxcb/ChangeLog9
-rw-r--r--x11-libs/libxcb/files/libxcb-1.8.1-multithread-deadlock.patch46
-rw-r--r--x11-libs/libxcb/libxcb-1.8.1-r1.ebuild38
3 files changed, 91 insertions, 2 deletions
diff --git a/x11-libs/libxcb/ChangeLog b/x11-libs/libxcb/ChangeLog
index ba2f5150c166..54950f4e9d37 100644
--- a/x11-libs/libxcb/ChangeLog
+++ b/x11-libs/libxcb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/libxcb
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/ChangeLog,v 1.96 2012/08/26 19:01:43 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/ChangeLog,v 1.97 2012/10/06 20:53:44 chithanh Exp $
+
+*libxcb-1.8.1-r1 (06 Oct 2012)
+
+ 06 Oct 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +files/libxcb-1.8.1-multithread-deadlock.patch, +libxcb-1.8.1-r1.ebuild:
+ Add patch to fix wine deadlock, bug #436780.
26 Aug 2012; Raúl Porcel <armin76@gentoo.org> libxcb-1.8.1.ebuild:
alpha/ia64/s390/sh/sparc stable wrt #419473
@@ -338,4 +344,3 @@
09 Oct 2006; Donnie Berkholz <dberkholz@gentoo.org>; +metadata.xml,
+libxcb-0.9.92.ebuild:
Add X C-language Bindings library.
-
diff --git a/x11-libs/libxcb/files/libxcb-1.8.1-multithread-deadlock.patch b/x11-libs/libxcb/files/libxcb-1.8.1-multithread-deadlock.patch
new file mode 100644
index 000000000000..d09b24dbe88f
--- /dev/null
+++ b/x11-libs/libxcb/files/libxcb-1.8.1-multithread-deadlock.patch
@@ -0,0 +1,46 @@
+From 23911a707b8845bff52cd7853fc5d59fb0823cef Mon Sep 17 00:00:00 2001
+From: Uli Schlachter <psychon@znc.in>
+Date: Mon, 24 Sep 2012 20:07:51 +0000
+Subject: Fix a multi-thread deadlock
+
+This fixes a deadlock which was seen in-the-wild with wine.
+
+It could happen that two threads tried to read from the socket at the same time
+and one of the thread got stuck inside of poll()/select().
+
+The fix works by making sure that the writing thread doesn't steal the reading
+thread's reply.
+
+Debugged-by: Erich Hoover <ehoover@mines.edu>
+Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=54671
+Signed-off-by: Uli Schlachter <psychon@znc.in>
+---
+diff --git a/src/xcb_conn.c b/src/xcb_conn.c
+index e01d566..6a7a806 100644
+--- a/src/xcb_conn.c
++++ b/src/xcb_conn.c
+@@ -432,10 +432,20 @@ int _xcb_conn_wait(xcb_connection_t *c, pthread_cond_t *cond, struct iovec **vec
+
+ if(ret)
+ {
++ /* The code allows two threads to call select()/poll() at the same time.
++ * First thread just wants to read, a second thread wants to write, too.
++ * We have to make sure that we don't steal the reading thread's reply
++ * and let it get stuck in select()/poll().
++ * So a thread may read if either:
++ * - There is no other thread that wants to read (the above situation
++ * did not occur).
++ * - It is the reading thread (above situation occurred).
++ */
++ int may_read = c->in.reading == 1 || !count;
+ #if USE_POLL
+- if((fd.revents & POLLIN) == POLLIN)
++ if(may_read && (fd.revents & POLLIN) == POLLIN)
+ #else
+- if(FD_ISSET(c->fd, &rfds))
++ if(may_read && FD_ISSET(c->fd, &rfds))
+ #endif
+ ret = ret && _xcb_in_read(c);
+
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/x11-libs/libxcb/libxcb-1.8.1-r1.ebuild b/x11-libs/libxcb/libxcb-1.8.1-r1.ebuild
new file mode 100644
index 000000000000..8e7f813e56ef
--- /dev/null
+++ b/x11-libs/libxcb/libxcb-1.8.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/libxcb-1.8.1-r1.ebuild,v 1.1 2012/10/06 20:53:44 chithanh Exp $
+
+EAPI=4
+
+XORG_DOC=doc
+inherit xorg-2
+
+DESCRIPTION="X C-language Bindings library"
+HOMEPAGE="http://xcb.freedesktop.org/"
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/libxcb"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="selinux"
+
+RDEPEND="dev-libs/libpthread-stubs
+ x11-libs/libXau
+ x11-libs/libXdmcp"
+DEPEND="${RDEPEND}
+ dev-lang/python[xml]
+ dev-libs/libxslt
+ >=x11-proto/xcb-proto-1.7-r1"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-multithread-deadlock.patch
+)
+
+pkg_setup() {
+ xorg-2_pkg_setup
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc build-docs)
+ $(use_enable selinux)
+ --enable-xinput
+ )
+}