summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-07-08 07:08:01 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-07-08 07:08:01 +0000
commit1be1f077545715d799dcfa2557357766fb91322c (patch)
tree0825bbaba3380cc670fc37083f34c4cd4908fddf /x11-libs/liboglappth
parentBump. Pull in newer libf2c so configure doesn't fail. (diff)
downloadgentoo-2-1be1f077545715d799dcfa2557357766fb91322c.tar.gz
gentoo-2-1be1f077545715d799dcfa2557357766fb91322c.tar.bz2
gentoo-2-1be1f077545715d799dcfa2557357766fb91322c.zip
New package: A library for creating portable OpenGL applications with easy-to-code scene setup and selection operations.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc8 x86_64)
Diffstat (limited to 'x11-libs/liboglappth')
-rw-r--r--x11-libs/liboglappth/ChangeLog11
-rw-r--r--x11-libs/liboglappth/Manifest5
-rw-r--r--x11-libs/liboglappth/files/gcc-4.3.patch10
-rw-r--r--x11-libs/liboglappth/liboglappth-0.96.ebuild28
-rw-r--r--x11-libs/liboglappth/metadata.xml12
5 files changed, 66 insertions, 0 deletions
diff --git a/x11-libs/liboglappth/ChangeLog b/x11-libs/liboglappth/ChangeLog
new file mode 100644
index 000000000000..78f1d1a491e2
--- /dev/null
+++ b/x11-libs/liboglappth/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-libs/liboglappth
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/liboglappth/ChangeLog,v 1.1 2008/07/08 07:08:00 dberkholz Exp $
+
+*liboglappth-0.96 (08 Jul 2008)
+
+ 08 Jul 2008; Donnie Berkholz <dberkholz@gentoo.org>; +files/gcc-4.3.patch,
+ +metadata.xml, +liboglappth-0.96.ebuild:
+ New package: A library for creating portable OpenGL applications with
+ easy-to-code scene setup and selection operations.
+
diff --git a/x11-libs/liboglappth/Manifest b/x11-libs/liboglappth/Manifest
new file mode 100644
index 000000000000..72aa5e6bb188
--- /dev/null
+++ b/x11-libs/liboglappth/Manifest
@@ -0,0 +1,5 @@
+AUX gcc-4.3.patch 293 RMD160 5c163c3bb77ac3676f086cd2a1247480f78e58cd SHA1 d11af6f3d8115194562d59c8e069b0caeb233958 SHA256 fd7fb052050c6feb895eb459f3f647917848c32c567aeea93e8f35c41b34fe5c
+DIST liboglappth-0.96.tar.gz 313284 RMD160 2b67fb748bada63c1cc70aa21cba85d1dbd642bd SHA1 bdaa47c76eee2db6cc859f135a10aabce096a45e SHA256 1b86d4218e6a2c7f73cc02edca2c937d7034c0cf60542fb6ef697cdf6f0c8acf
+EBUILD liboglappth-0.96.ebuild 688 RMD160 6ee8f3ba22658952722f51ec8008885e5e82a4e0 SHA1 b40bcc87479a687b934ed284fda9f959652e6062 SHA256 cfac7c1ce6247b6d0a691ddcee38953b2d4e6b2ce507d5e84766071f4aecc1ce
+MISC ChangeLog 400 RMD160 8e3e19c8b73b4ac41a80aaedba6d292374323938 SHA1 9850e2d7e86608c30d0f9a9873745191e321607b SHA256 71d70b337a6bd54cc830dada57a20e652dc8bba37921d938086d47b510e549ea
+MISC metadata.xml 553 RMD160 f8bf00291af94065bc4b5604d5f695d3814502d1 SHA1 51444cb1c8d735dc66b5c7b433509f470121edfb SHA256 6ab5bdd882bc36abb113b5c22df7c2daf35d1df8fcd9a1555fb9665959cd0aaa
diff --git a/x11-libs/liboglappth/files/gcc-4.3.patch b/x11-libs/liboglappth/files/gcc-4.3.patch
new file mode 100644
index 000000000000..7a70ab2a2659
--- /dev/null
+++ b/x11-libs/liboglappth/files/gcc-4.3.patch
@@ -0,0 +1,10 @@
+--- liboglappth-0.96.orig/src/base_wcl.cpp 2008-07-07 23:49:10.000000000 -0700
++++ liboglappth-0.96/src/base_wcl.cpp 2008-07-07 23:49:26.000000000 -0700
+@@ -11,6 +11,7 @@
+
+ #include "base_app.h"
+ #include <stdlib.h> // the definition for NULL...
++#include <cstring>
+
+ #include <GL/glut.h>
+
diff --git a/x11-libs/liboglappth/liboglappth-0.96.ebuild b/x11-libs/liboglappth/liboglappth-0.96.ebuild
new file mode 100644
index 000000000000..b0e9d6c7c8a4
--- /dev/null
+++ b/x11-libs/liboglappth/liboglappth-0.96.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/liboglappth/liboglappth-0.96.ebuild,v 1.1 2008/07/08 07:08:00 dberkholz Exp $
+
+inherit eutils
+
+DESCRIPTION="A library for creating portable OpenGL applications with easy-to-code scene setup and selection operations."
+HOMEPAGE="http://www.bioinformatics.org/ghemical/"
+SRC_URI="http://www.bioinformatics.org/ghemical/download/current/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+RDEPEND="virtual/opengl
+ virtual/glu
+ virtual/glut"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/gcc-4.3.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
diff --git a/x11-libs/liboglappth/metadata.xml b/x11-libs/liboglappth/metadata.xml
new file mode 100644
index 000000000000..81439daa1259
--- /dev/null
+++ b/x11-libs/liboglappth/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-chemistry</herd>
+<longdescription>
+Ghemical supports both quantum-mechanics (semi-empirical and ab initio) models
+and molecular mechanics models (there is an experimental Tripos 5.2-like force
+field for organic molecules). Also a tool for reduced protein models is
+included. Geometry optimization, molecular dynamics and a large set of
+visualization tools are currently available.
+</longdescription>
+</pkgmetadata>