summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Vasilevski <yvasilev@gentoo.org>2006-07-14 17:20:21 +0000
committerYuri Vasilevski <yvasilev@gentoo.org>2006-07-14 17:20:21 +0000
commit1dc4f6dbe602b118ce6668adc18264c82b0e45ed (patch)
tree208903ddde2bdafea5387ed4182f25c1ab1b8cb3 /x11-libs/libmatchbox
parentppc stable, bug #139612 (diff)
downloadgentoo-2-1dc4f6dbe602b118ce6668adc18264c82b0e45ed.tar.gz
gentoo-2-1dc4f6dbe602b118ce6668adc18264c82b0e45ed.tar.bz2
gentoo-2-1dc4f6dbe602b118ce6668adc18264c82b0e45ed.zip
Added a warning if emerging with incompatible USE flags. Bug #138135
(Portage version: 2.1.1_pre2-r8)
Diffstat (limited to 'x11-libs/libmatchbox')
-rw-r--r--x11-libs/libmatchbox/ChangeLog6
-rw-r--r--x11-libs/libmatchbox/libmatchbox-1.7.ebuild15
-rw-r--r--x11-libs/libmatchbox/libmatchbox-1.8.ebuild15
3 files changed, 31 insertions, 5 deletions
diff --git a/x11-libs/libmatchbox/ChangeLog b/x11-libs/libmatchbox/ChangeLog
index 917b2eff4077..4b5314411eeb 100644
--- a/x11-libs/libmatchbox/ChangeLog
+++ b/x11-libs/libmatchbox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/libmatchbox
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libmatchbox/ChangeLog,v 1.3 2006/06/04 20:32:23 yvasilev Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libmatchbox/ChangeLog,v 1.4 2006/07/14 17:20:21 yvasilev Exp $
+
+ 14 Jul 2006; <yvasilev@gentoo.org> libmatchbox-1.7.ebuild,
+ libmatchbox-1.8.ebuild:
+ Added a warning if emerging with incompatible USE flags. Bug #138135
*libmatchbox-1.8 (04 Jun 2006)
diff --git a/x11-libs/libmatchbox/libmatchbox-1.7.ebuild b/x11-libs/libmatchbox/libmatchbox-1.7.ebuild
index 0826c6d3bfff..78ddcc9023cb 100644
--- a/x11-libs/libmatchbox/libmatchbox-1.7.ebuild
+++ b/x11-libs/libmatchbox/libmatchbox-1.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 2006-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libmatchbox/libmatchbox-1.7.ebuild,v 1.1 2006/03/12 20:12:18 yvasilev Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libmatchbox/libmatchbox-1.7.ebuild,v 1.2 2006/07/14 17:20:21 yvasilev Exp $
-inherit libtool
+inherit eutils libtool
DESCRIPTION="The Matchbox Library."
HOMEPAGE="http://projects.o-hand.com/matchbox/"
@@ -24,6 +24,17 @@ RDEPEND="|| ( ( x11-libs/libXext
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
+pkg_setup() {
+ # Bug #138135
+ if use truetype && use pango; then
+ ewarn "You have both the truetype and pango USE flags set, pango"
+ ewarn "overrides and disables the XFT support truetype enables."
+ ewarn "If this isn't what you intended you should stop the build!"
+ ebeep 3
+ epause 3
+ fi
+}
+
src_unpack() {
unpack ${A}
cd ${S}
diff --git a/x11-libs/libmatchbox/libmatchbox-1.8.ebuild b/x11-libs/libmatchbox/libmatchbox-1.8.ebuild
index b70d80ab2615..17b978b6f6fd 100644
--- a/x11-libs/libmatchbox/libmatchbox-1.8.ebuild
+++ b/x11-libs/libmatchbox/libmatchbox-1.8.ebuild
@@ -1,8 +1,8 @@
# Copyright 2006-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libmatchbox/libmatchbox-1.8.ebuild,v 1.1 2006/06/04 20:32:23 yvasilev Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libmatchbox/libmatchbox-1.8.ebuild,v 1.2 2006/07/14 17:20:21 yvasilev Exp $
-inherit libtool
+inherit eutils libtool
DESCRIPTION="The Matchbox Library."
HOMEPAGE="http://projects.o-hand.com/matchbox/"
@@ -24,6 +24,17 @@ RDEPEND="|| ( ( x11-libs/libXext
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
+pkg_setup() {
+ # Bug #138135
+ if use truetype && use pango; then
+ ewarn "You have both the truetype and pango USE flags set, pango"
+ ewarn "overrides and disables the XFT support truetype enables."
+ ewarn "If this isn't what you intended you should stop the build!"
+ ebeep 3
+ epause 3
+ fi
+}
+
src_unpack() {
unpack ${A}
cd ${S}