summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2006-10-13 04:11:14 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2006-10-13 04:11:14 +0000
commit30b6243908c958f8c96bbbe8eff3476e41396144 (patch)
treed8ea87fef5a0b522af0164a82d6cb2402111e86c /x11-libs/libXrandr/libXrandr-1.1.1-r1.ebuild
parentAdd a fix from upstream that removes an unnecessary call to UnlockDisplay. (diff)
downloadgentoo-2-30b6243908c958f8c96bbbe8eff3476e41396144.tar.gz
gentoo-2-30b6243908c958f8c96bbbe8eff3476e41396144.tar.bz2
gentoo-2-30b6243908c958f8c96bbbe8eff3476e41396144.zip
Add a fix from upstream that removes an unnecessary call to UnlockDisplay.
This fixes behaviour with xcb enabled in libX11. (Portage version: 2.1.2_pre2-r9)
Diffstat (limited to 'x11-libs/libXrandr/libXrandr-1.1.1-r1.ebuild')
-rw-r--r--x11-libs/libXrandr/libXrandr-1.1.1-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/x11-libs/libXrandr/libXrandr-1.1.1-r1.ebuild b/x11-libs/libXrandr/libXrandr-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..dc0696053ba1
--- /dev/null
+++ b/x11-libs/libXrandr/libXrandr-1.1.1-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXrandr/libXrandr-1.1.1-r1.ebuild,v 1.1 2006/10/13 04:11:14 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+# SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org Xrandr library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-proto/randrproto
+ x11-proto/xproto"
+DEPEND="${RDEPEND}
+ x11-proto/renderproto"
+
+PATCHES="${FILESDIR}/drop-extra-unlockdisplay.patch"