summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2014-07-18 15:47:38 +0000
committerMatt Turner <mattst88@gentoo.org>2014-07-18 15:47:38 +0000
commit7a3088bda84a42c35f9c7aed9236e7730819a7b9 (patch)
tree5fc05866c0836c103329f12352cfc544c656d7d1 /x11-libs/libXi
parentEAPI bump. (diff)
downloadgentoo-2-7a3088bda84a42c35f9c7aed9236e7730819a7b9.tar.gz
gentoo-2-7a3088bda84a42c35f9c7aed9236e7730819a7b9.tar.bz2
gentoo-2-7a3088bda84a42c35f9c7aed9236e7730819a7b9.zip
Version bump to 1.7.4.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 974CA72A)
Diffstat (limited to 'x11-libs/libXi')
-rw-r--r--x11-libs/libXi/ChangeLog7
-rw-r--r--x11-libs/libXi/libXi-1.7.4.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/x11-libs/libXi/ChangeLog b/x11-libs/libXi/ChangeLog
index e668c5182dd4..f9a19c9da6fd 100644
--- a/x11-libs/libXi/ChangeLog
+++ b/x11-libs/libXi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libXi
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXi/ChangeLog,v 1.167 2014/06/18 21:07:43 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXi/ChangeLog,v 1.168 2014/07/18 15:47:38 mattst88 Exp $
+
+*libXi-1.7.4 (18 Jul 2014)
+
+ 18 Jul 2014; Matt Turner <mattst88@gentoo.org> +libXi-1.7.4.ebuild:
+ Version bump to 1.7.4.
18 Jun 2014; Michał Górny <mgorny@gentoo.org> libXi-1.7.2.ebuild:
Update dependencies to require guaranteed EAPI=5 or multilib ebuilds, bug
diff --git a/x11-libs/libXi/libXi-1.7.4.ebuild b/x11-libs/libXi/libXi-1.7.4.ebuild
new file mode 100644
index 000000000000..0edd01707310
--- /dev/null
+++ b/x11-libs/libXi/libXi-1.7.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXi/libXi-1.7.4.ebuild,v 1.1 2014/07/18 15:47:38 mattst88 Exp $
+
+EAPI=5
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org Xi library"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE=""
+
+RDEPEND=">=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXfixes-5.0.1[${MULTILIB_USEDEP}]
+ >=x11-proto/inputproto-2.3[${MULTILIB_USEDEP}]
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]
+ >=x11-proto/xextproto-7.2.1-r1[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc specs)
+ $(use_with doc xmlto)
+ $(use_with doc asciidoc)
+ --without-fop
+ )
+ xorg-2_src_configure
+}
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+
+ ewarn "Some special keys and keyboard layouts may stop working."
+ ewarn "To fix them, recompile xorg-server."
+}