summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-05-17 09:53:51 +0000
committerJustin Lecher <jlec@gentoo.org>2011-05-17 09:53:51 +0000
commit4eaaeda9bebc558ff01444e4dac78d10d483022d (patch)
treed5c435d816be13a17e38eedcca08d1ffbcabf0dc /x11-libs/gl2ps
parentVersion bump to the GNS3 community release. All the hard patching work done b... (diff)
downloadgentoo-2-4eaaeda9bebc558ff01444e4dac78d10d483022d.tar.gz
gentoo-2-4eaaeda9bebc558ff01444e4dac78d10d483022d.tar.bz2
gentoo-2-4eaaeda9bebc558ff01444e4dac78d10d483022d.zip
Fixed underlinking, #367649
(Portage version: 2.2.0_alpha33/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/gl2ps')
-rw-r--r--x11-libs/gl2ps/ChangeLog6
-rw-r--r--x11-libs/gl2ps/files/gl2ps-1.3.5-CMakeLists.patch30
-rw-r--r--x11-libs/gl2ps/gl2ps-1.3.5-r2.ebuild18
-rw-r--r--x11-libs/gl2ps/gl2ps-1.3.5.ebuild8
4 files changed, 37 insertions, 25 deletions
diff --git a/x11-libs/gl2ps/ChangeLog b/x11-libs/gl2ps/ChangeLog
index e52e53e3d8b3..eff9f7bf0f36 100644
--- a/x11-libs/gl2ps/ChangeLog
+++ b/x11-libs/gl2ps/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/gl2ps
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gl2ps/ChangeLog,v 1.13 2011/03/16 20:31:08 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gl2ps/ChangeLog,v 1.14 2011/05/17 09:53:51 jlec Exp $
+
+ 17 May 2011; Justin Lecher <jlec@gentoo.org> gl2ps-1.3.5.ebuild,
+ gl2ps-1.3.5-r2.ebuild, files/gl2ps-1.3.5-CMakeLists.patch:
+ Fixed underlinking, #367649
*gl2ps-1.3.5-r2 (16 Mar 2011)
diff --git a/x11-libs/gl2ps/files/gl2ps-1.3.5-CMakeLists.patch b/x11-libs/gl2ps/files/gl2ps-1.3.5-CMakeLists.patch
index 87e3b7f58172..cc9a3817a72c 100644
--- a/x11-libs/gl2ps/files/gl2ps-1.3.5-CMakeLists.patch
+++ b/x11-libs/gl2ps/files/gl2ps-1.3.5-CMakeLists.patch
@@ -1,7 +1,11 @@
-diff -Nur gl2ps-1.3.5-source.orig/CMakeLists.txt gl2ps-1.3.5-source/CMakeLists.txt
---- gl2ps-1.3.5-source.orig/CMakeLists.txt 2011-03-16 19:21:58.000000000 +0000
-+++ gl2ps-1.3.5-source/CMakeLists.txt 2011-03-16 19:29:50.000000000 +0000
-@@ -46,6 +46,7 @@
+ CMakeLists.txt | 25 ++++++++++---------------
+ 1 files changed, 10 insertions(+), 15 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 69b88e2..e0b9278 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -46,6 +46,7 @@ project(gl2ps C)
option(ENABLE_ZLIB "Enable compression using ZLIB" ON)
option(ENABLE_PNG "Enable PNG support" ON)
@@ -9,7 +13,7 @@ diff -Nur gl2ps-1.3.5-source.orig/CMakeLists.txt gl2ps-1.3.5-source/CMakeLists.t
set(GL2PS_MAJOR_VERSION 1)
set(GL2PS_MINOR_VERSION 3)
-@@ -103,39 +104,40 @@
+@@ -103,39 +104,33 @@ endif(ENABLE_PNG)
include_directories(${EXTERNAL_INCLUDES})
if(OPENGL_FOUND)
@@ -46,20 +50,18 @@ diff -Nur gl2ps-1.3.5-source.orig/CMakeLists.txt gl2ps-1.3.5-source/CMakeLists.t
install(FILES ${CMAKE_SOURCE_DIR}/gl2psTestSimple.c DESTINATION ${GL2PS_DOC})
+install(FILES ${CMAKE_SOURCE_DIR}/gl2ps.pdf DESTINATION ${GL2PS_DOC})
- if(GLUT_FOUND)
- add_executable(gl2psTest WIN32 gl2psTest.c)
+-if(GLUT_FOUND)
+- add_executable(gl2psTest WIN32 gl2psTest.c)
- target_link_libraries(gl2psTest lib ${EXTERNAL_LIBRARIES})
-+ target_link_libraries(gl2psTest shared ${EXTERNAL_LIBRARIES})
- add_executable(gl2psTestSimple WIN32 gl2psTestSimple.c)
+- add_executable(gl2psTestSimple WIN32 gl2psTestSimple.c)
- target_link_libraries(gl2psTestSimple lib ${EXTERNAL_LIBRARIES})
-+ target_link_libraries(gl2psTestSimple shared ${EXTERNAL_LIBRARIES})
- endif(GLUT_FOUND)
-
+-endif(GLUT_FOUND)
+-
+if(ENABLE_DOC)
find_package(LATEX)
if(PDFLATEX_COMPILER)
add_custom_command(OUTPUT gl2ps.pdf DEPENDS gl2ps.tex
-@@ -144,7 +146,6 @@
+@@ -144,7 +139,6 @@ if(PDFLATEX_COMPILER)
COMMAND ${PDFLATEX_COMPILER} ARGS ${CMAKE_SOURCE_DIR}/gl2ps.tex
COMMAND ${CMAKE_COMMAND} -E copy gl2ps.pdf ${CMAKE_SOURCE_DIR})
add_custom_target(pdf ALL DEPENDS gl2ps.pdf)
@@ -67,7 +69,7 @@ diff -Nur gl2ps-1.3.5-source.orig/CMakeLists.txt gl2ps-1.3.5-source/CMakeLists.t
find_program(TTH tth)
if(TTH)
add_custom_command(OUTPUT gl2ps.html DEPENDS gl2ps.tex gl2ps.pdf
-@@ -154,6 +155,7 @@
+@@ -154,6 +148,7 @@ if(PDFLATEX_COMPILER)
add_custom_target(html DEPENDS gl2ps.html)
endif(TTH)
endif(PDFLATEX_COMPILER)
diff --git a/x11-libs/gl2ps/gl2ps-1.3.5-r2.ebuild b/x11-libs/gl2ps/gl2ps-1.3.5-r2.ebuild
index 7bba4a2041e5..359814b3fa25 100644
--- a/x11-libs/gl2ps/gl2ps-1.3.5-r2.ebuild
+++ b/x11-libs/gl2ps/gl2ps-1.3.5-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gl2ps/gl2ps-1.3.5-r2.ebuild,v 1.1 2011/03/16 20:31:08 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gl2ps/gl2ps-1.3.5-r2.ebuild,v 1.2 2011/05/17 09:53:51 jlec Exp $
-EAPI="3"
+EAPI=3
inherit cmake-utils multilib
DESCRIPTION="OpenGL to PostScript printing library"
@@ -14,14 +14,18 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="doc png zlib"
-DEPEND="media-libs/freeglut
+DEPEND="
+ media-libs/freeglut
png? ( media-libs/libpng )
- zlib? ( sys-libs/zlib )
- doc? ( dev-tex/tth dev-texlive/texlive-latex )"
+ doc? ( dev-tex/tth dev-texlive/texlive-latex )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
-S="${WORKDIR}/${P}-source"
+S=${WORKDIR}/${P}-source
-PATCHES=( "${FILESDIR}"/${P}-CMakeLists.patch "${FILESDIR}"/${P}-soversion.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-CMakeLists.patch
+ "${FILESDIR}"/${P}-soversion.patch )
src_configure() {
local mycmakeargs=(
diff --git a/x11-libs/gl2ps/gl2ps-1.3.5.ebuild b/x11-libs/gl2ps/gl2ps-1.3.5.ebuild
index 56cd158ef10e..eb88b065d698 100644
--- a/x11-libs/gl2ps/gl2ps-1.3.5.ebuild
+++ b/x11-libs/gl2ps/gl2ps-1.3.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gl2ps/gl2ps-1.3.5.ebuild,v 1.7 2010/09/16 17:33:01 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gl2ps/gl2ps-1.3.5.ebuild,v 1.8 2011/05/17 09:53:51 jlec Exp $
EAPI=2
inherit cmake-utils multilib
@@ -14,9 +14,11 @@ SLOT="0"
KEYWORDS="~alpha amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="png zlib"
-DEPEND="media-libs/freeglut
+DEPEND="
+ media-libs/freeglut
png? ( media-libs/libpng )
zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
S=${WORKDIR}/${P}-source