summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2008-12-18 13:50:38 +0000
committerTony Vroon <chainsaw@gentoo.org>2008-12-18 13:50:38 +0000
commit3de1c9aebf31b291245b1386906b9da15cb47f93 (patch)
treec55b004bc4c99fe5ae5b73327f68d44329980365 /x11-drivers
parentAdd new ebuilds and fixes from Alessio. (diff)
downloadgentoo-2-3de1c9aebf31b291245b1386906b9da15cb47f93.tar.gz
gentoo-2-3de1c9aebf31b291245b1386906b9da15cb47f93.tar.bz2
gentoo-2-3de1c9aebf31b291245b1386906b9da15cb47f93.zip
Version bump, adds support for input ABI 0 (older X servers), which users apparently expect. Closes bug #250112 filed by Chris Slycord <cslycord@gmail.com>. With thanks to Donnie Berkholz <dberkholz@gentoo.org> for forwarding the release announcement.
(Portage version: 2.1.6.1/cvs/Linux 2.6.28-rc8-00001-g6c34bc2-dirty x86_64)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-synaptics/ChangeLog10
-rw-r--r--x11-drivers/xf86-input-synaptics/xf86-input-synaptics-0.99.3.ebuild70
2 files changed, 79 insertions, 1 deletions
diff --git a/x11-drivers/xf86-input-synaptics/ChangeLog b/x11-drivers/xf86-input-synaptics/ChangeLog
index f50742e197f4..7d1d2f9ee16b 100644
--- a/x11-drivers/xf86-input-synaptics/ChangeLog
+++ b/x11-drivers/xf86-input-synaptics/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-drivers/xf86-input-synaptics
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/ChangeLog,v 1.15 2008/12/09 16:18:50 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/ChangeLog,v 1.16 2008/12/18 13:50:38 chainsaw Exp $
+
+*xf86-input-synaptics-0.99.3 (18 Dec 2008)
+
+ 18 Dec 2008; <chainsaw@gentoo.org> +xf86-input-synaptics-0.99.3.ebuild:
+ Version bump, adds support for input ABI 0 (older X servers), which users
+ apparently expect. Closes bug #250112 filed by Chris Slycord
+ <cslycord@gmail.com>. With thanks to Donnie Berkholz
+ <dberkholz@gentoo.org> for forwarding the release announcement.
*xf86-input-synaptics-0.99.2-r1 (09 Dec 2008)
diff --git a/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-0.99.3.ebuild b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-0.99.3.ebuild
new file mode 100644
index 000000000000..99d0d080db41
--- /dev/null
+++ b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-0.99.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-0.99.3.ebuild,v 1.1 2008/12/18 13:50:38 chainsaw Exp $
+
+inherit toolchain-funcs eutils linux-info x-modular
+
+DESCRIPTION="Driver for Synaptics touchpads"
+HOMEPAGE="http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+LICENSE="MIT"
+IUSE=""
+RDEPEND="x11-libs/libXext
+ hal? ( sys-apps/hal )"
+DEPEND="${RDEPEND}
+ !x11-drivers/synaptics
+ x11-base/xorg-server
+ x11-proto/inputproto
+ >=sys-apps/sed-4"
+
+evdev-input_check() {
+ # Check kernel config for required event interface support (either
+ # built-in or as a module. Bug #134309.
+
+ ebegin "Checking kernel config for event device support"
+ linux_chkconfig_present INPUT_EVDEV
+ eend $?
+
+ if [[ $? -ne 0 ]] ; then
+ ewarn "Synaptics driver requires event interface support."
+ ewarn "Please enable the event interface in your kernel config."
+ ewarn "The option can be found at:"
+ ewarn
+ ewarn " Device Drivers"
+ ewarn " Input device support"
+ ewarn " -*- Generic input layer"
+ ewarn " <*> Event interface"
+ ewarn
+ ewarn "Then rebuild the kernel or install the module."
+ epause 5
+ fi
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+ evdev-input_check
+}
+
+src_unpack() {
+ x-modular_unpack_source
+ epatch "${FILESDIR}/0.99.2-fdi-comments.patch"
+}
+
+src_install() {
+ DOCS="INSTALL NEWS TODO README"
+ x-modular_src_install
+
+ # Stupid new daemon, didn't work for me because of shm issues
+ newinitd "${FILESDIR}"/rc.init syndaemon
+ newconfd "${FILESDIR}"/rc.conf syndaemon
+
+ # Have HAL assign this driver to supported touchpads.
+ insinto /usr/share/hal/fdi/policy/10osvendor
+ doins "${S}"/fdi/11-x11-synaptics.fdi
+}
+
+pkg_postinst() {
+ einfo "Synaptics settings are now stored in: "
+ einfo "/usr/share/hal/fdi/policy/10osvendor/11-x11-synaptics.fdi"
+ ewarn "You need to migrate your settings and clear them from xorg.conf"
+}