summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2010-10-04 20:33:59 +0000
committerMichał Górny <mgorny@gentoo.org>2010-10-04 20:33:59 +0000
commit6a06440e8f8cf95b4695f0b320555a863a2bc446 (patch)
tree24d1049f886abdfd78eba8b10d49e425e50400e6 /x11-base
parentdev-cpp/libxmlpp: Rebuild configure for grep 2.7 or later (bug #339404) (diff)
downloadgentoo-2-6a06440e8f8cf95b4695f0b320555a863a2bc446.tar.gz
gentoo-2-6a06440e8f8cf95b4695f0b320555a863a2bc446.tar.bz2
gentoo-2-6a06440e8f8cf95b4695f0b320555a863a2bc446.zip
Replace the tslib build patch with a set of new patches in order to fix bug #318609. The first patch fixes linking with tslib whenever pkg-config fails to find it but fallback check does. The second one fixes overall linking with tslib whenever -Wl,--as-needed is used.
(Portage version: 2.2_rc88_p86/cvs/Linux x86_64)
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xorg-server/ChangeLog13
-rw-r--r--x11-base/xorg-server/files/0001-Fix-tslib-check-fallback-to-set-TSLIB_LIBS.patch35
-rw-r--r--x11-base/xorg-server/files/0002-Fix-linking-with-tslib-with-Wl-as-needed.patch25
-rw-r--r--x11-base/xorg-server/files/1.7.5.902-fix-tslib-1.0-check.patch19
-rw-r--r--x11-base/xorg-server/files/xorg-server-1.7.6-tslib-as-needed.patch25
-rw-r--r--x11-base/xorg-server/xorg-server-1.7.6.ebuild8
-rw-r--r--x11-base/xorg-server/xorg-server-1.7.7-r1.ebuild8
-rw-r--r--x11-base/xorg-server/xorg-server-1.8.2.ebuild6
-rw-r--r--x11-base/xorg-server/xorg-server-1.9.0-r2.ebuild11
9 files changed, 121 insertions, 29 deletions
diff --git a/x11-base/xorg-server/ChangeLog b/x11-base/xorg-server/ChangeLog
index 25dfbdbcdcd7..b0704a529be5 100644
--- a/x11-base/xorg-server/ChangeLog
+++ b/x11-base/xorg-server/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for x11-base/xorg-server
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/ChangeLog,v 1.540 2010/09/30 02:48:32 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/ChangeLog,v 1.541 2010/10/04 20:33:59 mgorny Exp $
+
+ 04 Oct 2010; Michał Górny <mgorny@gentoo.org> xorg-server-1.7.6.ebuild,
+ xorg-server-1.7.7-r1.ebuild, xorg-server-1.8.2.ebuild,
+ xorg-server-1.9.0-r2.ebuild, -files/1.7.5.902-fix-tslib-1.0-check.patch,
+ +files/0001-Fix-tslib-check-fallback-to-set-TSLIB_LIBS.patch,
+ +files/0002-Fix-linking-with-tslib-with-Wl-as-needed.patch,
+ +files/xorg-server-1.7.6-tslib-as-needed.patch:
+ Replace the tslib build patch with a set of new patches in order to fix
+ bug #318609. The first patch fixes linking with tslib whenever pkg-config
+ fails to find it but fallback check does. The second one fixes overall
+ linking with tslib whenever -Wl,--as-needed is used.
30 Sep 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
xorg-server-1.9.0-r2.ebuild:
diff --git a/x11-base/xorg-server/files/0001-Fix-tslib-check-fallback-to-set-TSLIB_LIBS.patch b/x11-base/xorg-server/files/0001-Fix-tslib-check-fallback-to-set-TSLIB_LIBS.patch
new file mode 100644
index 000000000000..8538bf35f302
--- /dev/null
+++ b/x11-base/xorg-server/files/0001-Fix-tslib-check-fallback-to-set-TSLIB_LIBS.patch
@@ -0,0 +1,35 @@
+From 7cf37a8247205335657dd7a644856bbaf619b7ce Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Mon, 4 Oct 2010 18:38:44 +0200
+Subject: [PATCH 1/2] Fix tslib check fallback to set TSLIB_LIBS.
+
+If pkg-config is unable to find tslib but the fallback check does find
+it, the compilation continues with tslib support enabled though
+TSLIB_LIBS is unset. Thus, the compilation fails with a linking error on
+tslib functions.
+
+This patch sets TSLIB_LIBS to '-lts' whenever the tslib fallback check
+succeds.
+---
+ configure.ac | 5 ++++-
+ 1 files changed, 4 insertions(+), 1 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index c0bf98f..6d63663 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -2034,7 +2034,10 @@ if test "$KDRIVE" = yes; then
+
+ PKG_CHECK_MODULES([TSLIB], [tslib-0.0], [HAVE_TSLIB="yes"], [HAVE_TSLIB="no"])
+ if test "x$HAVE_TSLIB" = xno; then
+- AC_CHECK_LIB(ts, ts_open, [HAVE_TSLIB="yes"])
++ AC_CHECK_LIB(ts, ts_open, [
++ HAVE_TSLIB="yes"
++ TSLIB_LIBS="-lts"
++ ])
+ fi
+
+ if test "xTSLIB" = xauto; then
+--
+1.7.3.1
+
diff --git a/x11-base/xorg-server/files/0002-Fix-linking-with-tslib-with-Wl-as-needed.patch b/x11-base/xorg-server/files/0002-Fix-linking-with-tslib-with-Wl-as-needed.patch
new file mode 100644
index 000000000000..cdcfca6fdf81
--- /dev/null
+++ b/x11-base/xorg-server/files/0002-Fix-linking-with-tslib-with-Wl-as-needed.patch
@@ -0,0 +1,25 @@
+From 39193982958d8e3c433f32d834912129e360d377 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Mon, 4 Oct 2010 19:02:29 +0200
+Subject: [PATCH 2/2] Fix linking with tslib, with -Wl,--as-needed.
+
+---
+ configure.ac | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 6d63663..e8f9473 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -2122,7 +2122,7 @@ if test "$KDRIVE" = yes; then
+ KDRIVE_LOCAL_LIBS="$MAIN_LIB $DIX_LIB $KDRIVE_LIB $KDRIVE_STUB_LIB"
+ KDRIVE_LOCAL_LIBS="$KDRIVE_LOCAL_LIBS $FB_LIB $MI_LIB $KDRIVE_PURE_LIBS"
+ KDRIVE_LOCAL_LIBS="$KDRIVE_LOCAL_LIBS $KDRIVE_OS_LIB $OS_LIB"
+- KDRIVE_LIBS="$TSLIB_LIBS $KDRIVE_LOCAL_LIBS $XSERVER_SYS_LIBS $GLX_SYS_LIBS $DLOPEN_LIBS"
++ KDRIVE_LIBS="$KDRIVE_LOCAL_LIBS $XSERVER_SYS_LIBS $GLX_SYS_LIBS $DLOPEN_LIBS $TSLIB_LIBS"
+
+ AC_SUBST([XEPHYR_LIBS])
+ AC_SUBST([XEPHYR_INCS])
+--
+1.7.3.1
+
diff --git a/x11-base/xorg-server/files/1.7.5.902-fix-tslib-1.0-check.patch b/x11-base/xorg-server/files/1.7.5.902-fix-tslib-1.0-check.patch
deleted file mode 100644
index 3675822edf28..000000000000
--- a/x11-base/xorg-server/files/1.7.5.902-fix-tslib-1.0-check.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- configure.ac 2010-03-16 22:24:14.000000000 +0100
-+++ configure.ac.new 2010-03-16 22:33:10.000000000 +0100
-@@ -1915,8 +1915,14 @@
- AC_DEFINE(KDRIVEFBDEV, 1, [Build fbdev-based kdrive server])
- fi
-
--
-- PKG_CHECK_MODULES([TSLIB], [tslib-0.0], [HAVE_TSLIB="yes"], [HAVE_TSLIB="no"])
-+dnl Do tripple check for tslib in the transition phase to unversioned pkgconfig files...
-+ PKG_CHECK_MODULES([TSLIB], [tslib], [HAVE_TSLIB="yes"], [
-+ PKG_CHECK_MODULES([TSLIB], [tslib-1.0], [HAVE_TSLIB="yes"], [
-+ PKG_CHECK_MODULES([TSLIB], [tslib-0.0], [HAVE_TSLIB="yes"], [
-+ HAVE_TSLIB="no"
-+ ])
-+ ])
-+ ])
- if test "x$HAVE_TSLIB" = xno; then
- AC_CHECK_LIB(ts, ts_open, [HAVE_TSLIB="yes"])
- fi
diff --git a/x11-base/xorg-server/files/xorg-server-1.7.6-tslib-as-needed.patch b/x11-base/xorg-server/files/xorg-server-1.7.6-tslib-as-needed.patch
new file mode 100644
index 000000000000..6e1b3e59401c
--- /dev/null
+++ b/x11-base/xorg-server/files/xorg-server-1.7.6-tslib-as-needed.patch
@@ -0,0 +1,25 @@
+From c5eeb329f06a3c58704351261f8633c0ed753f18 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Mon, 4 Oct 2010 19:02:29 +0200
+Subject: [PATCH] Fix linking with tslib, with -Wl,--as-needed.
+
+---
+ configure.ac | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 4408e86..47df6c3 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1981,7 +1981,7 @@ if test "$KDRIVE" = yes; then
+ KDRIVE_LOCAL_LIBS="$MAIN_LIB $DIX_LIB $KDRIVE_LIB $KDRIVE_STUB_LIB $CONFIG_LIB"
+ KDRIVE_LOCAL_LIBS="$KDRIVE_LOCAL_LIBS $FB_LIB $MI_LIB $KDRIVE_PURE_LIBS"
+ KDRIVE_LOCAL_LIBS="$KDRIVE_LOCAL_LIBS $KDRIVE_OS_LIB $OS_LIB"
+- KDRIVE_LIBS="$TSLIB_LIBS $KDRIVE_LOCAL_LIBS $XSERVER_SYS_LIBS $GLX_SYS_LIBS"
++ KDRIVE_LIBS="$KDRIVE_LOCAL_LIBS $XSERVER_SYS_LIBS $GLX_SYS_LIBS $TSLIB_LIBS"
+
+ AC_SUBST([XEPHYR_LIBS])
+ AC_SUBST([XEPHYR_INCS])
+--
+1.7.3.1
+
diff --git a/x11-base/xorg-server/xorg-server-1.7.6.ebuild b/x11-base/xorg-server/xorg-server-1.7.6.ebuild
index b8ac1d0e76a3..1c37b5bf9cfd 100644
--- a/x11-base/xorg-server/xorg-server-1.7.6.ebuild
+++ b/x11-base/xorg-server/xorg-server-1.7.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/xorg-server-1.7.6.ebuild,v 1.11 2010/09/05 11:59:11 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/xorg-server-1.7.6.ebuild,v 1.12 2010/10/04 20:33:59 mgorny Exp $
EAPI="2"
@@ -126,12 +126,14 @@ UPSTREAMED_PATCHES=(
# Fix from bug http://bugs.freedesktop.org/show_bug.cgi?id=25400
"${FILESDIR}/1.7.3.901-0001-dix-if-owner-events-is-true-for-passive-grabs-add-th.patch"
- # Fix for bug #304067
- "${FILESDIR}/1.7.5.902-fix-tslib-1.0-check.patch"
)
PATCHES=(
"${UPSTREAMED_PATCHES[@]}"
+
+ # Fixes for bug #318609
+ "${FILESDIR}"/0001-Fix-tslib-check-fallback-to-set-TSLIB_LIBS.patch
+ "${FILESDIR}"/${P}-tslib-as-needed.patch
)
pkg_setup() {
diff --git a/x11-base/xorg-server/xorg-server-1.7.7-r1.ebuild b/x11-base/xorg-server/xorg-server-1.7.7-r1.ebuild
index df445c825109..7cb1fdce1f69 100644
--- a/x11-base/xorg-server/xorg-server-1.7.7-r1.ebuild
+++ b/x11-base/xorg-server/xorg-server-1.7.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/xorg-server-1.7.7-r1.ebuild,v 1.9 2010/09/26 19:03:06 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/xorg-server-1.7.7-r1.ebuild,v 1.10 2010/10/04 20:33:59 mgorny Exp $
EAPI="2"
@@ -126,13 +126,15 @@ EPATCH_SUFFIX="patch"
# These have been sent upstream
UPSTREAMED_PATCHES=(
"${WORKDIR}/patches/"
- # Fix for bug #304067
- "${FILESDIR}/1.7.5.902-fix-tslib-1.0-check.patch"
"${FILESDIR}"/${PN}-1.8-nouveau-default.patch
)
PATCHES=(
"${UPSTREAMED_PATCHES[@]}"
+
+ # Fixes for bug #318609
+ "${FILESDIR}"/0001-Fix-tslib-check-fallback-to-set-TSLIB_LIBS.patch
+ "${FILESDIR}"/${PN}-1.7.6-tslib-as-needed.patch
)
pkg_setup() {
diff --git a/x11-base/xorg-server/xorg-server-1.8.2.ebuild b/x11-base/xorg-server/xorg-server-1.8.2.ebuild
index 86bbf9e6cf60..6943dea21df3 100644
--- a/x11-base/xorg-server/xorg-server-1.8.2.ebuild
+++ b/x11-base/xorg-server/xorg-server-1.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/xorg-server-1.8.2.ebuild,v 1.2 2010/09/05 11:59:11 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/xorg-server-1.8.2.ebuild,v 1.3 2010/10/04 20:33:59 mgorny Exp $
EAPI=3
XORG_EAUTORECONF="yes"
@@ -104,6 +104,10 @@ PATCHES=(
"${UPSTREAMED_PATCHES[@]}"
"${FILESDIR}"/${PN}-disable-acpi.patch
"${FILESDIR}"/${PN}-1.8-nouveau-default.patch
+
+ # Fixes for bug #318609
+ "${FILESDIR}"/0001-Fix-tslib-check-fallback-to-set-TSLIB_LIBS.patch
+ "${FILESDIR}"/0002-Fix-linking-with-tslib-with-Wl-as-needed.patch
)
pkg_setup() {
diff --git a/x11-base/xorg-server/xorg-server-1.9.0-r2.ebuild b/x11-base/xorg-server/xorg-server-1.9.0-r2.ebuild
index 3bcefa478a1b..f3094a7ff11f 100644
--- a/x11-base/xorg-server/xorg-server-1.9.0-r2.ebuild
+++ b/x11-base/xorg-server/xorg-server-1.9.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/xorg-server-1.9.0-r2.ebuild,v 1.2 2010/09/30 02:48:32 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/xorg-server-1.9.0-r2.ebuild,v 1.3 2010/10/04 20:33:59 mgorny Exp $
EAPI=3
inherit xorg-2 multilib versionator
@@ -105,8 +105,11 @@ PATCHES=(
"${UPSTREAMED_PATCHES[@]}"
"${FILESDIR}"/${PN}-disable-acpi.patch
"${FILESDIR}"/${PN}-1.9-nouveau-default.patch
- "${FILESDIR}"/1.7.5.902-fix-tslib-1.0-check.patch
"${FILESDIR}"/1.9.0-fix-VbeModeInfoBlock-memcpy.patch
+
+ # Fixes for bug #318609
+ "${FILESDIR}"/0001-Fix-tslib-check-fallback-to-set-TSLIB_LIBS.patch
+ "${FILESDIR}"/0002-Fix-linking-with-tslib-with-Wl-as-needed.patch
)
pkg_setup() {
@@ -153,6 +156,10 @@ pkg_setup() {
--with-os-vendor=Gentoo
${conf_opts}"
+ if use kdrive && use tslib; then
+ XORG_EAUTORECONF=yes
+ fi
+
# Xorg-server requires includes from OS mesa which are not visible for
# users of binary drivers.
# Due to the limitations of CONFIGURE_OPTIONS, we have to export this