summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-08-08 06:28:13 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-08-08 06:28:13 +0000
commit57fb94ba97fd17987ae03bea4bd04417b795d84b (patch)
tree9bfd00b09ca8ce22f5f0c789638e86d6e99bbc25 /x11-apps/xkbutils
parentversion bump (diff)
downloadgentoo-2-57fb94ba97fd17987ae03bea4bd04417b795d84b.tar.gz
gentoo-2-57fb94ba97fd17987ae03bea4bd04417b795d84b.tar.bz2
gentoo-2-57fb94ba97fd17987ae03bea4bd04417b795d84b.zip
Initial commit for modular X.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'x11-apps/xkbutils')
-rw-r--r--x11-apps/xkbutils/ChangeLog10
-rw-r--r--x11-apps/xkbutils/Manifest2
-rw-r--r--x11-apps/xkbutils/files/digest-xkbutils-0.99.01
-rw-r--r--x11-apps/xkbutils/xkbutils-0.99.0.ebuild23
4 files changed, 36 insertions, 0 deletions
diff --git a/x11-apps/xkbutils/ChangeLog b/x11-apps/xkbutils/ChangeLog
new file mode 100644
index 000000000000..5e0e2f17938b
--- /dev/null
+++ b/x11-apps/xkbutils/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-apps/xkbutils
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xkbutils/ChangeLog,v 1.1 2005/08/08 06:28:11 spyderous Exp $
+
+*xkbutils-0.99.0 (08 Aug 2005)
+
+ 08 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>;
+ +xkbutils-0.99.0.ebuild:
+ Initial commit for modular X.
+
diff --git a/x11-apps/xkbutils/Manifest b/x11-apps/xkbutils/Manifest
new file mode 100644
index 000000000000..f050f2d28d61
--- /dev/null
+++ b/x11-apps/xkbutils/Manifest
@@ -0,0 +1,2 @@
+MD5 1df8b0c5c65b2b12c4e60fdc957a2e67 xkbutils-0.99.0.ebuild 516
+MD5 d005ea700b22101a43beaafc75fabdbd files/digest-xkbutils-0.99.0 67
diff --git a/x11-apps/xkbutils/files/digest-xkbutils-0.99.0 b/x11-apps/xkbutils/files/digest-xkbutils-0.99.0
new file mode 100644
index 000000000000..7b127dbd4b76
--- /dev/null
+++ b/x11-apps/xkbutils/files/digest-xkbutils-0.99.0
@@ -0,0 +1 @@
+MD5 4b582a91d311314c379ab10acca22540 xkbutils-0.99.0.tar.bz2 63754
diff --git a/x11-apps/xkbutils/xkbutils-0.99.0.ebuild b/x11-apps/xkbutils/xkbutils-0.99.0.ebuild
new file mode 100644
index 000000000000..807357e3ab35
--- /dev/null
+++ b/x11-apps/xkbutils/xkbutils-0.99.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xkbutils/xkbutils-0.99.0.ebuild,v 1.1 2005/08/08 06:28:11 spyderous Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xkbutils application"
+KEYWORDS="~x86"
+IUSE="xprint"
+RDEPEND="x11-libs/libxkbfile
+ x11-libs/libXaw"
+DEPEND="${RDEPEND}"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}