summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2009-01-13 02:47:48 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2009-01-13 02:47:48 +0000
commit587c499f1086e6b513f5ef320ddb6ffd46e94a66 (patch)
treead6d5ccabc93a3921236274f7bb84e0f2f5135ab /x11-apps/xedit
parentBump. Use correct conversion specifier for Py_ssize_t arguments. Fix connect ... (diff)
downloadgentoo-2-587c499f1086e6b513f5ef320ddb6ffd46e94a66.tar.gz
gentoo-2-587c499f1086e6b513f5ef320ddb6ffd46e94a66.tar.bz2
gentoo-2-587c499f1086e6b513f5ef320ddb6ffd46e94a66.zip
Bump. Way too many changes for a package that should be dead. Make ispell interface work correctly again. Add perl and "auto tools" modes. Add python mode. Assorted bugfixes.
(Portage version: 2.1.6.4/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'x11-apps/xedit')
-rw-r--r--x11-apps/xedit/ChangeLog11
-rw-r--r--x11-apps/xedit/xedit-1.1.2.ebuild29
2 files changed, 38 insertions, 2 deletions
diff --git a/x11-apps/xedit/ChangeLog b/x11-apps/xedit/ChangeLog
index 4f3fc0f0808d..c1f67725f0ef 100644
--- a/x11-apps/xedit/ChangeLog
+++ b/x11-apps/xedit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-apps/xedit
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xedit/ChangeLog,v 1.21 2008/03/24 14:03:05 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xedit/ChangeLog,v 1.22 2009/01/13 02:47:48 dberkholz Exp $
+
+*xedit-1.1.2 (13 Jan 2009)
+
+ 13 Jan 2009; Donnie Berkholz <dberkholz@gentoo.org>; +xedit-1.1.2.ebuild:
+ Bump. Way too many changes for a package that should be dead. Make ispell
+ interface work correctly again. Add perl and "auto tools" modes. Add
+ python mode. Assorted bugfixes.
24 Mar 2008; Markus Meier <maekke@gentoo.org> xedit-1.0.2.ebuild:
amd64 stable, bug #202087
diff --git a/x11-apps/xedit/xedit-1.1.2.ebuild b/x11-apps/xedit/xedit-1.1.2.ebuild
new file mode 100644
index 000000000000..6c3999e902e2
--- /dev/null
+++ b/x11-apps/xedit/xedit-1.1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xedit/xedit-1.1.2.ebuild,v 1.1 2009/01/13 02:47:48 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="simple text editor for X"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="xprint"
+RDEPEND="x11-libs/libXprintUtil
+ x11-libs/libXaw
+ xprint? ( x11-libs/libXprintUtil )"
+DEPEND="${RDEPEND}"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}
+
+#src_compile() {
+# x-modular_src_configure
+# emake -j1 || die "emake failed"
+#}