summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-01-28 07:52:04 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-01-28 07:52:04 +0000
commitd021c704918af6d3f6ac6dbc3fa23646b30e28e0 (patch)
tree6453d5ebe96014393f41210cf6cad6ade1475ef7 /x11-apps/xdm/xdm-1.1.11-r1.ebuild
parentRe-adding now that upstream has made it into a gem and no longer bundles it. (diff)
downloadgentoo-2-d021c704918af6d3f6ac6dbc3fa23646b30e28e0.tar.gz
gentoo-2-d021c704918af6d3f6ac6dbc3fa23646b30e28e0.tar.bz2
gentoo-2-d021c704918af6d3f6ac6dbc3fa23646b30e28e0.zip
Import native support for ConsoleKit wrt #360987
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'x11-apps/xdm/xdm-1.1.11-r1.ebuild')
-rw-r--r--x11-apps/xdm/xdm-1.1.11-r1.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/x11-apps/xdm/xdm-1.1.11-r1.ebuild b/x11-apps/xdm/xdm-1.1.11-r1.ebuild
new file mode 100644
index 000000000000..c1c4109d259a
--- /dev/null
+++ b/x11-apps/xdm/xdm-1.1.11-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/xdm-1.1.11-r1.ebuild,v 1.1 2012/01/28 07:52:04 ssuominen Exp $
+
+EAPI=4
+
+XORG_EAUTORECONF=yes
+
+inherit multilib xorg-2 pam systemd
+
+DEFAULTVT=vt7
+
+DESCRIPTION="X.Org xdm application"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="consolekit ipv6 pam"
+
+RDEPEND="x11-apps/xrdb
+ x11-libs/libXdmcp
+ x11-libs/libXaw
+ >=x11-apps/xinit-1.0.2-r3
+ x11-libs/libXinerama
+ x11-libs/libXmu
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-apps/sessreg
+ x11-apps/xconsole
+ consolekit? ( sys-auth/consolekit )
+ pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ x11-proto/xineramaproto
+ x11-proto/xproto"
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/${PN}-consolekit.patch )
+
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ $(use_with pam)
+ "$(systemd_with_unitdir)"
+ --with-default-vt=${DEFAULTVT}
+ --with-xdmconfigdir=/etc/X11/xdm
+ $(use_with consolekit)
+ )
+}
+
+src_install() {
+ xorg-2_src_install
+
+ exeinto /usr/$(get_libdir)/X11/xdm
+ doexe "${FILESDIR}"/Xsession
+
+ use pam && pamd_mimic system-local-login xdm auth account session
+
+ # Keep /var/lib/xdm. This is where authfiles are stored. See #286350.
+ keepdir /var/lib/xdm
+}
+
+pkg_postinst() {
+ # Mea culpa, feel free to remove that after some time --mgorny.
+ if [[ -L "${ROOT}"/etc/systemd/system/graphical.target.wants/${PN}'@tty7'.service ]]
+ then
+ ebegin "Renaming ${PN}@tty7.service to ${PN}.service"
+ ln -s "${ROOT}"/lib/systemd/system/xdm.service \
+ "${ROOT}"/etc/systemd/system/graphical.target.wants/${PN}.service && \
+ rm -f "${ROOT}"/etc/systemd/system/graphical.target.wants/${PN}'@tty7'.service
+ eend ${?} \
+ "Please try to re-enable xdm.service"
+ fi
+}