summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-07-17 07:34:08 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-07-17 07:34:08 +0000
commit9c73e95d789a13c77b75e287aa24b8ef3bd82131 (patch)
tree5f27ecbe068d2b338e860fa4f41905f13afd068c /www-servers
parentsci-biology/abyss: Moved to autotools-utils.eclass (diff)
downloadgentoo-2-9c73e95d789a13c77b75e287aa24b8ef3bd82131.tar.gz
gentoo-2-9c73e95d789a13c77b75e287aa24b8ef3bd82131.tar.bz2
gentoo-2-9c73e95d789a13c77b75e287aa24b8ef3bd82131.zip
Version bump
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/cherokee/ChangeLog10
-rw-r--r--www-servers/cherokee/cherokee-1.2.103.ebuild203
-rw-r--r--www-servers/cherokee/files/cherokee-1.2.103-fix-Makefile-CTK.patch11
-rw-r--r--www-servers/cherokee/files/cherokee-1.2.103-fix-configure.ac.patch16
-rw-r--r--www-servers/cherokee/files/cherokee-1.2.103-linux3.patch36
5 files changed, 275 insertions, 1 deletions
diff --git a/www-servers/cherokee/ChangeLog b/www-servers/cherokee/ChangeLog
index a99b649b5c06..178b955b4361 100644
--- a/www-servers/cherokee/ChangeLog
+++ b/www-servers/cherokee/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-servers/cherokee
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/cherokee/ChangeLog,v 1.97 2013/07/05 17:49:14 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/cherokee/ChangeLog,v 1.98 2013/07/17 07:34:08 blueness Exp $
+
+*cherokee-1.2.103 (17 Jul 2013)
+
+ 17 Jul 2013; Anthony G. Basile <blueness@gentoo.org> +cherokee-1.2.103.ebuild,
+ +files/cherokee-1.2.103-fix-Makefile-CTK.patch,
+ +files/cherokee-1.2.103-fix-configure.ac.patch,
+ +files/cherokee-1.2.103-linux3.patch:
+ Version bump
*cherokee-1.2.101-r3 (05 Jul 2013)
diff --git a/www-servers/cherokee/cherokee-1.2.103.ebuild b/www-servers/cherokee/cherokee-1.2.103.ebuild
new file mode 100644
index 000000000000..c2c2722596e3
--- /dev/null
+++ b/www-servers/cherokee/cherokee-1.2.103.ebuild
@@ -0,0 +1,203 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/cherokee/cherokee-1.2.103.ebuild,v 1.1 2013/07/17 07:34:08 blueness Exp $
+
+EAPI="5"
+PYTHON_DEPEND="admin? 2"
+PYTHON_USE_WITH="threads"
+
+WANT_AUTOMAKE="1.11"
+
+inherit autotools eutils multilib pam python systemd
+
+DESCRIPTION="An extremely fast and tiny web server."
+SRC_URI="https://github.com/cherokee/webserver/archive/v${PV}.zip"
+HOMEPAGE="http://www.cherokee-project.com/"
+S="${WORKDIR}"/webserver-${PV}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="admin ffmpeg debug geoip ipv6 kernel_linux ldap mysql nls pam php rrdtool ssl static static-libs"
+
+COMMON_DEPEND="dev-libs/libpcre
+ >=sys-libs/zlib-1.1.4-r1
+ ffmpeg? ( virtual/ffmpeg )
+ geoip? ( dev-libs/geoip )
+ ldap? ( net-nds/openldap )
+ mysql? ( >=virtual/mysql-5 )
+ nls? ( virtual/libintl )
+ pam? ( virtual/pam )
+ php? ( || (
+ dev-lang/php[fpm]
+ dev-lang/php[cgi]
+ ) )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )"
+RDEPEND="${COMMON_DEPEND}
+ rrdtool? ( net-analyzer/rrdtool )"
+
+RESTRICT="test"
+
+WEBROOT="/var/www/localhost"
+
+pkg_setup() {
+ python_pkg_setup
+
+ python_set_active_version 2
+
+ enewgroup cherokee
+ enewuser cherokee -1 -1 /var/www cherokee
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${PN}-1.2.99-gentoo.patch" \
+ "${FILESDIR}/${PN}-1.2.103-linux3.patch" \
+ "${FILESDIR}/${PN}-1.2.103-fix-configure.ac.patch" \
+ "${FILESDIR}/${PN}-1.2.103-fix-Makefile-CTK.patch"
+
+ ${S}/po/admin/generate_POTFILESin.py > po/admin/POTFILES.in
+ eautoreconf
+
+ python_convert_shebangs -r 2 .
+}
+
+src_configure() {
+ local myconf
+
+ if use admin ; then
+ myconf="${myconf} --enable-admin --with-python=$(PYTHON -2)"
+ else
+ myconf="${myconf} --disable-admin --without-python"
+ fi
+
+ # Uses autodetect because --with-php requires path to php-{fpm,cgi}.
+ if ! use php ; then
+ myconf="${myconf} --without-php"
+ fi
+
+ if use static ; then
+ myconf="${myconf} --enable-static-module=all"
+ fi
+
+ local os="Unknown"
+ case "${CHOST}" in
+ *-freebsd*)
+ os="FreeBSD" ;;
+ *-netbsd*)
+ os="NetBSD" ;;
+ *-openbsd*)
+ os="OpenBSD" ;;
+ *)
+ os="Linux" ;;
+ esac
+
+ # This make cherokee 1.2 sad
+ # $(use_enable threads pthread) \
+ econf \
+ $(use_enable debug trace) \
+ $(use_enable debug backtraces) \
+ $(use_enable ipv6) \
+ $(use_enable kernel_linux epoll) \
+ $(use_enable nls) \
+ $(use_enable pam) \
+ $(use_enable static-libs static) \
+ $(use_with ffmpeg) \
+ $(use_with geoip) \
+ $(use_with ldap) \
+ $(use_with mysql) \
+ $(use_with ssl libssl) \
+ --disable-dependency-tracking \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ --enable-os-string="Gentoo ${os}" \
+ --enable-tmpdir="${EPREFIX}/var/tmp" \
+ --localstatedir="${EPREFIX}/var" \
+ --with-wwwroot="${EPREFIX}${WEBROOT}/htdocs" \
+ --with-cgiroot="${EPREFIX}${WEBROOT}/cgi-bin" \
+ --with-wwwuser=cherokee \
+ --with-wwwgroup=cherokee \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if ! use static-libs ; then
+ find "${ED}" -name '*.la' -delete || die
+ elif ! use static ; then
+ find "${ED}/usr/$(get_libdir)/cherokee" '(' -name '*.la' -o -name '*.a' ')' -delete || die
+ fi
+
+ dodoc AUTHORS NEWS README.rst
+
+ if use pam ; then
+ pamd_mimic system-auth cherokee auth account session || die
+ fi
+
+ newinitd "${FILESDIR}/${PN}-initd-1.2.99" ${PN}
+ newconfd "${FILESDIR}/${PN}-confd-1.2.98" ${PN}
+
+ if ! use admin ; then
+ rm -r \
+ "${ED}"/usr/bin/cherokee-admin-launcher \
+ "${ED}"/usr/bin/CTK-run \
+ "${ED}"/usr/sbin/cherokee-admin \
+ "${ED}"/usr/share/cherokee/admin || die
+ fi
+
+ exeinto /usr/share/doc/${PF}/contrib
+ doexe contrib/{bin2buffer.py,make-cert.sh,make-dh_params.sh,tracelor.py}
+
+ #move the htdocs to docdir, bug #429632
+ docompress -x /usr/share/doc/"${PF}"/htdocs.dist
+ mv "${ED}"${WEBROOT}/htdocs \
+ "${ED}"/usr/share/doc/"${PF}"/htdocs.dist
+ mkdir "${ED}"${WEBROOT}/htdocs
+
+ keepdir \
+ "${WEBROOT}"/htdocs \
+ /var/log/cherokee \
+ /var/lib/cherokee/graphs/images
+ fowners cherokee:cherokee \
+ /var/log/cherokee \
+ /var/lib/cherokee/graphs \
+ /var/lib/cherokee/graphs/images
+
+ # logrotate
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotate-r1 ${PN}
+
+ systemd_dounit "${FILESDIR}"/cherokee.service
+}
+
+pkg_postinst() {
+ elog
+ if use admin ; then
+ python_mod_optimize "${EPREFIX}/usr/share/cherokee/admin/"
+ elog "Just run '/usr/sbin/cherokee-admin' and go to: http://localhost:9090"
+ elog
+ elog "Cherokee currently supports configuration versioning, so from now on,"
+ elog "whenever a change is made to the configuration file format,"
+ elog "Cherokee-Admin will be able to automatically convert yours to the new"
+ elog "release. You simply have to load Cherokee-Admin and it will be converted"
+ elog "once you proceed to saving it."
+ elog
+ elog "There is also a command line utility that you can use to do the exact"
+ elog "same thing. Config format can change in different versions. It is"
+ elog "provided under:"
+ elog " ${EPREFIX}/usr/share/cherokee/admin/upgrade_config.py"
+ else
+ elog "Try USE=admin if you want an easy way to configure cherokee."
+ fi
+ elog
+ elog "emerge www-servers/spawn-fcgi if you use Ruby on Rails with ${PN}."
+ elog
+}
+
+pkg_postrm() {
+ if use admin ; then
+ python_mod_cleanup "${EPREFIX}/usr/share/cherokee/admin/"
+ fi
+}
diff --git a/www-servers/cherokee/files/cherokee-1.2.103-fix-Makefile-CTK.patch b/www-servers/cherokee/files/cherokee-1.2.103-fix-Makefile-CTK.patch
new file mode 100644
index 000000000000..98b31823e4dc
--- /dev/null
+++ b/www-servers/cherokee/files/cherokee-1.2.103-fix-Makefile-CTK.patch
@@ -0,0 +1,11 @@
+diff -Naur webserver-1.2.103.orig/admin/Makefile.am webserver-1.2.103/admin/Makefile.am
+--- webserver-1.2.103.orig/admin/Makefile.am 2013-01-26 17:52:44.000000000 -0500
++++ webserver-1.2.103/admin/Makefile.am 2013-07-17 03:28:32.000000000 -0400
+@@ -1,6 +1,6 @@
+ ## Cherokee: Makefile.am -*- makefile -*-
+
+-SUBDIRS = plugins wizards CTK icons
++SUBDIRS = plugins wizards icons
+
+ if INSTALL_ADMIN
+ SUBDIRS += static
diff --git a/www-servers/cherokee/files/cherokee-1.2.103-fix-configure.ac.patch b/www-servers/cherokee/files/cherokee-1.2.103-fix-configure.ac.patch
new file mode 100644
index 000000000000..3292c1bd7a37
--- /dev/null
+++ b/www-servers/cherokee/files/cherokee-1.2.103-fix-configure.ac.patch
@@ -0,0 +1,16 @@
+diff -Naur webserver-1.2.103.orig/configure.ac webserver-1.2.103/configure.ac
+--- webserver-1.2.103.orig/configure.ac 2013-01-26 17:52:44.000000000 -0500
++++ webserver-1.2.103/configure.ac 2013-07-15 08:36:01.000000000 -0400
+@@ -1597,12 +1597,6 @@
+ admin/static/images/flags/Makefile
+ admin/static/images/wizards/Makefile
+ admin/static/images/other/Makefile
+-admin/CTK/Makefile
+-admin/CTK/CTK/Makefile
+-admin/CTK/static/css/Makefile
+-admin/CTK/static/images/Makefile
+-admin/CTK/static/js/Makefile
+-admin/CTK/static/Makefile
+ po/Makefile
+ ])
+
diff --git a/www-servers/cherokee/files/cherokee-1.2.103-linux3.patch b/www-servers/cherokee/files/cherokee-1.2.103-linux3.patch
new file mode 100644
index 000000000000..7f96f68ab97e
--- /dev/null
+++ b/www-servers/cherokee/files/cherokee-1.2.103-linux3.patch
@@ -0,0 +1,36 @@
+diff -Naur webserver-1.2.103.orig/admin/SystemStats.py webserver-1.2.103/admin/SystemStats.py
+--- webserver-1.2.103.orig/admin/SystemStats.py 2013-01-26 17:52:44.000000000 -0500
++++ webserver-1.2.103/admin/SystemStats.py 2013-07-15 07:27:11.000000000 -0400
+@@ -39,7 +39,7 @@
+ global _stats
+
+ if not _stats:
+- if sys.platform == 'linux2':
++ if sys.platform == 'linux2' or sys.platform == 'linux3':
+ _stats = System_stats__Linux()
+ elif sys.platform == 'darwin':
+ _stats = System_stats__Darwin()
+diff -Naur webserver-1.2.103.orig/admin/util.py webserver-1.2.103/admin/util.py
+--- webserver-1.2.103.orig/admin/util.py 2013-01-26 17:52:44.000000000 -0500
++++ webserver-1.2.103/admin/util.py 2013-07-15 07:29:12.000000000 -0400
+@@ -341,7 +341,7 @@
+ def os_get_document_root():
+ if sys.platform == 'darwin':
+ return "/Library/WebServer/Documents"
+- elif sys.platform == 'linux2':
++ elif sys.platform == 'linux2' or sys.platform == 'linux3':
+ if os.path.exists ("/etc/redhat-release"):
+ return '/var/www'
+ elif os.path.exists ("/etc/fedora-release"):
+diff -Naur webserver-1.2.103.orig/admin/wizards/php.py webserver-1.2.103/admin/wizards/php.py
+--- webserver-1.2.103.orig/admin/wizards/php.py 2013-01-26 17:52:44.000000000 -0500
++++ webserver-1.2.103/admin/wizards/php.py 2013-07-15 07:29:47.000000000 -0400
+@@ -607,7 +607,7 @@
+ first_group = str(root_group)
+
+ # Systems
+- if sys.platform == 'linux2':
++ if sys.platform == 'linux2' or sys.platform == 'linux3':
+ if os.getuid() == 0:
+ return root_group
+ return first_group