summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-10-25 03:42:11 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-10-25 03:42:11 +0000
commit9c02fd136ca45e9c44001aa779b6e96ecf7982e1 (patch)
tree002e0d8615317ddd72bdd39e8c5d615fc309e7d9 /www-servers
parentBump (diff)
downloadgentoo-2-9c02fd136ca45e9c44001aa779b6e96ecf7982e1.tar.gz
gentoo-2-9c02fd136ca45e9c44001aa779b6e96ecf7982e1.tar.bz2
gentoo-2-9c02fd136ca45e9c44001aa779b6e96ecf7982e1.zip
Bump
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/pound/ChangeLog7
-rw-r--r--www-servers/pound/pound-2.7d.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/www-servers/pound/ChangeLog b/www-servers/pound/ChangeLog
index 872afc027f5e..29cde1fc267e 100644
--- a/www-servers/pound/ChangeLog
+++ b/www-servers/pound/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/pound
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/ChangeLog,v 1.53 2014/08/10 20:08:55 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/ChangeLog,v 1.54 2014/10/25 03:42:11 patrick Exp $
+
+*pound-2.7d (25 Oct 2014)
+
+ 25 Oct 2014; Patrick Lauer <patrick@gentoo.org> +pound-2.7d.ebuild:
+ Bump
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> pound-2.5.ebuild,
pound-2.6.ebuild, pound-2.7a.ebuild:
diff --git a/www-servers/pound/pound-2.7d.ebuild b/www-servers/pound/pound-2.7d.ebuild
new file mode 100644
index 000000000000..1e58d6bde497
--- /dev/null
+++ b/www-servers/pound/pound-2.7d.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/pound-2.7d.ebuild,v 1.1 2014/10/25 03:42:11 patrick Exp $
+
+EAPI=5
+inherit eutils
+
+MY_P=${P/p/P}
+DESCRIPTION="A http/https reverse-proxy and load-balancer"
+HOMEPAGE="http://www.apsis.ch/pound/"
+SRC_URI="http://www.apsis.ch/pound/${MY_P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libpcre
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ dodir /usr/sbin
+ cp "${S}"/pound "${D}"/usr/sbin/
+ cp "${S}"/poundctl "${D}"/usr/sbin/
+
+ doman pound.8
+ doman poundctl.8
+ dodoc README FAQ
+
+ dodir /etc/init.d
+ newinitd "${FILESDIR}"/pound.init-1.9 pound
+
+ insinto /etc
+ newins "${FILESDIR}"/pound-2.2.cfg pound.cfg
+}
+
+pkg_postinst() {
+ elog "No demo-/sample-configfile is included in the distribution -"
+ elog "read the man-page for more info."
+ elog "A sample (localhost:8888 -> localhost:80) for gentoo is given in \"/etc/pound.cfg\"."
+ echo
+ ewarn "You will have to upgrade you configuration file, if you are"
+ ewarn "upgrading from a version <= 2.0."
+ echo
+ ewarn "The 'WebDAV' config statement is no longer supported!"
+ ewarn "Please adjust your configuration, if necessary."
+ echo
+}