summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-10-03 19:30:31 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-10-03 19:30:31 +0000
commit9857f3ad581c36f61d2ebed7a8de263f0857f050 (patch)
tree9a612a166fd9e2bb9cc319f03622fea13a94bd6c /www-servers
parentStable for HPPA (bug #524302). (diff)
downloadgentoo-2-9857f3ad581c36f61d2ebed7a8de263f0857f050.tar.gz
gentoo-2-9857f3ad581c36f61d2ebed7a8de263f0857f050.tar.bz2
gentoo-2-9857f3ad581c36f61d2ebed7a8de263f0857f050.zip
Version bump
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/thttpd/ChangeLog8
-rw-r--r--www-servers/thttpd/files/thttpd-renamed-htpasswd.patch4
-rw-r--r--www-servers/thttpd/thttpd-2.27.0.ebuild81
3 files changed, 90 insertions, 3 deletions
diff --git a/www-servers/thttpd/ChangeLog b/www-servers/thttpd/ChangeLog
index 7d1253ae81fe..f6d15514763d 100644
--- a/www-servers/thttpd/ChangeLog
+++ b/www-servers/thttpd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/thttpd
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/thttpd/ChangeLog,v 1.77 2014/08/10 20:09:17 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/thttpd/ChangeLog,v 1.78 2014/10/03 19:30:31 blueness Exp $
+
+*thttpd-2.27.0 (03 Oct 2014)
+
+ 03 Oct 2014; Anthony G. Basile <blueness@gentoo.org> +thttpd-2.27.0.ebuild,
+ files/thttpd-renamed-htpasswd.patch:
+ Version bump
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> thttpd-2.26.4-r2.ebuild,
thttpd-2.26.4-r3.ebuild, thttpd-9999.ebuild:
diff --git a/www-servers/thttpd/files/thttpd-renamed-htpasswd.patch b/www-servers/thttpd/files/thttpd-renamed-htpasswd.patch
index bdd4995f82c7..31e68429dbd6 100644
--- a/www-servers/thttpd/files/thttpd-renamed-htpasswd.patch
+++ b/www-servers/thttpd/files/thttpd-renamed-htpasswd.patch
@@ -104,5 +104,5 @@ index b1f3b4d..ffd19d7 100644
dist_sbin_SCRIPTS = syslogtocern
-
-install-exec-hook:
-- chgrp $(WEBGROUP) $(sbindir)/makeweb
-- chmod 2751 $(sbindir)/makeweb
+- chgrp $(WEBGROUP) $(DESTDIR)$(sbindir)/makeweb
+- chmod 2751 $(DESTDIR)$(sbindir)/makeweb
diff --git a/www-servers/thttpd/thttpd-2.27.0.ebuild b/www-servers/thttpd/thttpd-2.27.0.ebuild
new file mode 100644
index 000000000000..2e84bfca619c
--- /dev/null
+++ b/www-servers/thttpd/thttpd-2.27.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/thttpd/thttpd-2.27.0.ebuild,v 1.1 2014/10/03 19:30:31 blueness Exp $
+
+EAPI="5"
+
+inherit autotools eutils flag-o-matic toolchain-funcs user
+
+if [[ ${PV} = 9999* ]]
+then
+ EGIT_REPO_URI="git://opensource.dyc.edu/s${PN}.git"
+ inherit git-2
+ KEYWORDS=""
+else
+ MY_P="s${P}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="http://opensource.dyc.edu/pub/sthttpd/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+fi
+
+DESCRIPTION="Fork of thttpd, a small, fast, multiplexing webserver"
+HOMEPAGE="http://opensource.dyc.edu/sthttpd"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+WEBROOT="/var/www/localhost"
+
+THTTPD_USER=thttpd
+THTTPD_GROUP=thttpd
+THTTPD_DOCROOT="${EPREFIX}${WEBROOT}/htdocs"
+
+DOCS=( README TODO )
+
+pkg_setup() {
+ ebegin "Creating thttpd user and group"
+ enewgroup ${THTTPD_GROUP}
+ enewuser ${THTTPD_USER} -1 -1 -1 ${THTTPD_GROUP}
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/thttpd-renamed-htpasswd.patch
+ mv "${S}"/extras/{htpasswd.c,th_htpasswd.c}
+ eautoreconf -f -i
+}
+
+src_configure() {
+ econf WEBDIR=${THTTPD_DOCROOT}
+}
+
+src_install () {
+ default
+
+ newinitd "${FILESDIR}"/thttpd.init.1 thttpd
+ newconfd "${FILESDIR}"/thttpd.confd.1 thttpd
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/thttpd.logrotate" thttpd
+
+ insinto /etc/thttpd
+ doins "${FILESDIR}"/thttpd.conf.sample
+
+ #move htdocs to docdir, bug #429632
+ docompress -x /usr/share/doc/"${PF}"/htdocs.dist
+ mv "${ED}"${WEBROOT}/htdocs \
+ "${ED}"/usr/share/doc/"${PF}"/htdocs.dist
+ mkdir "${ED}"${WEBROOT}/htdocs
+
+ keepdir ${WEBROOT}/htdocs
+
+ chown root:${THTTPD_GROUP} "${ED}/usr/sbin/makeweb" \
+ || die "Failed chown makeweb"
+ chmod 2751 "${ED}/usr/sbin/makeweb" \
+ || die "Failed chmod makeweb"
+ chmod 755 "${ED}/usr/share/doc/${PF}/htdocs.dist/cgi-bin/printenv" \
+ || die "Failed chmod printenv"
+}