summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2006-08-16 14:54:37 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2006-08-16 14:54:37 +0000
commit2d86aa113a9e413a7d381bd2908f61b9eb734328 (patch)
tree158bf3aa7a469f608c8296491822a34662670fc5 /www-servers
parentVersion bump. Fix critical bug introduced into bugz post by last update. (diff)
downloadgentoo-2-2d86aa113a9e413a7d381bd2908f61b9eb734328.tar.gz
gentoo-2-2d86aa113a9e413a7d381bd2908f61b9eb734328.tar.bz2
gentoo-2-2d86aa113a9e413a7d381bd2908f61b9eb734328.zip
* bump and .54 stabilization
(Portage version: 2.1.1_pre5-r1)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog11
-rw-r--r--www-servers/nginx/files/digest-nginx-0.3.593
-rw-r--r--www-servers/nginx/nginx-0.3.54.ebuild4
-rw-r--r--www-servers/nginx/nginx-0.3.59.ebuild79
4 files changed, 92 insertions, 5 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 853cbf1486e5..a01fabf7c6f6 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.105 2006/08/15 00:08:07 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.106 2006/08/16 14:54:37 voxus Exp $
+
+*nginx-0.3.59 (16 Aug 2006)
+
+ 16 Aug 2006; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.3.59.ebuild,
+ -nginx-0.3.58.ebuild, -nginx-0.3.49.ebuid, nginx-0.3.54.ebuild:
+ Version bump, 0.3.54 goes stable on amd64 and x86.
*nginx-0.3.58 (15 Aug 2006)
@@ -22,8 +28,7 @@
*nginx-0.3.55 (28 Jul 2006)
- 28 Jul 2006; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.3.55.ebuild,
- -nginx-0.3.54.ebuild:
+ 28 Jul 2006; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.3.55.ebuild:
Version bump.
*nginx-0.3.54 (11 Jul 2006)
diff --git a/www-servers/nginx/files/digest-nginx-0.3.59 b/www-servers/nginx/files/digest-nginx-0.3.59
new file mode 100644
index 000000000000..b3577b21221f
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.3.59
@@ -0,0 +1,3 @@
+MD5 30ac75a4d83da87ca9daf2f57fbb7cb2 nginx-0.3.59.tar.gz 416215
+RMD160 a20753961e5f3249e041ee46c0b12ce98ba29328 nginx-0.3.59.tar.gz 416215
+SHA256 293cb3ea191fdd9cc8044057d05db5f9d3a8ac066b87f0ba820936da63684f7e nginx-0.3.59.tar.gz 416215
diff --git a/www-servers/nginx/nginx-0.3.54.ebuild b/www-servers/nginx/nginx-0.3.54.ebuild
index 665021d3ecb2..3c932e02a49f 100644
--- a/www-servers/nginx/nginx-0.3.54.ebuild
+++ b/www-servers/nginx/nginx-0.3.54.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.3.54.ebuild,v 1.1 2006/07/11 15:02:35 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.3.54.ebuild,v 1.2 2006/08/16 14:54:37 voxus Exp $
inherit eutils
@@ -10,7 +10,7 @@ HOMEPAGE="http://sysoev.ru/nginx/"
SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ~ppc x86"
IUSE="debug fastcgi imap pcre perl threads ssl zlib"
DEPEND="dev-lang/perl
diff --git a/www-servers/nginx/nginx-0.3.59.ebuild b/www-servers/nginx/nginx-0.3.59.ebuild
new file mode 100644
index 000000000000..4000711734de
--- /dev/null
+++ b/www-servers/nginx/nginx-0.3.59.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.3.59.ebuild,v 1.1 2006/08/16 14:54:37 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre perl threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use fastcgi && myconf="${myconf} --with-http_realip_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm --with-md5=/usr/include \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ cp ${FILESDIR}/nginx-r1 ${T}/nginx
+ doinitd ${T}/nginx
+
+ rm conf/nginx.conf
+ cp ${FILESDIR}/nginx.conf-r2 ${T}/nginx.conf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/* ${T}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+
+ use perl && {
+ cd ${S}/objs/src/http/modules/perl/
+ make DESTDIR=${D} install || die "failed to install perl stuff"
+ }
+}