summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-08-23 20:59:46 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-08-23 20:59:46 +0000
commit0c86e8ca74a1b6bcd5d28a5534b2dd270416cdd5 (patch)
tree4abb5733aa77ab23ceb7c5b5fb039a1e849aba03 /www-servers/varnish
parentarm stable, bug #430370 (diff)
downloadgentoo-2-0c86e8ca74a1b6bcd5d28a5534b2dd270416cdd5.tar.gz
gentoo-2-0c86e8ca74a1b6bcd5d28a5534b2dd270416cdd5.tar.bz2
gentoo-2-0c86e8ca74a1b6bcd5d28a5534b2dd270416cdd5.zip
Version bump
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'www-servers/varnish')
-rw-r--r--www-servers/varnish/ChangeLog8
-rw-r--r--www-servers/varnish/files/varnish-3.0.3-automagic.patch58
-rw-r--r--www-servers/varnish/varnish-3.0.3.ebuild66
3 files changed, 131 insertions, 1 deletions
diff --git a/www-servers/varnish/ChangeLog b/www-servers/varnish/ChangeLog
index 38b8f5bf8bcc..ab9f276915bb 100644
--- a/www-servers/varnish/ChangeLog
+++ b/www-servers/varnish/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/varnish
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/ChangeLog,v 1.51 2012/07/11 23:27:45 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/ChangeLog,v 1.52 2012/08/23 20:59:46 blueness Exp $
+
+*varnish-3.0.3 (23 Aug 2012)
+
+ 23 Aug 2012; Anthony G. Basile <blueness@gentoo.org> +varnish-3.0.3.ebuild,
+ +files/varnish-3.0.3-automagic.patch:
+ Version bump
11 Jul 2012; Anthony G. Basile <blueness@gentoo.org> varnish-2.0.4-r1.ebuild,
varnish-3.0.2-r1.ebuild:
diff --git a/www-servers/varnish/files/varnish-3.0.3-automagic.patch b/www-servers/varnish/files/varnish-3.0.3-automagic.patch
new file mode 100644
index 000000000000..b492e3c080b6
--- /dev/null
+++ b/www-servers/varnish/files/varnish-3.0.3-automagic.patch
@@ -0,0 +1,58 @@
+diff -Naur varnish-3.0.3.orig//configure.ac varnish-3.0.3/configure.ac
+--- varnish-3.0.3.orig//configure.ac 2012-08-20 05:20:40.000000000 -0400
++++ varnish-3.0.3/configure.ac 2012-08-23 15:58:15.000000000 -0400
+@@ -87,15 +87,20 @@
+
+ save_LIBS="${LIBS}"
+ LIBS=""
+-AC_SEARCH_LIBS(initscr, [curses ncurses],
+- [have_curses=yes], [have_curses=no])
+-CURSES_LIBS="${LIBS}"
+-LIBS="${save_LIBS}"
+-AC_SUBST(CURSES_LIBS)
+-if test "$have_curses" = no; then
+- AC_MSG_WARN([curses not found; some tools will not be built])
+-fi
+-AC_CHECK_HEADERS([ncurses/curses.h curses.h])
++AC_ARG_WITH([tools], AS_HELP_STRING([--without-tools],
++ [Don't build additional tools: varnishhist, varnishstat, varnishtop, varnishsizes (default: test)]))
++
++AS_IF([test "x$with_tools" != "xno"], [
++ AC_SEARCH_LIBS(initscr, [curses ncurses],
++ [have_curses=yes], [have_curses=no])
++ CURSES_LIBS="${LIBS}"
++ LIBS="${save_LIBS}"
++ AC_SUBST(CURSES_LIBS)
++ if test "$have_curses" = no; then
++ AC_MSG_ERROR([curses not found, required to build additional tools])
++ fi
++ AC_CHECK_HEADERS([ncurses/curses.h curses.h])
++])
+ AM_CONDITIONAL([HAVE_CURSES], [test x$have_curses = xyes])
+
+ save_LIBS="${LIBS}"
+@@ -147,17 +152,13 @@
+ AC_SUBST(PCRE_CFLAGS)
+ AC_SUBST(PCRE_LIBS)
+
+-PKG_CHECK_MODULES([LIBEDIT], [libedit],
+- [AC_DEFINE([HAVE_LIBEDIT], [1], [Define we have libedit])],
+- [AC_CHECK_HEADERS([readline/readline.h])
+- AC_CHECK_HEADERS([edit/readline/readline.h])
+- AC_CHECK_LIB(edit, el_init,
+- [ AC_DEFINE([HAVE_LIBEDIT], [1], [Define we have libedit])
+- LIBEDIT_CFLAGS=""
+- LIBEDIT_LIBS="-ledit ${CURSES_LIBS}"
+- ],
+- [AC_MSG_WARN([libedit not found, disabling libedit support])],
+- [${CURSES_LIBS}])])
++AC_ARG_WITH([libedit], AS_HELP_STRING([--with-libedit],
++ [Enable support for libedit in varnishadm (default: disabled)]))
++AS_IF([test "x$with_libedit" = "xyes"], [
++ PKG_CHECK_MODULES([LIBEDIT], [libedit],
++ [AC_DEFINE([HAVE_LIBEDIT], [1], [Define we have libedit])],
++ [AC_MSG_ERROR([libedit not found])])
++])
+
+ # Checks for header files.
+ AC_HEADER_STDC
diff --git a/www-servers/varnish/varnish-3.0.3.ebuild b/www-servers/varnish/varnish-3.0.3.ebuild
new file mode 100644
index 000000000000..c2e8ac5de738
--- /dev/null
+++ b/www-servers/varnish/varnish-3.0.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/varnish-3.0.3.ebuild,v 1.1 2012/08/23 20:59:46 blueness Exp $
+
+EAPI="4"
+
+inherit autotools-utils eutils
+
+DESCRIPTION="Varnish is a state-of-the-art, high-performance HTTP accelerator"
+HOMEPAGE="http://www.varnish-cache.org/"
+SRC_URI="http://repo.varnish-cache.org/source/${P}.tar.gz"
+
+LICENSE="BSD-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="doc libedit static-libs +tools"
+
+CDEPEND="dev-libs/libpcre
+ libedit? ( dev-libs/libedit )
+ tools? ( sys-libs/ncurses )"
+#varnish compiles stuff at run time
+RDEPEND="${CDEPEND}
+ sys-devel/gcc"
+DEPEND="${CDEPEND}
+ dev-python/docutils
+ virtual/pkgconfig"
+
+RESTRICT="test" #315725
+
+DOCS=( README doc/changes.rst )
+
+PATCHES=( "${FILESDIR}"/${PN}-3.0.3-automagic.patch )
+
+src_prepare() {
+ autotools-utils_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with libedit)
+ $(use_with tools)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ newinitd "${FILESDIR}"/varnishd.initd varnishd
+ newconfd "${FILESDIR}"/varnishd.confd varnishd
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/varnishd.logrotate" varnishd
+
+ dodir /var/log/varnish
+
+ use doc && dohtml -r "doc/sphinx/=build/html/"
+}
+
+pkg_postinst () {
+ elog "No demo-/sample-configfile is included in the distribution -"
+ elog "please read the man-page for more info."
+ elog "A sample (localhost:8080 -> localhost:80) for gentoo is given in"
+ elog " /etc/conf.d/varnishd"
+}