summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2014-10-28 13:43:14 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2014-10-28 13:43:14 +0000
commit477f72a9898310e1fbf723351c5ddc40d0fc1d04 (patch)
tree353c9747eacbf7ff15a328a3888df3b3497b9314 /www-servers/uwsgi
parentVersion bump - bug #527198 (diff)
downloadgentoo-2-477f72a9898310e1fbf723351c5ddc40d0fc1d04.tar.gz
gentoo-2-477f72a9898310e1fbf723351c5ddc40d0fc1d04.tar.bz2
gentoo-2-477f72a9898310e1fbf723351c5ddc40d0fc1d04.zip
fix upstream archive mismatch, use github as SRC_URI
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'www-servers/uwsgi')
-rw-r--r--www-servers/uwsgi/ChangeLog6
-rw-r--r--www-servers/uwsgi/files/2.0.8-threaded-php.patch39
-rw-r--r--www-servers/uwsgi/uwsgi-2.0.8.ebuild6
3 files changed, 8 insertions, 43 deletions
diff --git a/www-servers/uwsgi/ChangeLog b/www-servers/uwsgi/ChangeLog
index 46515f0739c5..1500043e8612 100644
--- a/www-servers/uwsgi/ChangeLog
+++ b/www-servers/uwsgi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-servers/uwsgi
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/uwsgi/ChangeLog,v 1.62 2014/10/27 16:40:14 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/uwsgi/ChangeLog,v 1.63 2014/10/28 13:43:14 ultrabug Exp $
+
+ 28 Oct 2014; Ultrabug <ultrabug@gentoo.org> uwsgi-2.0.8.ebuild,
+ -files/2.0.8-threaded-php.patch:
+ fix upstream archive mismatch, use github as SRC_URI
*uwsgi-2.0.8 (27 Oct 2014)
diff --git a/www-servers/uwsgi/files/2.0.8-threaded-php.patch b/www-servers/uwsgi/files/2.0.8-threaded-php.patch
deleted file mode 100644
index 10bd5189ad6f..000000000000
--- a/www-servers/uwsgi/files/2.0.8-threaded-php.patch
+++ /dev/null
@@ -1,39 +0,0 @@
---- a/plugins/php/php_plugin.c 2014-10-27 17:23:50.909755436 +0100
-+++ b/plugins/php/php_plugin.c 2014-10-27 17:25:24.970534680 +0100
-@@ -88,7 +88,7 @@
- return str_length;
- }
-
--static int sapi_uwsgi_send_headers(sapi_headers_struct *sapi_headers)
-+static int sapi_uwsgi_send_headers(sapi_headers_struct *sapi_headers TSRMLS_DC)
- {
- sapi_header_struct *h;
- zend_llist_position pos;
-@@ -146,7 +146,7 @@
- }
-
-
--static char *sapi_uwsgi_read_cookies(void)
-+static char *sapi_uwsgi_read_cookies(TSRMLS_D)
- {
- uint16_t len = 0;
- struct wsgi_request *wsgi_req = (struct wsgi_request *) SG(server_context);
-@@ -570,6 +570,10 @@
- struct uwsgi_string_list *pset = uphp.set;
- struct uwsgi_string_list *append_config = uphp.append_config;
-
-+#ifdef ZTS
-+ tsrm_startup(1, 1, 0, NULL);
-+#endif
-+
- if (!uphp.sapi_initialized) {
- sapi_startup(&uwsgi_sapi_module);
- uphp.sapi_initialized = 1;
-@@ -678,6 +682,7 @@
-
- zend_file_handle file_handle;
-
-+ TSRMLS_FETCH(); // fetch the threading state in case PHP is built with threading
- SG(server_context) = (void *) wsgi_req;
-
- if (uwsgi_parse_vars(wsgi_req)) {
diff --git a/www-servers/uwsgi/uwsgi-2.0.8.ebuild b/www-servers/uwsgi/uwsgi-2.0.8.ebuild
index ad69372e9b4d..c5fb93cfdf47 100644
--- a/www-servers/uwsgi/uwsgi-2.0.8.ebuild
+++ b/www-servers/uwsgi/uwsgi-2.0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/uwsgi/uwsgi-2.0.8.ebuild,v 1.1 2014/10/27 16:40:14 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/uwsgi/uwsgi-2.0.8.ebuild,v 1.2 2014/10/28 13:43:14 ultrabug Exp $
EAPI="5"
@@ -20,7 +20,7 @@ inherit apache-module distutils-r1 eutils multilib pax-utils php-ext-source-r2 p
DESCRIPTION="uWSGI server for Python web applications"
HOMEPAGE="http://projects.unbit.it/uwsgi/"
-SRC_URI="http://projects.unbit.it/downloads/${MY_P}.tar.gz"
+SRC_URI="https://github.com/unbit/uwsgi/archive/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -137,7 +137,7 @@ pkg_setup() {
src_prepare() {
epatch \
- "${FILESDIR}/2.0.8-threaded-php.patch"
+ "${FILESDIR}/1.1.2-threaded-php.patch"
sed -i \
-e "s|'-O2', ||" \