summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2006-12-17 18:22:23 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2006-12-17 18:22:23 +0000
commit579e531fc54b3b7ab1073671101bd10f34fc3aed (patch)
treeea5079a97c3c23bf9eef4dc77eba939187f53b69 /www-servers/nginx
parent+ status use @ nginx (diff)
downloadgentoo-2-579e531fc54b3b7ab1073671101bd10f34fc3aed.tar.gz
gentoo-2-579e531fc54b3b7ab1073671101bd10f34fc3aed.tar.bz2
gentoo-2-579e531fc54b3b7ab1073671101bd10f34fc3aed.zip
* closing bugs #156126 and 156426
(Portage version: 2.1.2_rc3-r6)
Diffstat (limited to 'www-servers/nginx')
-rw-r--r--www-servers/nginx/ChangeLog8
-rw-r--r--www-servers/nginx/files/digest-nginx-0.5.4-r13
-rw-r--r--www-servers/nginx/files/nginx.conf-r357
-rw-r--r--www-servers/nginx/nginx-0.5.4-r1.ebuild86
4 files changed, 153 insertions, 1 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 16fe40b5fd1d..6767f1500534 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.124 2006/12/17 13:09:55 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.125 2006/12/17 18:22:23 voxus Exp $
+
+*nginx-0.5.4-r1 (17 Dec 2006)
+
+ 17 Dec 2006; Konstantin V. Arkhipov <voxus@gentoo.org>
+ +files/nginx.conf-r3, +nginx-0.5.4-r1.ebuild:
+ Closing bugs #156126 and 156426.
*nginx-0.5.4 (17 Dec 2006)
diff --git a/www-servers/nginx/files/digest-nginx-0.5.4-r1 b/www-servers/nginx/files/digest-nginx-0.5.4-r1
new file mode 100644
index 000000000000..8ad087f5750a
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.5.4-r1
@@ -0,0 +1,3 @@
+MD5 2295a1f9441a0e48c5668544eef03d12 nginx-0.5.4.tar.gz 442554
+RMD160 c2b4c75e74bedd207262e1dca2778cbe37fe0f04 nginx-0.5.4.tar.gz 442554
+SHA256 746ae459965510e6441bfad75b06bb13c0038ea52469a83cc779c14b3bad8373 nginx-0.5.4.tar.gz 442554
diff --git a/www-servers/nginx/files/nginx.conf-r3 b/www-servers/nginx/files/nginx.conf-r3
new file mode 100644
index 000000000000..a924424b77a2
--- /dev/null
+++ b/www-servers/nginx/files/nginx.conf-r3
@@ -0,0 +1,57 @@
+user nginx nginx;
+worker_processes 1;
+
+error_log /var/log/nginx/error_log info;
+
+events {
+ worker_connections 8192;
+ use epoll;
+}
+
+http {
+ include /etc/nginx/mime.types;
+ default_type application/octet-stream;
+
+ log_format main
+ '$remote_addr - $remote_user [$time_local] '
+ '"$request" $status $bytes_sent '
+ '"$http_referer" "$http_user_agent" '
+ '"$gzip_ratio"';
+
+ client_header_timeout 10m;
+ client_body_timeout 10m;
+ send_timeout 10m;
+
+ connection_pool_size 256;
+ client_header_buffer_size 1k;
+ large_client_header_buffers 4 2k;
+ request_pool_size 4k;
+
+ gzip on;
+ gzip_min_length 1100;
+ gzip_buffers 4 8k;
+ gzip_types text/plain;
+
+ output_buffers 1 32k;
+ postpone_output 1460;
+
+ sendfile on;
+ tcp_nopush on;
+ tcp_nodelay on;
+
+ keepalive_timeout 75 20;
+
+ ignore_invalid_headers on;
+
+ index index.html;
+
+ server {
+ listen 127.0.0.1;
+ server_name localhost;
+
+ access_log /var/log/nginx/localhost.access_log main;
+ error_log /var/log/nginx/localhost.error_log;
+
+ root /var/www/localhost/htdocs;
+ }
+}
diff --git a/www-servers/nginx/nginx-0.5.4-r1.ebuild b/www-servers/nginx/nginx-0.5.4-r1.ebuild
new file mode 100644
index 000000000000..d53c9308c518
--- /dev/null
+++ b/www-servers/nginx/nginx-0.5.4-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.5.4-r1.ebuild,v 1.1 2006/12/17 18:22:23 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre perl threads ssl status zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+pkg_setup() {
+ ebegin "Creating nginx user and group"
+ enewgroup nginx
+ enewuser nginx -1 -1 /dev/null nginx
+ eend ${?}
+}
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use fastcgi && myconf="${myconf} --with-http_realip_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+ use status && myconf="${myconf} --with-http_stub_status_module"
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm --with-md5=/usr/include \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ cp ${FILESDIR}/nginx-r1 ${T}/nginx
+ doinitd ${T}/nginx
+
+ cp ${FILESDIR}/nginx.conf-r3 conf/nginx.conf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/*
+
+ dodoc CHANGES{,.ru} LICENSE README
+
+ use perl && {
+ cd ${S}/objs/src/http/modules/perl/
+ make DESTDIR=${D} install || die "failed to install perl stuff"
+ }
+}