summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-08 22:19:53 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-08 22:19:53 +0000
commitd8ae81ec6b8dd8946d350650b90d438078abed67 (patch)
tree15f4728eebcbd7c5e8151ba4cdbe7de44fd60cbf /www-servers/mini_httpd
parentFix building with GLIBC 2.10+ wrt #277567, thanks to Arttu Valo for patch. (diff)
downloadgentoo-2-d8ae81ec6b8dd8946d350650b90d438078abed67.tar.gz
gentoo-2-d8ae81ec6b8dd8946d350650b90d438078abed67.tar.bz2
gentoo-2-d8ae81ec6b8dd8946d350650b90d438078abed67.zip
Fix building with GLIBC 2.10+ wrt #278157.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'www-servers/mini_httpd')
-rw-r--r--www-servers/mini_httpd/ChangeLog8
-rw-r--r--www-servers/mini_httpd/files/mini_httpd-1.19-glibc-2.10.patch21
-rw-r--r--www-servers/mini_httpd/mini_httpd-1.19.ebuild15
3 files changed, 38 insertions, 6 deletions
diff --git a/www-servers/mini_httpd/ChangeLog b/www-servers/mini_httpd/ChangeLog
index 1c19dc038bf4..e84578356561 100644
--- a/www-servers/mini_httpd/ChangeLog
+++ b/www-servers/mini_httpd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-servers/mini_httpd
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/mini_httpd/ChangeLog,v 1.11 2008/12/21 21:58:57 caleb Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/mini_httpd/ChangeLog,v 1.12 2009/08/08 22:19:53 ssuominen Exp $
+
+ 08 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+ mini_httpd-1.19.ebuild, +files/mini_httpd-1.19-glibc-2.10.patch:
+ Fix building with GLIBC 2.10+ wrt #278157.
21 Dec 2008; Caleb Tennis <caleb@gentoo.org> mini_httpd-1.19.ebuild:
amd64 stable
diff --git a/www-servers/mini_httpd/files/mini_httpd-1.19-glibc-2.10.patch b/www-servers/mini_httpd/files/mini_httpd-1.19-glibc-2.10.patch
new file mode 100644
index 000000000000..082b0ed58062
--- /dev/null
+++ b/www-servers/mini_httpd/files/mini_httpd-1.19-glibc-2.10.patch
@@ -0,0 +1,21 @@
+diff -ur mini_httpd-1.19.orig/htpasswd.c mini_httpd-1.19/htpasswd.c
+--- mini_httpd-1.19.orig/htpasswd.c 2001-12-19 02:08:10.000000000 +0200
++++ mini_httpd-1.19/htpasswd.c 2009-08-09 01:20:36.000000000 +0300
+@@ -49,7 +49,7 @@
+ while((line[y++] = line[x++]));
+ }
+
+-static int getline(char *s, int n, FILE *f) {
++static int get_line(char *s, int n, FILE *f) {
+ register int i=0;
+
+ while(1) {
+@@ -189,7 +189,7 @@
+ strcpy(user,argv[2]);
+
+ found = 0;
+- while(!(getline(line,MAX_STRING_LEN,f))) {
++ while(!(get_line(line,MAX_STRING_LEN,f))) {
+ if(found || (line[0] == '#') || (!line[0])) {
+ putline(tfp,line);
+ continue;
diff --git a/www-servers/mini_httpd/mini_httpd-1.19.ebuild b/www-servers/mini_httpd/mini_httpd-1.19.ebuild
index 25fba8e77078..943f9147ec1d 100644
--- a/www-servers/mini_httpd/mini_httpd-1.19.ebuild
+++ b/www-servers/mini_httpd/mini_httpd-1.19.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/mini_httpd/mini_httpd-1.19.ebuild,v 1.10 2008/12/21 21:58:57 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/mini_httpd/mini_httpd-1.19.ebuild,v 1.11 2009/08/08 22:19:53 ssuominen Exp $
-inherit toolchain-funcs
+inherit eutils toolchain-funcs
DESCRIPTION="Small forking webserver with optional ssl and ipv6 support"
HOMEPAGE="http://www.acme.com/software/mini_httpd/"
@@ -13,7 +13,14 @@ SLOT="0"
KEYWORDS="amd64 ~ia64 ppc s390 sparc x86"
IUSE="ssl ipv6"
-DEPEND="ssl? ( dev-libs/openssl )"
+RDEPEND="ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+}
src_compile() {
## we need to hack a bit to have the correct install-dir -- no autoconf :(