summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2008-05-12 07:31:03 +0000
committerChristian Faulhammer <opfer@gentoo.org>2008-05-12 07:31:03 +0000
commit4d8da6180d8616ef5afc6a3dec4298849d8e9191 (patch)
treebb16a259e976cb6a34a4c55efba6e565b61526b2 /www-servers/boa
parentUse NEED_PYTHON to depend on python. Use distutils_src_unpack. swig is not a ... (diff)
downloadgentoo-2-4d8da6180d8616ef5afc6a3dec4298849d8e9191.tar.gz
gentoo-2-4d8da6180d8616ef5afc6a3dec4298849d8e9191.tar.bz2
gentoo-2-4d8da6180d8616ef5afc6a3dec4298849d8e9191.zip
Adjust DESCRIPTION; migrate from tetex USE flag to doc USE flag and change the dependency from virtual/tetex to latex-base, bug 196745; remove die comments; make doc USE flag install documentation including the now new boa.dvi; move sys-apps/flex from RDEPEND to DEPEND see bug 221349 by flameeyes
(Portage version: 2.1.4.4)
Diffstat (limited to 'www-servers/boa')
-rw-r--r--www-servers/boa/ChangeLog12
-rw-r--r--www-servers/boa/boa-0.94.14_rc21.ebuild31
2 files changed, 28 insertions, 15 deletions
diff --git a/www-servers/boa/ChangeLog b/www-servers/boa/ChangeLog
index c1e4153a9c37..771427d5910e 100644
--- a/www-servers/boa/ChangeLog
+++ b/www-servers/boa/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-servers/boa
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/boa/ChangeLog,v 1.14 2007/07/01 17:12:10 dirtyepic Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/boa/ChangeLog,v 1.15 2008/05/12 07:31:03 opfer Exp $
+
+ 12 May 2008; Christian Faulhammer <opfer@gentoo.org>
+ boa-0.94.14_rc21.ebuild:
+ Adjust DESCRIPTION; migrate from tetex USE flag to doc USE flag and change
+ the dependency from virtual/tetex to latex-base, bug 196745; remove die
+ comments; make doc USE flag install documentation including the now new
+ boa.dvi; move sys-apps/flex from RDEPEND to DEPEND see bug 221349 by
+ flameeyes
01 Jul 2007; Ryan Hill <dirtyepic@gentoo.org>
-files/boa-0.94.13-gcc3.patch, -files/boa-0.94.13-server_uid.patch,
diff --git a/www-servers/boa/boa-0.94.14_rc21.ebuild b/www-servers/boa/boa-0.94.14_rc21.ebuild
index efbe8e970c33..e88068f3b8e1 100644
--- a/www-servers/boa/boa-0.94.14_rc21.ebuild
+++ b/www-servers/boa/boa-0.94.14_rc21.ebuild
@@ -1,22 +1,24 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/boa/boa-0.94.14_rc21.ebuild,v 1.4 2007/07/01 17:09:02 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/boa/boa-0.94.14_rc21.ebuild,v 1.5 2008/05/12 07:31:03 opfer Exp $
inherit eutils
MY_PV=${PV/_/}
-DESCRIPTION="Boa - A very small and very fast http daemon."
+DESCRIPTION="A very small and very fast http daemon."
SRC_URI="http://www.boa.org/${PN}-${MY_PV}.tar.gz"
HOMEPAGE="http://www.boa.org/"
KEYWORDS="~x86 ~sparc ~mips ~ppc ~amd64"
LICENSE="GPL-2"
SLOT="0"
-IUSE="tetex"
+IUSE="doc"
S=${WORKDIR}/${PN}-${MY_PV}
-DEPEND="sys-devel/flex
- sys-devel/bison
- tetex? ( virtual/tetex )"
+
+RDEPEND="sys-devel/bison"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ doc? ( virtual/latex-base )"
src_unpack() {
unpack ${A}
@@ -27,18 +29,21 @@ src_unpack() {
}
src_compile() {
- econf || die "econf failed"
- emake || die "emake failed"
- use tetex || sed -i -e '/^all:/s/boa.dvi //' docs/Makefile
- emake docs || die "emake docs failed"
+ econf || die
+ emake || die
+ use doc || sed -i -e '/^all:/s/boa.dvi //' docs/Makefile
+ emake docs || die
}
src_install() {
dosbin src/boa
doman docs/boa.8
- dodoc docs/boa.html
- dodoc docs/boa_banner.png
doinfo docs/boa.info
+ if use doc; then
+ dodoc docs/boa.html
+ dodoc docs/boa_banner.png
+ dodoc docs/boa.dvi
+ fi
keepdir /var/log/boa
dodir /var/www/localhost/htdocs