summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-10-18 16:20:16 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-10-18 16:20:16 +0000
commitf714993eb809e00744e3ab069811fd65399f7b14 (patch)
tree828ccd0cca72d9c84e5ed03971b09e276135092b /www-plugins
parenttidy (diff)
downloadgentoo-2-f714993eb809e00744e3ab069811fd65399f7b14.tar.gz
gentoo-2-f714993eb809e00744e3ab069811fd65399f7b14.tar.bz2
gentoo-2-f714993eb809e00744e3ab069811fd65399f7b14.zip
Version bump, bug #340066. Require LLVM 2.7 during build, bug #340437.
(Portage version: 2.2_rc97/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/lightspark/ChangeLog9
-rw-r--r--www-plugins/lightspark/files/lightspark-0.4.4.3-cmakelists.patch (renamed from www-plugins/lightspark/files/lightspark-0.4.4.2-cmakelists.patch)20
-rw-r--r--www-plugins/lightspark/lightspark-0.4.4.3.ebuild (renamed from www-plugins/lightspark/lightspark-0.4.4.2.ebuild)9
3 files changed, 24 insertions, 14 deletions
diff --git a/www-plugins/lightspark/ChangeLog b/www-plugins/lightspark/ChangeLog
index 02c8f7343234..e75c3f6beecf 100644
--- a/www-plugins/lightspark/ChangeLog
+++ b/www-plugins/lightspark/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-plugins/lightspark
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.18 2010/09/14 19:25:06 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.19 2010/10/18 16:20:16 chithanh Exp $
+
+*lightspark-0.4.4.3 (18 Oct 2010)
+
+ 18 Oct 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ -lightspark-0.4.4.2.ebuild, -files/lightspark-0.4.4.2-cmakelists.patch,
+ +lightspark-0.4.4.3.ebuild, +files/lightspark-0.4.4.3-cmakelists.patch:
+ Version bump, bug #340066. Require LLVM 2.7 during build, bug #340437.
14 Sep 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
lightspark-0.4.4.2.ebuild:
diff --git a/www-plugins/lightspark/files/lightspark-0.4.4.2-cmakelists.patch b/www-plugins/lightspark/files/lightspark-0.4.4.3-cmakelists.patch
index 19d881a07ec5..4921ecb402a1 100644
--- a/www-plugins/lightspark/files/lightspark-0.4.4.2-cmakelists.patch
+++ b/www-plugins/lightspark/files/lightspark-0.4.4.3-cmakelists.patch
@@ -1,16 +1,16 @@
diff -ur a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2010-09-11 21:34:25.000000000 +0200
-+++ b/CMakeLists.txt 2010-09-13 17:19:30.384369002 +0200
-@@ -310,7 +310,7 @@
- ADD_LIBRARY(spark STATIC ${LIBSPARK_SOURCES})
- ENDIF (CMAKE_COMPILER_IS_GNUCC)
-
--TARGET_LINK_LIBRARIES(spark ${EXTRA_LIBS_LIBRARIES} ${ZLIB_LIBRARIES} ${Boost_LIBRARIES} ${LLVM_LIBS_CORE} ${LLVM_LIBS_JIT} ${SDL_LIBRARY} ${OPTIONAL_LIBRARIES} ${GTK_LIBRARIES} ${FREETYPE_LIBRARIES} ${OPENGL_LIBRARIES} ${FTGL_LIBRARIES} ${GLEW_LIBRARIES} ${PCRECPP_LIBRARIES} ${Threads_LIBRARIES})
-+TARGET_LINK_LIBRARIES(spark ${CMAKE_MODULE_LINKER_FLAGS} ${EXTRA_LIBS_LIBRARIES} ${ZLIB_LIBRARIES} ${Boost_LIBRARIES} ${LLVM_LIBS_CORE} ${LLVM_LIBS_JIT} ${SDL_LIBRARY} ${OPTIONAL_LIBRARIES} ${GTK_LIBRARIES} ${FREETYPE_LIBRARIES} ${OPENGL_LIBRARIES} ${FTGL_LIBRARIES} ${GLEW_LIBRARIES} ${PCRECPP_LIBRARIES} ${Threads_LIBRARIES})
+--- a/CMakeLists.txt 2010-09-24 19:17:38.000000000 +0200
++++ b/CMakeLists.txt 2010-10-18 17:57:45.168022354 +0200
+@@ -321,7 +321,7 @@
+ ${Boost_LIBRARIES} ${LLVM_LIBS_CORE} ${LLVM_LIBS_JIT} ${SDL_LIBRARY}
+ ${OPTIONAL_LIBRARIES} ${GTK_LIBRARIES} ${FREETYPE_LIBRARIES}
+ ${OPENGL_LIBRARIES} ${FTGL_LIBRARIES} ${GLEW_LIBRARIES} ${PCRECPP_LIBRARIES}
+- ${Threads_LIBRARIES} ${XMLPP_LIBRARIES})
++ ${Threads_LIBRARIES} ${XMLPP_LIBRARIES} ${CMAKE_MODULE_LINKER_FLAGS})
SET_TARGET_PROPERTIES(spark PROPERTIES VERSION "${MAJOR_VERSION}.${MINOR_VERSION}.${PATCH_VERSION}")
SET_TARGET_PROPERTIES(spark PROPERTIES SOVERSION "${MAJOR_VERSION}.${MINOR_VERSION}")
-@@ -322,7 +322,7 @@
+@@ -333,7 +333,7 @@
IF(COMPILE_LIGHTSPARK)
ADD_EXECUTABLE(lightspark main.cpp)
TARGET_LINK_LIBRARIES(lightspark spark)
@@ -19,7 +19,7 @@ diff -ur a/CMakeLists.txt b/CMakeLists.txt
IF(UNIX)
INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/lightspark.frag DESTINATION ${DATADIR}/lightspark)
-@@ -336,7 +336,7 @@
+@@ -347,7 +347,7 @@
IF(COMPILE_TIGHTSPARK)
ADD_EXECUTABLE(tightspark tightspark.cpp)
TARGET_LINK_LIBRARIES(tightspark spark)
diff --git a/www-plugins/lightspark/lightspark-0.4.4.2.ebuild b/www-plugins/lightspark/lightspark-0.4.4.3.ebuild
index f6086de6795b..8ea241f7537c 100644
--- a/www-plugins/lightspark/lightspark-0.4.4.2.ebuild
+++ b/www-plugins/lightspark/lightspark-0.4.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/lightspark-0.4.4.2.ebuild,v 1.2 2010/09/14 19:25:06 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/lightspark-0.4.4.3.ebuild,v 1.1 2010/10/18 16:20:16 chithanh Exp $
EAPI=3
inherit cmake-utils nsplugins multilib
@@ -14,7 +14,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="nsplugin pulseaudio"
-RDEPEND="dev-libs/libpcre[cxx]
+RDEPEND="dev-cpp/libxmlpp:2.6
+ dev-libs/libpcre[cxx]
media-fonts/liberation-fonts
media-video/ffmpeg
media-libs/fontconfig
@@ -35,14 +36,16 @@ RDEPEND="dev-libs/libpcre[cxx]
x11-libs/gtkglext
)
x11-libs/libX11"
+# Require sys-devel/llvm-2.7 during build, bug #340437
DEPEND="${RDEPEND}
+ =sys-devel/llvm-2.7*
dev-lang/nasm
dev-util/pkgconfig"
S=${WORKDIR}/${P/_rc*/}
PATCHES=(
- "${FILESDIR}"/${PN}-0.4.4.2-cmakelists.patch
+ "${FILESDIR}"/${PN}-0.4.4.3-cmakelists.patch
)
src_configure() {