summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMounir Lamouri <volkmar@gentoo.org>2009-09-16 18:12:44 +0000
committerMounir Lamouri <volkmar@gentoo.org>2009-09-16 18:12:44 +0000
commit72b12e85a1df745082d1b4e4fb71a2e562e366fd (patch)
tree0ad48bcbf95f072eff3d783abb4a85ee81a55e11 /www-plugins
parentstable x86, bug 284976 (diff)
downloadgentoo-2-72b12e85a1df745082d1b4e4fb71a2e562e366fd.tar.gz
gentoo-2-72b12e85a1df745082d1b4e4fb71a2e562e366fd.tar.bz2
gentoo-2-72b12e85a1df745082d1b4e4fb71a2e562e366fd.zip
Version bump to 1.9.8.86.
Bug 282468. (Portage version: 14103-svn/cvs/Linux ppc)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/noscript/ChangeLog8
-rw-r--r--www-plugins/noscript/noscript-1.9.8.86.ebuild68
2 files changed, 75 insertions, 1 deletions
diff --git a/www-plugins/noscript/ChangeLog b/www-plugins/noscript/ChangeLog
index 1316adef23ad..5f8abaa5a264 100644
--- a/www-plugins/noscript/ChangeLog
+++ b/www-plugins/noscript/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-plugins/noscript
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/noscript/ChangeLog,v 1.5 2009/09/15 01:50:05 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/noscript/ChangeLog,v 1.6 2009/09/16 18:12:44 volkmar Exp $
+
+*noscript-1.9.8.86 (16 Sep 2009)
+
+ 16 Sep 2009; Mounir Lamouri <volkmar@gentoo.org>
+ +noscript-1.9.8.86.ebuild:
+ Version bump to 1.9.8.86. Bug 282468
15 Sep 2009; Jeroen Roovers <jer@gentoo.org> noscript-1.9.6.6.ebuild:
Stable for HPPA (bug #282466).
diff --git a/www-plugins/noscript/noscript-1.9.8.86.ebuild b/www-plugins/noscript/noscript-1.9.8.86.ebuild
new file mode 100644
index 000000000000..6462967621f0
--- /dev/null
+++ b/www-plugins/noscript/noscript-1.9.8.86.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/noscript/noscript-1.9.8.86.ebuild,v 1.1 2009/09/16 18:12:44 volkmar Exp $
+
+inherit mozextension multilib
+
+DESCRIPTION="Restrict active contents in your web browser"
+HOMEPAGE="http://noscript.net/"
+SRC_URI="http://software.informaction.com/data/releases/${P}.xpi"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ || (
+ >=www-client/mozilla-firefox-1.5
+ >=www-client/mozilla-firefox-bin-1.5
+ >=www-client/seamonkey-1.1
+ >=www-client/seamonkey-bin-1.1
+ )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+# NOTES:
+# can also be used for Flock, MidBrowser, eMusic, Toolkit, Songbird, Fennec
+
+src_unpack() {
+ xpi_unpack "${P}".xpi
+}
+
+src_install() {
+ local MOZILLA_FIVE_HOME
+ mozillas=""
+
+ if has_version '>=www-client/mozilla-firefox-1.5'; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-firefox"
+ xpi_install "${WORKDIR}/${P}"
+ mozillas="$(best_version www-client/mozilla-firefox) ${mozillas}"
+ fi
+ if has_version '>=www-client/mozilla-firefox-bin-1.5'; then
+ MOZILLA_FIVE_HOME="/opt/firefox"
+ xpi_install "${WORKDIR}/${P}"
+ mozillas="$(best_version www-client/mozilla-firefox-bin) ${mozillas}"
+ fi
+ if has_version '>=www-client/seamonkey-1.1'; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/seamonkey"
+ xpi_install "${WORKDIR}/${P}"
+ mozillas="$(best_version www-client/seamonkey) ${mozillas}"
+ fi
+ if has_version '>=www-client/seamonkey-bin-1.1'; then
+ MOZILLA_FIVE_HOME="/opt/seamonkey"
+ xpi_install "${WORKDIR}/${P}"
+ mozillas="$(best_version www-client/seamonkey-bin) ${mozillas}"
+ fi
+}
+
+pkg_postinst() {
+ elog "NoScript has been installed for the following packages:"
+ for i in ${mozillas}; do
+ elog " $i"
+ done
+ elog
+ elog "After installing other mozilla ebuilds, if you want to use noscript with them"
+ elog "reinstall www-plugins/noscript"
+}