summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2011-06-17 02:25:58 +0000
committerPatrick McLean <chutzpah@gentoo.org>2011-06-17 02:25:58 +0000
commit36c492595393ddf48c63224a66c9919677492ba1 (patch)
tree00f15c25dc3949a018b153edc89a58a1e8e6922e /www-plugins
parentFix RDEPEND/DEPEND again. (diff)
downloadgentoo-2-36c492595393ddf48c63224a66c9919677492ba1.tar.gz
gentoo-2-36c492595393ddf48c63224a66c9919677492ba1.tar.bz2
gentoo-2-36c492595393ddf48c63224a66c9919677492ba1.zip
Version bump (bug #371705). Forward port the parallel make patch, it appears upstream has the old version.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/nspluginwrapper/ChangeLog10
-rw-r--r--www-plugins/nspluginwrapper/files/nspluginwrapper-1.4.2-parallel-make.patch67
-rw-r--r--www-plugins/nspluginwrapper/nspluginwrapper-1.4.2.ebuild95
3 files changed, 171 insertions, 1 deletions
diff --git a/www-plugins/nspluginwrapper/ChangeLog b/www-plugins/nspluginwrapper/ChangeLog
index 67d98bc23505..2245e13de0d1 100644
--- a/www-plugins/nspluginwrapper/ChangeLog
+++ b/www-plugins/nspluginwrapper/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-plugins/nspluginwrapper
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/nspluginwrapper/ChangeLog,v 1.15 2011/05/30 14:24:04 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/nspluginwrapper/ChangeLog,v 1.16 2011/06/17 02:25:58 chutzpah Exp $
+
+*nspluginwrapper-1.4.2 (17 Jun 2011)
+
+ 17 Jun 2011; Patrick McLean <chutzpah@gentoo.org>
+ +nspluginwrapper-1.4.2.ebuild,
+ +files/nspluginwrapper-1.4.2-parallel-make.patch:
+ Version bump (bug #371705). Forward port the parallel make patch, it appears
+ upstream has the old version.
30 May 2011; Patrick McLean <chutzpah@gentoo.org>
nspluginwrapper-1.4.0-r1.ebuild:
diff --git a/www-plugins/nspluginwrapper/files/nspluginwrapper-1.4.2-parallel-make.patch b/www-plugins/nspluginwrapper/files/nspluginwrapper-1.4.2-parallel-make.patch
new file mode 100644
index 000000000000..b3280d6b2c75
--- /dev/null
+++ b/www-plugins/nspluginwrapper/files/nspluginwrapper-1.4.2-parallel-make.patch
@@ -0,0 +1,67 @@
+diff -ur nspluginwrapper-1.4.2.orig//Makefile nspluginwrapper-1.4.2/Makefile
+--- nspluginwrapper-1.4.2.orig//Makefile 2011-06-04 14:41:40.000000000 -0400
++++ nspluginwrapper-1.4.2/Makefile 2011-06-16 22:11:07.059551179 -0400
+@@ -14,7 +14,7 @@
+ endif
+
+ ifeq ($(INSTALL),)
+-INSTALL = install
++INSTALL = install -D
+ ifneq (,$(findstring $(OS),solaris))
+ INSTALL = $(SRC_PATH)/utils/install.sh
+ endif
+@@ -236,44 +236,40 @@
+ uninstall.mkruntime:
+ rm -f $(DESTDIR)$(npcommondir)/mkruntime
+
+-install: install.dirs install.player install.wrapper install.viewer install.libnoxshm install.loader install.config
+-install.dirs:
+- mkdir -p $(DESTDIR)$(npcommondir) || :
+- mkdir -p $(DESTDIR)$(nphostdir) || :
+- mkdir -p $(DESTDIR)$(nptargetdir) || :
++install: install.player install.wrapper install.viewer install.libnoxshm install.loader install.config
+ ifeq ($(build_player),yes)
+-install.player: install.dirs $(npplayer_PROGRAM)
++install.player: $(npplayer_PROGRAM)
+ $(INSTALL) -m 755 $(STRIP_OPT) $(npplayer_PROGRAM) $(DESTDIR)$(nphostdir)/$(npplayer_PROGRAM)
+ mkdir -p $(DESTDIR)$(bindir)
+ $(LN_S) $(nphostdir)/$(npplayer_PROGRAM) $(DESTDIR)$(bindir)/nspluginplayer
+ else
+ install.player:
+ endif
+-install.wrapper: install.dirs $(npwrapper_LIBRARY)
++install.wrapper: $(npwrapper_LIBRARY)
+ $(INSTALL) -m 755 $(STRIP_OPT) $(npwrapper_LIBRARY) $(DESTDIR)$(nphostdir)/$(npwrapper_LIBRARY)
+ ifeq ($(build_viewer),yes)
+-install.viewer: install.dirs install.viewer.bin install.viewer.glue
+-install.libnoxshm: install.dirs do.install.libnoxshm
++install.viewer: install.viewer.bin install.viewer.glue
++install.libnoxshm: do.install.libnoxshm
+ else
+ install.viewer:
+ install.libnoxshm:
+ endif
+-install.viewer.bin: install.dirs $(npviewer_PROGRAM)
++install.viewer.bin: $(npviewer_PROGRAM)
+ $(INSTALL) -m 755 $(STRIP_OPT) $(npviewer_PROGRAM) $(DESTDIR)$(nptargetdir)/$(npviewer_PROGRAM)
+-install.viewer.glue:: install.dirs
++install.viewer.glue:: install.viewer.bin
+ p=$(DESTDIR)$(nptargetdir)/$(npviewer_PROGRAM:%.bin=%); \
+ echo "#!/bin/sh" > $$p; \
+ echo "TARGET_OS=$(TARGET_OS)" >> $$p; \
+ echo "TARGET_ARCH=$(TARGET_ARCH)" >> $$p; \
+ echo ". $(npcommondir)/$(nploader_PROGRAM)" >> $$p; \
+ chmod 755 $$p
+-do.install.libnoxshm: install.dirs $(libnoxshm_LIBRARY)
++do.install.libnoxshm: $(libnoxshm_LIBRARY)
+ $(INSTALL) -m 755 $(STRIP_OPT) $(libnoxshm_LIBRARY) $(DESTDIR)$(nptargetdir)/$(libnoxshm_LIBRARY)
+-install.config: install.dirs $(npconfig_PROGRAM)
++install.config: $(npconfig_PROGRAM)
+ $(INSTALL) -m 755 $(STRIP_OPT) $(npconfig_PROGRAM) $(DESTDIR)$(nphostdir)/$(npconfig_PROGRAM)
+ mkdir -p $(DESTDIR)$(bindir)
+ $(LN_S) $(nphostdir)/$(npconfig_PROGRAM) $(DESTDIR)$(bindir)/nspluginwrapper
+-install.loader: install.dirs $(nploader_PROGRAM)
++install.loader: $(nploader_PROGRAM)
+ $(INSTALL) -m 755 $(nploader_PROGRAM) $(DESTDIR)$(npcommondir)/$(nploader_PROGRAM)
+ install.mkruntime: $(SRC_PATH)/utils/mkruntime.sh
+ $(INSTALL) -m 755 $< $(DESTDIR)$(npcommondir)/mkruntime
diff --git a/www-plugins/nspluginwrapper/nspluginwrapper-1.4.2.ebuild b/www-plugins/nspluginwrapper/nspluginwrapper-1.4.2.ebuild
new file mode 100644
index 000000000000..02c6c94014e2
--- /dev/null
+++ b/www-plugins/nspluginwrapper/nspluginwrapper-1.4.2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/nspluginwrapper/nspluginwrapper-1.4.2.ebuild,v 1.1 2011/06/17 02:25:58 chutzpah Exp $
+
+EAPI=2
+
+inherit eutils multilib nsplugins flag-o-matic
+
+DESCRIPTION="Netscape Plugin Wrapper - Load 32bit plugins on 64bit browser"
+HOMEPAGE="http://nspluginwrapper.davidben.net/"
+SRC_URI="http://web.mit.edu/davidben/Public/nspluginwrapper/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2:2
+ net-misc/curl
+ app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-gtklibs
+ >=sys-apps/util-linux-2.13"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+autoinstall() {
+ if [[ -x /usr/bin/${PN} ]]; then
+ einfo "Auto installing 32bit plugins..."
+ ${PN} -a -i
+ ls /usr/$(get_libdir)/nsbrowser/plugins
+
+ # Remove wrappers if equivalent 64-bit plugins exist
+ # TODO: May be better to patch nspluginwrapper so it doesn't create
+ # duplicate wrappers in the first place...
+ local DIR64="${ROOT}/usr/$(get_libdir)/nsbrowser/plugins/"
+ for f in "${DIR64}"/npwrapper.*.so; do
+ local PLUGIN=${f##*/npwrapper.}
+ if [[ -f ${DIR64}/${PLUGIN} ]]; then
+ einfo " Removing duplicate wrapper for native 64-bit ${PLUGIN}"
+ ${PN} -r "${f}"
+ fi
+ done
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.3.0-gdk-native-windows.patch"
+ epatch "${FILESDIR}/${P}-parallel-make.patch"
+}
+
+src_configure() {
+ replace-flags -O3 -O2
+
+ ./configure --enable-biarch \
+ --target-cpu=i386 \
+ --with-lib32=$(ABI=x86 get_libdir) \
+ --with-lib64=$(get_libdir) \
+ --pkglibdir=/usr/$(get_libdir)/${PN}
+}
+
+src_compile() {
+ emake LDFLAGS_32="-m32 ${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dosym "/usr/$(get_libdir)/${PN}/x86_64/linux/npconfig" "/usr/bin/${PN}"
+ keepdir "/usr/$(get_libdir)/${PLUGINS_DIR}"
+
+ dodoc NEWS README TODO
+}
+
+pkg_postinst() {
+ autoinstall
+ elog "Any 32bit plugins you currently have installed have now been"
+ elog "configured to work in a 64bit browser. Any plugins you install in"
+ elog "the future will first need to be setup with:"
+ elog " \"nspluginwrapper -i <path-to-32bit-plugin>\""
+ elog "before they will function in a 64bit browser"
+ elog
+}
+
+# this is terribly ugly, but without a way to query portage as to whether
+# we are upgrading/reinstalling a package versus unmerging, I can't think of
+# a better way
+
+pkg_prerm() {
+ einfo "Removing wrapper plugins..."
+ ${PN} --auto --remove
+}
+
+pkg_postrm() {
+ autoinstall
+}