summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-02-27 11:28:38 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-02-27 11:28:38 +0000
commite4af9f40afabbdb418ce5c88b587841c984dab50 (patch)
tree2f50f4c54dd1bd645d9086ac977d8710ebbc9052 /www-plugins/gnash
parentVersion bump. (diff)
downloadgentoo-2-e4af9f40afabbdb418ce5c88b587841c984dab50.tar.gz
gentoo-2-e4af9f40afabbdb418ce5c88b587841c984dab50.tar.bz2
gentoo-2-e4af9f40afabbdb418ce5c88b587841c984dab50.zip
Allow building nsplugin against npapi-sdk, bug #383071.
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins/gnash')
-rw-r--r--www-plugins/gnash/ChangeLog6
-rw-r--r--www-plugins/gnash/files/gnash-0.8.10-npapi-sdk.patch29
-rw-r--r--www-plugins/gnash/gnash-0.8.10.ebuild12
3 files changed, 44 insertions, 3 deletions
diff --git a/www-plugins/gnash/ChangeLog b/www-plugins/gnash/ChangeLog
index 61ba15f94709..f3a41412b411 100644
--- a/www-plugins/gnash/ChangeLog
+++ b/www-plugins/gnash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-plugins/gnash
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/ChangeLog,v 1.77 2012/02/27 01:23:22 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/ChangeLog,v 1.78 2012/02/27 11:28:38 chithanh Exp $
+
+ 27 Feb 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ gnash-0.8.10.ebuild, +files/gnash-0.8.10-npapi-sdk.patch:
+ Allow building nsplugin against npapi-sdk, bug #383071.
27 Feb 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
gnash-0.8.10.ebuild:
diff --git a/www-plugins/gnash/files/gnash-0.8.10-npapi-sdk.patch b/www-plugins/gnash/files/gnash-0.8.10-npapi-sdk.patch
new file mode 100644
index 000000000000..eb542959e3be
--- /dev/null
+++ b/www-plugins/gnash/files/gnash-0.8.10-npapi-sdk.patch
@@ -0,0 +1,29 @@
+From 983a675c94ecec54ae14593744aa9a2198466499 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Thu, 15 Sep 2011 12:59:55 +0200
+Subject: [PATCH] Support building against NPAPI-SDK as well.
+
+---
+ macros/npapi.m4 | 6 +++++-
+ 1 files changed, 5 insertions(+), 1 deletions(-)
+
+diff --git a/macros/npapi.m4 b/macros/npapi.m4
+index e3bde2f..522bbb1 100644
+--- a/macros/npapi.m4
++++ b/macros/npapi.m4
+@@ -34,7 +34,11 @@ AC_DEFUN([GNASH_PATH_NPAPI],
+
+ if test x$cross_compiling = xno; then
+ if test x"$PKG_CONFIG" != x -a x"${ac_cv_path_npapi_incl}" = x; then
+- $PKG_CONFIG --exists mozilla-plugin && NPAPI_CFLAGS="`$PKG_CONFIG --cflags mozilla-plugin`"
++ if $PKG_CONFIG --exists npapi-sdk; then
++ NPAPI_CFLAGS="`$PKG_CONFIG --cflags npapi-sdk`"
++ elif $PKG_CONFIG --exists mozilla-plugin; then
++ NPAPI_CFLAGS="`$PKG_CONFIG --cflags mozilla-plugin`"
++ fi
+ fi
+ fi
+
+--
+1.7.3.4
+
diff --git a/www-plugins/gnash/gnash-0.8.10.ebuild b/www-plugins/gnash/gnash-0.8.10.ebuild
index 00c082d87ded..ea1c0c7a4c24 100644
--- a/www-plugins/gnash/gnash-0.8.10.ebuild
+++ b/www-plugins/gnash/gnash-0.8.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.10.ebuild,v 1.4 2012/02/27 01:23:22 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.10.ebuild,v 1.5 2012/02/27 11:28:38 chithanh Exp $
EAPI=4
CMAKE_REQUIRED="never"
@@ -90,7 +90,12 @@ RDEPEND=">=dev-libs/boost-1.41.0
openvg? (
media-libs/mesa[openvg]
)
- nsplugin? ( >=net-libs/xulrunner-1.9.2:1.9 )
+ nsplugin? (
+ || (
+ net-misc/npapi-sdk
+ >=net-libs/xulrunner-1.9.2:1.9
+ )
+ )
sdl? ( media-libs/libsdl[X] )
sdl-sound? ( media-libs/libsdl )
media-libs/speex[ogg]
@@ -150,6 +155,9 @@ src_prepare() {
# Fix libamf includes
epatch "${FILESDIR}"/${PN}-0.8.10-amf-include.patch
+ # Allow building against npapi-sdk, bug #383071
+ epatch "${FILESDIR}"/${PN}-0.8.10-npapi-sdk.patch
+
eautoreconf
}
src_configure() {