summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2010-07-20 14:49:58 +0000
committerJim Ramsay <lack@gentoo.org>2010-07-20 14:49:58 +0000
commit660ea017225584224aba785da4ef830e5ffee54b (patch)
tree0a9afdf835ec52a858688dfe02c9dba80ea9609c /www-plugins/adobe-flash
parentVersion bump (diff)
downloadgentoo-2-660ea017225584224aba785da4ef830e5ffee54b.tar.gz
gentoo-2-660ea017225584224aba785da4ef830e5ffee54b.tar.bz2
gentoo-2-660ea017225584224aba785da4ef830e5ffee54b.zip
Move plugin install path to /opt/Adobe/flash-plugin (Bug #328639)
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins/adobe-flash')
-rw-r--r--www-plugins/adobe-flash/ChangeLog11
-rw-r--r--www-plugins/adobe-flash/adobe-flash-10.0.45.2-r2.ebuild181
-rw-r--r--www-plugins/adobe-flash/adobe-flash-10.1.53.64-r1.ebuild161
-rw-r--r--www-plugins/adobe-flash/adobe-flash-9.0.277.0-r1.ebuild57
4 files changed, 409 insertions, 1 deletions
diff --git a/www-plugins/adobe-flash/ChangeLog b/www-plugins/adobe-flash/ChangeLog
index 9002f6030cf2..d8414e5fd997 100644
--- a/www-plugins/adobe-flash/ChangeLog
+++ b/www-plugins/adobe-flash/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for www-plugins/adobe-flash
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/ChangeLog,v 1.35 2010/07/11 10:46:49 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/ChangeLog,v 1.36 2010/07/20 14:49:58 lack Exp $
+
+*adobe-flash-10.1.53.64-r1 (20 Jul 2010)
+*adobe-flash-10.0.45.2-r2 (20 Jul 2010)
+*adobe-flash-9.0.277.0-r1 (20 Jul 2010)
+
+ 20 Jul 2010; Jim Ramsay <lack@gentoo.org>
+ +adobe-flash-9.0.277.0-r1.ebuild, +adobe-flash-10.0.45.2-r2.ebuild,
+ +adobe-flash-10.1.53.64-r1.ebuild:
+ Move plugin install path to /opt/Adobe/flash-plugin (Bug #328639)
11 Jul 2010; Fabio Erculiani <lxnay@gentoo.org>
adobe-flash-10.1.53.64.ebuild:
diff --git a/www-plugins/adobe-flash/adobe-flash-10.0.45.2-r2.ebuild b/www-plugins/adobe-flash/adobe-flash-10.0.45.2-r2.ebuild
new file mode 100644
index 000000000000..41c6c67d5f3a
--- /dev/null
+++ b/www-plugins/adobe-flash/adobe-flash-10.0.45.2-r2.ebuild
@@ -0,0 +1,181 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/adobe-flash-10.0.45.2-r2.ebuild,v 1.1 2010/07/20 14:49:58 lack Exp $
+
+EAPI=1
+inherit nsplugins rpm multilib toolchain-funcs
+
+MY_32B_URI="http://fpdownload.macromedia.com/get/flashplayer/current/flash-plugin-${PV}-release.i386.rpm"
+MY_64B_URI="http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-${PV}.linux-x86_64.so.tar.gz"
+
+DESCRIPTION="Adobe Flash Player"
+SRC_URI="x86? ( ${MY_32B_URI} )
+amd64? (
+ multilib? (
+ 32bit? ( ${MY_32B_URI} )
+ 64bit? ( ${MY_64B_URI} )
+ )
+ !multilib? ( ${MY_64B_URI} )
+)"
+HOMEPAGE="http://www.adobe.com/"
+IUSE="multilib +32bit +64bit"
+SLOT="0"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="AdobeFlash-10"
+RESTRICT="strip mirror"
+
+S="${WORKDIR}"
+
+NATIVE_DEPS="x11-libs/gtk+:2
+ media-libs/fontconfig
+ dev-libs/nss
+ net-misc/curl
+ >=sys-libs/glibc-2.4"
+
+EMUL_DEPS=">=app-emulation/emul-linux-x86-baselibs-20100220
+ app-emulation/emul-linux-x86-gtklibs
+ app-emulation/emul-linux-x86-soundlibs
+ app-emulation/emul-linux-x86-xlibs"
+
+RDEPEND="x86? ( $NATIVE_DEPS )
+ amd64? (
+ multilib? (
+ 64bit? ( $NATIVE_DEPS )
+ 32bit? ( $EMUL_DEPS )
+ )
+ !multilib? ( $NATIVE_DEPS )
+ )
+ || ( media-fonts/liberation-fonts media-fonts/corefonts )"
+
+# Where should this all go? (Bug #328639)
+INSTALL_BASE="opt/Adobe/flash-player"
+
+# Ignore QA warnings in these binary closed-source libraries, since we can't fix
+# them:
+QA_EXECSTACK="${INSTALL_BASE}32/libflashplayer.so
+ ${INSTALL_BASE}/libflashplayer.so"
+
+QA_DT_HASH="${INSTALL_BASE}32/libflashplayer.so
+ ${INSTALL_BASE}/libflashplayer.so"
+
+pkg_setup() {
+ if use x86; then
+ export native_install=1
+ elif use amd64; then
+ # amd64 users may unselect the native 64bit binary, if they choose
+ if ! use multilib || use 64bit; then
+ export native_install=1
+ # 64bit flash requires the 'lahf' instruction (bug #268336)
+ # Also, check if *any* of the processors are affected (bug #286159)
+ if grep '^flags' /proc/cpuinfo | grep -qv 'lahf_lm'; then
+ export need_lahf_wrapper=1
+ else
+ unset need_lahf_wrapper
+ fi
+ else
+ unset native_install
+ fi
+
+ if use multilib && ! use 32bit && ! use 64bit; then
+ eerror "You must select at least one library USE flag (32bit or 64bit)"
+ die "No library version selected [-32bit -64bit]"
+ fi
+ fi
+}
+
+src_compile() {
+ if [[ $need_lahf_wrapper ]]; then
+ # This experimental wrapper, from Maks Verver via bug #268336 should
+ # emulate the missing lahf instruction affected platforms.
+ $(tc-getCC) -fPIC -shared -nostdlib -lc -oflashplugin-lahf-fix.so \
+ "${FILESDIR}/flashplugin-lahf-fix.c" \
+ || die "Compile of flashplugin-lahf-fix.so failed"
+ fi
+}
+
+src_install() {
+ if [[ $native_install ]]; then
+ # 32b RPM has things hidden in funny places
+ use x86 && pushd "${S}/usr/lib/flash-plugin"
+
+ exeinto /${INSTALL_BASE}
+ doexe libflashplayer.so
+ inst_plugin /${INSTALL_BASE}/libflashplayer.so
+
+ use x86 && popd
+
+ # 64b tarball has no readme file.
+ use x86 && dodoc "${S}/usr/share/doc/flash-plugin-${PV}/readme.txt"
+ fi
+
+ if [[ $need_lahf_wrapper ]]; then
+ # This experimental wrapper, from Maks Verver via bug #268336 should
+ # emulate the missing lahf instruction affected platforms.
+ exeinto /${INSTALL_BASE}
+ doexe flashplugin-lahf-fix.so
+ inst_plugin /${INSTALL_BASE}/flashplugin-lahf-fix.so
+ fi
+
+ if use amd64 && has_multilib_profile && use 32bit; then
+ oldabi="${ABI}"
+ ABI="x86"
+
+ # 32b plugin
+ pushd "${S}/usr/lib/flash-plugin"
+ exeinto /${INSTALL_BASE}32/
+ doexe libflashplayer.so
+ inst_plugin /${INSTALL_BASE}32/libflashplayer.so
+ dodoc "${S}/usr/share/doc/flash-plugin-${PV}/readme.txt"
+ popd
+
+ ABI="${oldabi}"
+ fi
+
+ # The magic config file!
+ insinto "/etc/adobe"
+ doins "${FILESDIR}/mms.cfg"
+}
+
+pkg_postinst() {
+ if use amd64; then
+ if has_version 'www-plugins/nspluginwrapper'; then
+ if [[ $native_install ]]; then
+ # TODO: Perhaps parse the output of 'nspluginwrapper -l'
+ # However, the 64b flash plugin makes 'nspluginwrapper -l' segfault.
+ local FLASH_WRAPPER="${ROOT}/usr/lib64/nsbrowser/plugins/npwrapper.libflashplayer.so"
+ if [[ -f ${FLASH_WRAPPER} ]]; then
+ einfo "Removing duplicate 32-bit plugin wrapper: Native 64-bit plugin installed"
+ nspluginwrapper -r "${FLASH_WRAPPER}"
+ fi
+ if [[ $need_lahf_wrapper ]]; then
+ ewarn "Your processor does not support the 'lahf' instruction which is used"
+ ewarn "by Adobe's 64-bit flash binary. We have installed a wrapper which"
+ ewarn "should allow this plugin to run. If you encounter problems, please"
+ ewarn "adjust your USE flags to install only the 32-bit version and reinstall:"
+ ewarn " ${CATEGORY}/$PN[+32bit -64bit]"
+ fi
+ else
+ oldabi="${ABI}"
+ ABI="x86"
+ local FLASH_SOURCE="${ROOT}/usr/$(get_libdir)/${PLUGINS_DIR}/libflashplayer.so"
+
+ einfo "nspluginwrapper detected: Installing plugin wrapper"
+ nspluginwrapper -i "${FLASH_SOURCE}"
+
+ ABI="${oldabi}"
+ fi
+ elif [[ ! $native_install ]]; then
+ einfo "To use the 32-bit flash player in a native 64-bit firefox,"
+ einfo "you must install www-plugins/nspluginwrapper"
+ fi
+ fi
+
+ ewarn "Flash player is closed-source, and this version has a known major"
+ ewarn "security vulnerability[1]. Please consider only running flash applets"
+ ewarn "you know to be safe. The 'flashblock' extension may help for"
+ ewarn "mozilla users:"
+ ewarn " https://addons.mozilla.org/en-US/firefox/addon/433"
+ ewarn
+ ewarn "[1] http://www.adobe.com/support/security/advisories/apsa10-01.html"
+}
diff --git a/www-plugins/adobe-flash/adobe-flash-10.1.53.64-r1.ebuild b/www-plugins/adobe-flash/adobe-flash-10.1.53.64-r1.ebuild
new file mode 100644
index 000000000000..8bc321656cf7
--- /dev/null
+++ b/www-plugins/adobe-flash/adobe-flash-10.1.53.64-r1.ebuild
@@ -0,0 +1,161 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/adobe-flash-10.1.53.64-r1.ebuild,v 1.1 2010/07/20 14:49:58 lack Exp $
+
+EAPI=1
+inherit nsplugins rpm multilib toolchain-funcs
+
+MY_32B_URI="http://fpdownload.macromedia.com/get/flashplayer/current/flash-plugin-${PV}-release.i386.rpm"
+
+DESCRIPTION="Adobe Flash Player"
+SRC_URI="${MY_32B_URI}"
+HOMEPAGE="http://www.adobe.com/"
+IUSE="multilib"
+SLOT="0"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="AdobeFlash-10.1"
+RESTRICT="strip mirror"
+
+S="${WORKDIR}"
+
+NATIVE_DEPS="x11-libs/gtk+:2
+ media-libs/fontconfig
+ dev-libs/nss
+ net-misc/curl
+ >=sys-libs/glibc-2.4"
+
+EMUL_DEPS=">=app-emulation/emul-linux-x86-gtklibs-20100409-r1
+ app-emulation/emul-linux-x86-soundlibs"
+
+RDEPEND="x86? ( $NATIVE_DEPS )
+ amd64? ( $EMUL_DEPS )
+ || ( media-fonts/liberation-fonts media-fonts/corefonts )"
+
+# Where should this all go? (Bug #328639)
+INSTALL_BASE="opt/Adobe/flash-player"
+
+# Ignore QA warnings in these binary closed-source libraries, since we can't fix
+# them:
+QA_EXECSTACK="${INSTALL_BASE}32/libflashplayer.so
+ ${INSTALL_BASE}/libflashplayer.so"
+
+QA_DT_HASH="${INSTALL_BASE}32/libflashplayer.so
+ ${INSTALL_BASE}/libflashplayer.so"
+
+pkg_setup() {
+ if use x86; then
+ export native_install=1
+ elif use amd64; then
+ # As of 10.1, no more native 64b version *grumble grumble*
+ unset native_install
+ unset need_lahf_wrapper
+ export amd64_32bit=1
+ fi
+}
+
+src_compile() {
+ if [[ $need_lahf_wrapper ]]; then
+ # This experimental wrapper, from Maks Verver via bug #268336 should
+ # emulate the missing lahf instruction affected platforms.
+ $(tc-getCC) -fPIC -shared -nostdlib -lc -oflashplugin-lahf-fix.so \
+ "${FILESDIR}/flashplugin-lahf-fix.c" \
+ || die "Compile of flashplugin-lahf-fix.so failed"
+ fi
+}
+
+src_install() {
+ if [[ $native_install ]]; then
+ # 32b RPM has things hidden in funny places
+ use x86 && pushd "${S}/usr/lib/flash-plugin"
+
+ exeinto /${INSTALL_BASE}
+ doexe libflashplayer.so
+ inst_plugin /${INSTALL_BASE}/libflashplayer.so
+
+ use x86 && popd
+
+ # 64b tarball has no readme file.
+ use x86 && dodoc "${S}/usr/share/doc/flash-plugin-${PV}/readme.txt"
+ fi
+
+ if [[ $need_lahf_wrapper ]]; then
+ # This experimental wrapper, from Maks Verver via bug #268336 should
+ # emulate the missing lahf instruction affected platforms.
+ exeinto /${INSTALL_BASE}
+ doexe flashplugin-lahf-fix.so
+ inst_plugin /${INSTALL_BASE}/flashplugin-lahf-fix.so
+ fi
+
+ if [[ $amd64_32bit ]]; then
+ oldabi="${ABI}"
+ ABI="x86"
+
+ # 32b plugin
+ pushd "${S}/usr/lib/flash-plugin"
+ exeinto /${INSTALL_BASE}32
+ doexe libflashplayer.so
+ inst_plugin /${INSTALL_BASE}32/libflashplayer.so
+ dodoc "${S}/usr/share/doc/flash-plugin-${PV}/readme.txt"
+ popd
+
+ ABI="${oldabi}"
+ fi
+
+ # The magic config file!
+ insinto "/etc/adobe"
+ doins "${FILESDIR}/mms.cfg"
+}
+
+pkg_postinst() {
+ if use amd64; then
+ elog "Adobe has released 10.1 in only a 32-bit version and upgrading"
+ elog "is required to close a major security vulnerability:"
+ elog " http://bugs.gentoo.org/322855"
+ elog
+ elog "Furthermore, there are stability problems when running 10.1 in a"
+ elog "64-bit browser with nspluginwrapper. The current recommended"
+ elog "configuration is to use a 32-bit browser such as"
+ elog "www-client/firefox-bin:"
+ elog " http://bugs.gentoo.org/324365"
+ elog
+ # Temporarily skip automatic nspluginwrapper stuff, since it is fraught
+ # with peril (Bug #324365):
+ #
+ #if has_version 'www-plugins/nspluginwrapper'; then
+ # if [[ $native_install ]]; then
+ # # TODO: Perhaps parse the output of 'nspluginwrapper -l'
+ # # However, the 64b flash plugin makes 'nspluginwrapper -l' segfault.
+ # local FLASH_WRAPPER="${ROOT}/usr/lib64/nsbrowser/plugins/npwrapper.libflashplayer.so"
+ # if [[ -f ${FLASH_WRAPPER} ]]; then
+ # einfo "Removing duplicate 32-bit plugin wrapper: Native 64-bit plugin installed"
+ # nspluginwrapper -r "${FLASH_WRAPPER}"
+ # fi
+ # if [[ $need_lahf_wrapper ]]; then
+ # ewarn "Your processor does not support the 'lahf' instruction which is used"
+ # ewarn "by Adobe's 64-bit flash binary. We have installed a wrapper which"
+ # ewarn "should allow this plugin to run. If you encounter problems, please"
+ # ewarn "adjust your USE flags to install only the 32-bit version and reinstall:"
+ # ewarn " ${CATEGORY}/$PN[+32bit -64bit]"
+ # fi
+ # else
+ # oldabi="${ABI}"
+ # ABI="x86"
+ # local FLASH_SOURCE="${ROOT}/usr/$(get_libdir)/${PLUGINS_DIR}/libflashplayer.so"
+ #
+ # einfo "nspluginwrapper detected: Installing plugin wrapper"
+ # nspluginwrapper -i "${FLASH_SOURCE}"
+ #
+ # ABI="${oldabi}"
+ # fi
+ #elif [[ ! $native_install ]]; then
+ # einfo "To use the 32-bit flash player in a native 64-bit firefox,"
+ # einfo "you must install www-plugins/nspluginwrapper"
+ #fi
+ fi
+
+ ewarn "Flash player is closed-source, with a long history of security"
+ ewarn "issues. Please consider only running flash applets you know to"
+ ewarn "be safe. The 'flashblock' extension may help for mozilla users:"
+ ewarn " https://addons.mozilla.org/en-US/firefox/addon/433"
+}
diff --git a/www-plugins/adobe-flash/adobe-flash-9.0.277.0-r1.ebuild b/www-plugins/adobe-flash/adobe-flash-9.0.277.0-r1.ebuild
new file mode 100644
index 000000000000..b32685234cf1
--- /dev/null
+++ b/www-plugins/adobe-flash/adobe-flash-9.0.277.0-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/adobe-flash-9.0.277.0-r1.ebuild,v 1.1 2010/07/20 14:49:58 lack Exp $
+
+inherit nsplugins
+
+DESCRIPTION="Adobe Flash Player"
+SRC_URI="http://download.macromedia.com/pub/flashplayer/installers/current/9/install_flash_player_9.tar.gz"
+HOMEPAGE="http://www.adobe.com/go/kb406791"
+IUSE=""
+SLOT="0"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="AdobeFlash-9.0.31.0"
+RESTRICT="strip mirror"
+
+S=${WORKDIR}
+
+RDEPEND="amd64? ( app-emulation/emul-linux-x86-baselibs
+ app-emulation/emul-linux-x86-gtklibs
+ app-emulation/emul-linux-x86-soundlibs
+ app-emulation/emul-linux-x86-xlibs )
+ x86? ( x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXt
+ =x11-libs/gtk+-2*
+ media-libs/freetype
+ media-libs/fontconfig )
+ || ( media-fonts/liberation-fonts media-fonts/corefonts )"
+
+# Where should this all go? (Bug #328639)
+INSTALL_BASE="opt/Adobe/flash-player"
+
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
+
+src_install() {
+ cd "${S}/install_flash_player_9_linux/"
+ exeinto /${INSTALL_BASE}
+ doexe libflashplayer.so
+ inst_plugin /${INSTALL_BASE}/libflashplayer.so
+}
+
+pkg_postinst() {
+ ewarn "Flash player is closed-source, with a long history of security"
+ ewarn "issues. Please consider only running flash applets you know to"
+ ewarn "be safe."
+
+ if has_version 'www-client/mozilla-firefox'; then
+ elog "The firefox 'flashblock' extension may help:"
+ elog " https://addons.mozilla.org/en-US/firefox/addon/433"
+ fi
+}