summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-06-02 23:09:15 +0000
committerAlex Alexander <wired@gentoo.org>2010-06-02 23:09:15 +0000
commited5f8096bdcc52d711d93fbbc23d689829bb2225 (patch)
tree4a6e41933a886531a9be8999b2165213ee2d1648 /www-misc/zoneminder
parentInitial commit of customizable-weather plasmoid. Moved from kde overlay. Fixe... (diff)
downloadgentoo-2-ed5f8096bdcc52d711d93fbbc23d689829bb2225.tar.gz
gentoo-2-ed5f8096bdcc52d711d93fbbc23d689829bb2225.tar.bz2
gentoo-2-ed5f8096bdcc52d711d93fbbc23d689829bb2225.zip
zoneminder: fixed 1.24.2 build error
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'www-misc/zoneminder')
-rw-r--r--www-misc/zoneminder/ChangeLog6
-rw-r--r--www-misc/zoneminder/files/1.24.2/zm_build_fix.patch11
-rw-r--r--www-misc/zoneminder/zoneminder-1.24.2.ebuild3
3 files changed, 18 insertions, 2 deletions
diff --git a/www-misc/zoneminder/ChangeLog b/www-misc/zoneminder/ChangeLog
index 96efb3902889..8e35db689d6b 100644
--- a/www-misc/zoneminder/ChangeLog
+++ b/www-misc/zoneminder/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-misc/zoneminder
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/zoneminder/ChangeLog,v 1.38 2010/02/22 15:39:18 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/zoneminder/ChangeLog,v 1.39 2010/06/02 23:09:15 wired Exp $
+
+ 02 Jun 2010; Alex Alexander <wired@gentoo.org>
+ +files/1.24.2/zm_build_fix.patch, zoneminder-1.24.2.ebuild:
+ fixed 1.24.2 build error
22 Feb 2010; Samuli Suominen <ssuominen@gentoo.org>
+files/1.24.2/zm_jpeg.patch, zoneminder-1.24.2.ebuild:
diff --git a/www-misc/zoneminder/files/1.24.2/zm_build_fix.patch b/www-misc/zoneminder/files/1.24.2/zm_build_fix.patch
new file mode 100644
index 000000000000..164a10689362
--- /dev/null
+++ b/www-misc/zoneminder/files/1.24.2/zm_build_fix.patch
@@ -0,0 +1,11 @@
+diff -u -ru ZoneMinder-1.24.2-old//src/zm_utils.cpp ZoneMinder-1.24.2/src/zm_utils.cpp
+--- ZoneMinder-1.24.2-old//src/zm_utils.cpp 2010-06-03 01:34:27.981235559 +0300
++++ ZoneMinder-1.24.2/src/zm_utils.cpp 2010-06-03 01:44:52.108291327 +0300
+@@ -20,6 +20,7 @@
+ //#include "zm_debug.h"
+ #include "zm_utils.h"
+
++#include <cstdio>
+ #include <stdarg.h>
+
+ const std::string stringtf( const char *format, ... )
diff --git a/www-misc/zoneminder/zoneminder-1.24.2.ebuild b/www-misc/zoneminder/zoneminder-1.24.2.ebuild
index 7a58b6dc23eb..5ad9e4188e96 100644
--- a/www-misc/zoneminder/zoneminder-1.24.2.ebuild
+++ b/www-misc/zoneminder/zoneminder-1.24.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/zoneminder/zoneminder-1.24.2.ebuild,v 1.2 2010/02/22 15:39:18 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/zoneminder/zoneminder-1.24.2.ebuild,v 1.3 2010/06/02 23:09:15 wired Exp $
inherit eutils autotools depend.php depend.apache multilib
@@ -64,6 +64,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PATCH_PV}/zm_remote_camera_http.patch
epatch "${FILESDIR}"/${PATCH_PV}/db_upgrade_script_location.patch
epatch "${FILESDIR}"/${PATCH_PV}/zm_jpeg.patch
+ epatch "${FILESDIR}"/${PATCH_PV}/zm_build_fix.patch
eautoreconf
}