summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-06-29 13:17:59 +0000
committerPeter Volkov <pva@gentoo.org>2010-06-29 13:17:59 +0000
commit3db00d1b709e2a3046ecc6d00a8b100c90467de4 (patch)
treecb5ed036ae2894f55b9048e10580eca830642b2c /www-misc/fcgiwrap
parentStable on amd64 wrt bug #326139 (diff)
downloadgentoo-2-3db00d1b709e2a3046ecc6d00a8b100c90467de4.tar.gz
gentoo-2-3db00d1b709e2a3046ecc6d00a8b100c90467de4.tar.bz2
gentoo-2-3db00d1b709e2a3046ecc6d00a8b100c90467de4.zip
Initial import, bug #325413, thank Nikoli for this job.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'www-misc/fcgiwrap')
-rw-r--r--www-misc/fcgiwrap/ChangeLog11
-rw-r--r--www-misc/fcgiwrap/fcgiwrap-1.0.2-r1.ebuild47
-rw-r--r--www-misc/fcgiwrap/fcgiwrap-9999.ebuild47
-rw-r--r--www-misc/fcgiwrap/metadata.xml19
4 files changed, 124 insertions, 0 deletions
diff --git a/www-misc/fcgiwrap/ChangeLog b/www-misc/fcgiwrap/ChangeLog
new file mode 100644
index 000000000000..feb3224fa7f8
--- /dev/null
+++ b/www-misc/fcgiwrap/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for www-misc/fcgiwrap
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/fcgiwrap/ChangeLog,v 1.1 2010/06/29 13:17:59 pva Exp $
+
+*fcgiwrap-9999 (29 Jun 2010)
+*fcgiwrap-1.0.2-r1 (29 Jun 2010)
+
+ 29 Jun 2010; Peter Volkov <pva@gentoo.org> +fcgiwrap-1.0.2-r1.ebuild,
+ +fcgiwrap-9999.ebuild, +metadata.xml:
+ Initial import, bug #325413, thank Nikoli for this job.
+
diff --git a/www-misc/fcgiwrap/fcgiwrap-1.0.2-r1.ebuild b/www-misc/fcgiwrap/fcgiwrap-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..6ec6cf862ae6
--- /dev/null
+++ b/www-misc/fcgiwrap/fcgiwrap-1.0.2-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/fcgiwrap/fcgiwrap-1.0.2-r1.ebuild,v 1.1 2010/06/29 13:17:59 pva Exp $
+
+EAPI="3"
+
+[[ ${PV} = *9999* ]] && VCS_ECLASS="git" || VCS_ECLASS=""
+inherit autotools ${VCS_ECLASS}
+
+DESCRIPTION="Simple FastCGI wrapper for CGI scripts (CGI support for nginx)"
+HOMEPAGE="http://nginx.localdomain.pl/wiki/FcgiWrap"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="git://github.com/gnosek/${PN}.git"
+
+ KEYWORDS=""
+else
+ MY_REV="2e301c8"
+ SRC_URI="http://download.github.com/gnosek-${PN}-v${PV}-1-g${MY_REV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/gnosek-${PN}-${MY_REV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DEPEND="dev-libs/fcgi"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -e '/man8dir = $(DESTDIR)/s/@prefix@//' \
+ -i Makefile.in || die "sed failed"
+
+ eautoreconf
+}
+
+src_install() {
+ einstall DESTDIR="${D}"
+
+ dodoc README.rst
+}
+
+pkg_postinst() {
+ einfo 'You may want to install www-servers/spawn-fcgi to use with fcgiwrap.'
+}
diff --git a/www-misc/fcgiwrap/fcgiwrap-9999.ebuild b/www-misc/fcgiwrap/fcgiwrap-9999.ebuild
new file mode 100644
index 000000000000..c63083e2a121
--- /dev/null
+++ b/www-misc/fcgiwrap/fcgiwrap-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/fcgiwrap/fcgiwrap-9999.ebuild,v 1.1 2010/06/29 13:17:59 pva Exp $
+
+EAPI="3"
+
+[[ ${PV} = *9999* ]] && VCS_ECLASS="git" || VCS_ECLASS=""
+inherit autotools ${VCS_ECLASS}
+
+DESCRIPTION="Simple FastCGI wrapper for CGI scripts (CGI support for nginx)"
+HOMEPAGE="http://nginx.localdomain.pl/wiki/FcgiWrap"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="git://github.com/gnosek/${PN}.git"
+
+ KEYWORDS=""
+else
+ MY_REV="2e301c8"
+ SRC_URI="http://download.github.com/gnosek-${PN}-v${PV}-1-g${MY_REV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/gnosek-${PN}-${MY_REV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DEPEND="dev-libs/fcgi"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -e '/man8dir = $(DESTDIR)/s/@prefix@//' \
+ -i Makefile.in || die "sed failed"
+
+ eautoreconf
+}
+
+src_install() {
+ einstall DESTDIR="${D}"
+
+ dodoc README.rst
+}
+
+pkg_postinst() {
+ einfo 'You may want to install www-servers/spawn-fcgi to use with fcgiwrap.'
+}
diff --git a/www-misc/fcgiwrap/metadata.xml b/www-misc/fcgiwrap/metadata.xml
new file mode 100644
index 000000000000..c9a01cb144a2
--- /dev/null
+++ b/www-misc/fcgiwrap/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd></herd>
+<maintainer>
+<email>pva@gentoo.org</email>
+<name>Peter Volkov</name>
+</maintainer>
+<maintainer>
+<email>nikoli@lavabit.com</email>
+<name>Nikoli</name>
+</maintainer>
+<longdescription lang="en">
+ fcgiwrap is a simple server for running CGI applications over FastCGI. It
+ hopes to provide clean CGI support to Nginx (and other web servers that may
+ need it).
+</longdescription>
+</pkgmetadata>
+