summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-06-08 18:17:34 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-06-08 18:17:34 +0000
commitb92e999bc07b963db3adecc62504b792194a2b1d (patch)
tree9254b432eb52a116835e49fe2e0977394d9db39f /www-client
parentbump to 2.4.2. Bug fixes and translation updates. (diff)
downloadgentoo-2-b92e999bc07b963db3adecc62504b792194a2b1d.tar.gz
gentoo-2-b92e999bc07b963db3adecc62504b792194a2b1d.tar.bz2
gentoo-2-b92e999bc07b963db3adecc62504b792194a2b1d.zip
bump to 2.22.2. Mostly xulrunner changes.
(Portage version: 2.1.5.4)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany-extensions/ChangeLog8
-rw-r--r--www-client/epiphany-extensions/epiphany-extensions-2.22.2.ebuild91
2 files changed, 98 insertions, 1 deletions
diff --git a/www-client/epiphany-extensions/ChangeLog b/www-client/epiphany-extensions/ChangeLog
index 0ae69558639e..b5540e3883a9 100644
--- a/www-client/epiphany-extensions/ChangeLog
+++ b/www-client/epiphany-extensions/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/epiphany-extensions
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/ChangeLog,v 1.84 2008/05/29 18:17:03 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/ChangeLog,v 1.85 2008/06/08 18:17:34 eva Exp $
+
+*epiphany-extensions-2.22.2 (08 Jun 2008)
+
+ 08 Jun 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +epiphany-extensions-2.22.2.ebuild:
+ bump to 2.22.2. Mostly xulrunner changes.
29 May 2008; Ali Polatel <hawking@gentoo.org>
epiphany-extensions-2.20.3.ebuild, epiphany-extensions-2.22.1.ebuild:
diff --git a/www-client/epiphany-extensions/epiphany-extensions-2.22.2.ebuild b/www-client/epiphany-extensions/epiphany-extensions-2.22.2.ebuild
new file mode 100644
index 000000000000..efd3a07f22c5
--- /dev/null
+++ b/www-client/epiphany-extensions/epiphany-extensions-2.22.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/epiphany-extensions-2.22.2.ebuild,v 1.1 2008/06/08 18:17:34 eva Exp $
+
+inherit autotools eutils gnome2 python versionator
+
+MY_MAJORV=$(get_version_component_range 1-2)
+
+DESCRIPTION="Extensions for the Epiphany web browser"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/extensions.html"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~hppa ~ppc ~sparc ~x86"
+IUSE="dbus examples pcre python xulrunner"
+
+RDEPEND=">=www-client/epiphany-${MY_MAJORV}
+ app-text/opensp
+ >=dev-libs/glib-2.15.5
+ >=gnome-base/gconf-2.0
+ >=dev-libs/libxml2-2.6
+ >=x11-libs/gtk+-2.11.6
+ >=gnome-base/libglade-2
+ xulrunner? ( net-libs/xulrunner )
+ !xulrunner? ( >=www-client/mozilla-firefox-1.5 )
+ dbus? ( >=dev-libs/dbus-glib-0.34 )
+ pcre? ( >=dev-libs/libpcre-3.9-r2 )
+ python? ( >=dev-python/pygtk-2.11 )"
+DEPEND="${RDEPEND}
+ gnome-base/gnome-common
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.20
+ >=app-text/gnome-doc-utils-0.3.2"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+pkg_setup() {
+ local extensions=""
+
+ extensions="actions auto-reload auto-scroller certificates \
+ error-viewer extensions-manager-ui gestures java-console \
+ livehttpheaders page-info permissions push-scroller \
+ select-stylesheet sessionsaver sidebar smart-bookmarks \
+ tab-groups tab-states"
+
+ use dbus && extensions="${extensions} rss"
+
+ use pcre && extensions="${extensions} adblock greasemonkey"
+
+ use python && extensions="${extensions} python-console favicon cc-license-viewer epilicious"
+ use python && use examples && extensions="${extensions} sample-python"
+
+ use examples && extensions="${extensions} sample sample-mozilla"
+
+ G2CONF="${G2CONF} --with-extensions=$(echo "${extensions}" | sed -e 's/[[:space:]]\+/,/g')"
+
+ if use xulrunner; then
+ G2CONF="${G2CONF} --with-gecko=xulrunner"
+ else
+ G2CONF="${G2CONF} --with-gecko=firefox"
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+
+ # Don't remove sessionsaver, please. -dang
+ epatch "${FILESDIR}"/${PN}-2.21.92-sessionsaver-v4.patch.gz
+ echo "extensions/sessionsaver/ephy-sessionsaver-extension.c" >> po/POTFILES.in
+ AT_M4DIR="m4" eautoreconf
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ if use python; then
+ python_mod_optimize /usr/$(get_libdir)/epiphany/${MY_MAJORV}/extensions
+ fi
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+
+ if use python; then
+ python_mod_cleanup /usr/$(get_libdir)/epiphany/${MY_MAJORV}/extensions
+ fi
+}