summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2010-10-05 09:47:22 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2010-10-05 09:47:22 +0000
commitab4bdf5a19af1fd1433647a4f77fd46d1f2cbd0a (patch)
treef7e737efdfd6cfa4dafcea55a63efb9012b1675f /www-client
parentVersion bump. (diff)
downloadgentoo-2-ab4bdf5a19af1fd1433647a4f77fd46d1f2cbd0a.tar.gz
gentoo-2-ab4bdf5a19af1fd1433647a4f77fd46d1f2cbd0a.tar.bz2
gentoo-2-ab4bdf5a19af1fd1433647a4f77fd46d1f2cbd0a.zip
Pass the extra plugin dir in a command-line flag instead of patching the source. See bug #333575 by ferret <ferret@explodingferret.com>.
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog8
-rw-r--r--www-client/chromium/chromium-7.0.536.2.ebuild5
-rw-r--r--www-client/chromium/chromium-9999.ebuild5
-rw-r--r--www-client/chromium/files/chromium-launcher.sh2
4 files changed, 10 insertions, 10 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index e6c065e727b7..b37516ecd0a8 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.193 2010/10/04 10:55:37 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.194 2010/10/05 09:47:22 phajdan.jr Exp $
+
+ 05 Oct 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ chromium-7.0.536.2.ebuild, chromium-9999.ebuild,
+ files/chromium-launcher.sh:
+ Pass the extra plugin dir in a command-line flag instead of patching the
+ source. See bug #333575 by ferret <ferret@explodingferret.com>.
04 Oct 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
chromium-7.0.536.2.ebuild, chromium-9999.ebuild:
diff --git a/www-client/chromium/chromium-7.0.536.2.ebuild b/www-client/chromium/chromium-7.0.536.2.ebuild
index 84890087e53a..6a1ee9f0901b 100644
--- a/www-client/chromium/chromium-7.0.536.2.ebuild
+++ b/www-client/chromium/chromium-7.0.536.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-7.0.536.2.ebuild,v 1.2 2010/10/04 10:55:37 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-7.0.536.2.ebuild,v 1.3 2010/10/05 09:47:22 phajdan.jr Exp $
EAPI="2"
@@ -64,9 +64,6 @@ pkg_setup() {
}
src_prepare() {
- # Add Gentoo plugin paths.
- epatch "${FILESDIR}"/${PN}-plugins-path-r0.patch
-
# Small fixes to the system-provided sqlite support,
# to be upstreamed.
epatch "${FILESDIR}"/${PN}-system-sqlite-r0.patch
diff --git a/www-client/chromium/chromium-9999.ebuild b/www-client/chromium/chromium-9999.ebuild
index 30c48f738eef..2590020e89b9 100644
--- a/www-client/chromium/chromium-9999.ebuild
+++ b/www-client/chromium/chromium-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999.ebuild,v 1.88 2010/10/04 10:55:37 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999.ebuild,v 1.89 2010/10/05 09:47:22 phajdan.jr Exp $
EAPI="2"
@@ -109,9 +109,6 @@ pkg_setup() {
}
src_prepare() {
- # Add Gentoo plugin paths.
- epatch "${FILESDIR}"/${PN}-plugins-path-r0.patch
-
# Small fixes to the system-provided sqlite support,
# to be upstreamed.
epatch "${FILESDIR}"/${PN}-system-sqlite-r0.patch
diff --git a/www-client/chromium/files/chromium-launcher.sh b/www-client/chromium/files/chromium-launcher.sh
index dc14abd6fe35..a52268ef19e1 100644
--- a/www-client/chromium/files/chromium-launcher.sh
+++ b/www-client/chromium/files/chromium-launcher.sh
@@ -41,4 +41,4 @@ esac
# Set the .desktop file name
export CHROME_DESKTOP="chromium-chromium.desktop"
-exec "$PROGDIR/chrome" "$@"
+exec "$PROGDIR/chrome" --extra-plugin-dir=/usr/lib/nsbrowser/plugins "$@"