summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-05-02 08:20:36 +0000
committerJohannes Huber <johu@gentoo.org>2012-05-02 08:20:36 +0000
commit909ef2ff6eb0a41302e9f3c10bdbed87b413af3b (patch)
tree050cb657f0e3e6c8ca01b5c763190cf498661aa2 /www-client
parentStable for X86, wrt bug #414199 (diff)
downloadgentoo-2-909ef2ff6eb0a41302e9f3c10bdbed87b413af3b.tar.gz
gentoo-2-909ef2ff6eb0a41302e9f3c10bdbed87b413af3b.tar.bz2
gentoo-2-909ef2ff6eb0a41302e9f3c10bdbed87b413af3b.zip
Version bump.
(Portage version: 2.2.0_alpha101/cvs/Linux i686)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/rekonq/ChangeLog7
-rw-r--r--www-client/rekonq/rekonq-0.9.2.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/www-client/rekonq/ChangeLog b/www-client/rekonq/ChangeLog
index 6b22cf0ee7b9..df1e807db403 100644
--- a/www-client/rekonq/ChangeLog
+++ b/www-client/rekonq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/rekonq
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/rekonq/ChangeLog,v 1.41 2012/04/02 17:24:54 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/rekonq/ChangeLog,v 1.42 2012/05/02 08:20:36 johu Exp $
+
+*rekonq-0.9.2 (02 May 2012)
+
+ 02 May 2012; Johannes Huber <johu@gentoo.org> +rekonq-0.9.2.ebuild:
+ Version bump.
*rekonq-0.9.1 (02 Apr 2012)
diff --git a/www-client/rekonq/rekonq-0.9.2.ebuild b/www-client/rekonq/rekonq-0.9.2.ebuild
new file mode 100644
index 000000000000..816782eed8f6
--- /dev/null
+++ b/www-client/rekonq/rekonq-0.9.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/rekonq/rekonq-0.9.2.ebuild,v 1.1 2012/05/02 08:20:36 johu Exp $
+
+EAPI=4
+
+WEBKIT_REQUIRED="always"
+QT_MINIMAL="4.8"
+KDE_MINIMAL="4.7"
+KDE_SCM="git"
+KDE_LINGUAS="bg bs ca ca@valencia cs da de el en_GB eo es et eu fa fi fr ga gl
+hu is it ja ko lt nb nds nl pl pt pt_BR ro ru sk sl sr sr@ijekavian
+sr@ijekavianlatin sr@latin sv th tr ug uk zh_CN zh_TW"
+KDE_HANDBOOK="optional"
+VIRTUALX_REQUIRED=test
+inherit kde4-base
+
+DESCRIPTION="A browser based on qt-webkit"
+HOMEPAGE="http://rekonq.kde.org/"
+[[ ${PV} != *9999* ]] && SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="
+ >=x11-libs/qt-dbus-${QT_MINIMAL}:4
+"
+RDEPEND="${DEPEND}"
+
+# All test fails
+RESTRICT="test"
+
+src_prepare() {
+ # KDE_LINGUAS is also used to install appropriate handbooks
+ # since there is no en_US 'translation', it cannot be added
+ # hence making this impossible to install
+ mv doc/en_US doc/en || die "doc move failed"
+ sed -i -e 's/en_US/en/' doc/CMakeLists.txt || die "sed failed"
+ kde4-base_src_prepare
+}