summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2011-01-14 21:36:22 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2011-01-14 21:36:22 +0000
commit8b1154537442d0e3ba7342e4653fc89b39269627 (patch)
treebe7edbc7279d2392c5a7157778b7f01a7ac0fd11 /www-client
parentstable ppc, bug 342337 (diff)
downloadgentoo-2-8b1154537442d0e3ba7342e4653fc89b39269627.tar.gz
gentoo-2-8b1154537442d0e3ba7342e4653fc89b39269627.tar.bz2
gentoo-2-8b1154537442d0e3ba7342e4653fc89b39269627.zip
Make sure we don't use bundled xdg-utils. Remove old.
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog9
-rw-r--r--www-client/chromium/chromium-10.0.634.0-r1.ebuild (renamed from www-client/chromium/chromium-10.0.628.0-r1.ebuild)18
-rw-r--r--www-client/chromium/chromium-9999.ebuild10
-rw-r--r--www-client/chromium/files/chromium-system-xdg-utils-r0.patch54
4 files changed, 76 insertions, 15 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index 915472719767..bdbf16ada5d7 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.260 2011/01/13 13:05:19 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.261 2011/01/14 21:36:22 phajdan.jr Exp $
+
+*chromium-10.0.634.0-r1 (14 Jan 2011)
+
+ 14 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ +files/chromium-system-xdg-utils-r0.patch, -chromium-10.0.628.0-r1.ebuild,
+ +chromium-10.0.634.0-r1.ebuild, chromium-9999.ebuild:
+ Make sure we don't use bundled xdg-utils. Remove old.
13 Jan 2011; Markos Chandras <hwoarang@gentoo.org>
chromium-8.0.552.237.ebuild:
diff --git a/www-client/chromium/chromium-10.0.628.0-r1.ebuild b/www-client/chromium/chromium-10.0.634.0-r1.ebuild
index a8add6585034..1583013974f9 100644
--- a/www-client/chromium/chromium-10.0.628.0-r1.ebuild
+++ b/www-client/chromium/chromium-10.0.634.0-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-10.0.628.0-r1.ebuild,v 1.1 2011/01/10 09:44:20 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-10.0.634.0-r1.ebuild,v 1.1 2011/01/14 21:36:22 phajdan.jr Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
-V8_DEPEND="3.0.4.1"
+V8_DEPEND="3.0.6.1"
inherit eutils flag-o-matic multilib pax-utils portability python \
toolchain-funcs versionator virtualx
@@ -105,7 +105,8 @@ src_prepare() {
# Make sure we don't use bundled libvpx headers.
epatch "${FILESDIR}"/${PN}-system-vpx-r2.patch
- epatch "${FILESDIR}"/${PN}-system-speex-r0.patch
+ # Make sure we don't use bundled xdg-utils.
+ epatch "${FILESDIR}"/${PN}-system-xdg-utils-r0.patch
# Remove most bundled libraries. Some are still needed.
find third_party -type f \! -iname '*.gyp*' \
@@ -129,17 +130,13 @@ src_prepare() {
\! -path 'third_party/ots/*' \
\! -path 'third_party/protobuf/*' \
\! -path 'third_party/skia/*' \
+ \! -path 'third_party/speex/speex.h' \
\! -path 'third_party/sqlite/*' \
\! -path 'third_party/tcmalloc/*' \
\! -path 'third_party/undoview/*' \
- \! -path 'third_party/xdg-utils/*' \
\! -path 'third_party/zlib/contrib/minizip/*' \
-delete || die
- # Provide our own gyp file that links with the system speex.
- # TODO: move this upstream.
- cp "${FILESDIR}"/speex.gyp third_party/speex || die
-
# Check for the maintainer to ensure that the dependencies
# are up-to-date.
local v8_bundled="$(v8-extract-version v8/src/version.cc)"
@@ -193,7 +190,9 @@ src_configure() {
-Duse_system_libjpeg=1
-Duse_system_libpng=1
-Duse_system_libxml=1
+ -Duse_system_speex=1
-Duse_system_vpx=1
+ -Duse_system_xdg_utils=1
-Duse_system_zlib=1"
if use system-sqlite; then
@@ -301,7 +300,6 @@ src_install() {
doexe out/Release/chrome
doexe out/Release/chrome_sandbox || die
fperms 4755 "${CHROMIUM_HOME}/chrome_sandbox"
- doexe out/Release/xdg-settings || die
doexe "${FILESDIR}"/chromium-launcher.sh || die
insinto "${CHROMIUM_HOME}"
@@ -322,7 +320,7 @@ src_install() {
dosym /usr/$(get_libdir)/libavutil.so.50 "${CHROMIUM_HOME}" || die
# Install icon and desktop entry.
- newicon out/Release/product_logo_48.png ${PN}-browser.png || die
+ newicon chrome/app/theme/chromium/product_logo_48.png ${PN}-browser.png || die
dosym "${CHROMIUM_HOME}/chromium-launcher.sh" /usr/bin/chromium || die
make_desktop_entry chromium "Chromium" ${PN}-browser "Network;WebBrowser" \
"MimeType=text/html;text/xml;application/xhtml+xml;"
diff --git a/www-client/chromium/chromium-9999.ebuild b/www-client/chromium/chromium-9999.ebuild
index 67fff598f685..5762ceaf5a80 100644
--- a/www-client/chromium/chromium-9999.ebuild
+++ b/www-client/chromium/chromium-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999.ebuild,v 1.124 2011/01/12 12:58:56 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999.ebuild,v 1.125 2011/01/14 21:36:22 phajdan.jr Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
@@ -149,6 +149,9 @@ src_prepare() {
# Make sure we don't use bundled libvpx headers.
epatch "${FILESDIR}"/${PN}-system-vpx-r2.patch
+ # Make sure we don't use bundled xdg-utils.
+ epatch "${FILESDIR}"/${PN}-system-xdg-utils-r0.patch
+
# Remove most bundled libraries. Some are still needed.
find third_party -type f \! -iname '*.gyp*' \
\! -path 'third_party/WebKit/*' \
@@ -175,7 +178,6 @@ src_prepare() {
\! -path 'third_party/sqlite/*' \
\! -path 'third_party/tcmalloc/*' \
\! -path 'third_party/undoview/*' \
- \! -path 'third_party/xdg-utils/*' \
\! -path 'third_party/zlib/contrib/minizip/*' \
-delete || die
@@ -227,6 +229,7 @@ src_configure() {
-Duse_system_libxml=1
-Duse_system_speex=1
-Duse_system_vpx=1
+ -Duse_system_xdg_utils=1
-Duse_system_zlib=1"
if use system-sqlite; then
@@ -334,7 +337,6 @@ src_install() {
doexe out/Release/chrome
doexe out/Release/chrome_sandbox || die
fperms 4755 "${CHROMIUM_HOME}/chrome_sandbox"
- doexe out/Release/xdg-settings || die
doexe "${FILESDIR}"/chromium-launcher.sh || die
insinto "${CHROMIUM_HOME}"
@@ -355,7 +357,7 @@ src_install() {
dosym /usr/$(get_libdir)/libavutil.so.50 "${CHROMIUM_HOME}" || die
# Install icon and desktop entry.
- newicon out/Release/product_logo_48.png ${PN}-browser.png || die
+ newicon chrome/app/theme/chromium/product_logo_48.png ${PN}-browser.png || die
dosym "${CHROMIUM_HOME}/chromium-launcher.sh" /usr/bin/chromium || die
make_desktop_entry chromium "Chromium" ${PN}-browser "Network;WebBrowser" \
"MimeType=text/html;text/xml;application/xhtml+xml;"
diff --git a/www-client/chromium/files/chromium-system-xdg-utils-r0.patch b/www-client/chromium/files/chromium-system-xdg-utils-r0.patch
new file mode 100644
index 000000000000..143bff4b742a
--- /dev/null
+++ b/www-client/chromium/files/chromium-system-xdg-utils-r0.patch
@@ -0,0 +1,54 @@
+--- chrome/chrome_exe.gypi.orig 2011-01-14 16:57:11.000000000 +0000
++++ chrome/chrome_exe.gypi 2011-01-14 17:00:50.000000000 +0000
+@@ -141,6 +141,7 @@
+ 'msvs_guid': '7B219FAA-E360-43C8-B341-804A94EEFFAC',
+ 'variables': {
+ 'chrome_exe_target': 1,
++ 'use_system_xdg_utils%': 0,
+ },
+ 'conditions': [
+ ['OS=="linux" or OS=="freebsd" or OS=="openbsd"', {
+@@ -203,23 +204,27 @@
+ 'app/chrome_main.cc',
+ 'app/chrome_dll_resource.h',
+ ],
+- 'copies': [
+- {
+- 'destination': '<(PRODUCT_DIR)',
+- 'files': ['tools/build/linux/chrome-wrapper',
+- '../third_party/xdg-utils/scripts/xdg-mime',
+- '../third_party/xdg-utils/scripts/xdg-settings',
+- ],
+- # The wrapper script above may need to generate a .desktop file,
+- # which requires an icon. So, copy one next to the script.
+- 'conditions': [
+- ['branding=="Chrome"', {
+- 'files': ['app/theme/google_chrome/product_logo_48.png']
+- }, { # else: 'branding!="Chrome"
+- 'files': ['app/theme/chromium/product_logo_48.png']
+- }],
++ 'conditions': [
++ ['use_system_xdg_utils==0', {
++ 'copies': [
++ {
++ 'destination': '<(PRODUCT_DIR)',
++ 'files': ['tools/build/linux/chrome-wrapper',
++ '../third_party/xdg-utils/scripts/xdg-mime',
++ '../third_party/xdg-utils/scripts/xdg-settings',
++ ],
++ # The wrapper script above may need to generate a .desktop file,
++ # which requires an icon. So, copy one next to the script.
++ 'conditions': [
++ ['branding=="Chrome"', {
++ 'files': ['app/theme/google_chrome/product_logo_48.png']
++ }, { # else: 'branding!="Chrome"
++ 'files': ['app/theme/chromium/product_logo_48.png']
++ }],
++ ],
++ },
+ ],
+- },
++ }],
+ ],
+ }],
+ ['OS=="mac"', {