summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn N. Laliberte <allanonjl@gentoo.org>2006-07-02 19:28:10 +0000
committerJohn N. Laliberte <allanonjl@gentoo.org>2006-07-02 19:28:10 +0000
commit0165d3042c5f5b1556e97e21fe291969430ed796 (patch)
tree6626418ace7acdf7e48e2e636870da211294ba90 /www-client
parentVersion bump, bug #138879 (diff)
downloadgentoo-2-0165d3042c5f5b1556e97e21fe291969430ed796.tar.gz
gentoo-2-0165d3042c5f5b1556e97e21fe291969430ed796.tar.bz2
gentoo-2-0165d3042c5f5b1556e97e21fe291969430ed796.zip
migrate to using seamonkey instead of mozilla. cleanup old ebuilds.
(Portage version: 2.1.1_pre1-r5)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany/ChangeLog16
-rw-r--r--www-client/epiphany/epiphany-1.8.4.1-r1.ebuild71
-rw-r--r--www-client/epiphany/epiphany-2.14.2.1-r1.ebuild96
-rw-r--r--www-client/epiphany/files/digest-epiphany-1.8.4.1-r13
-rw-r--r--www-client/epiphany/files/digest-epiphany-2.14.2.1-r13
5 files changed, 188 insertions, 1 deletions
diff --git a/www-client/epiphany/ChangeLog b/www-client/epiphany/ChangeLog
index 0e9d93afd339..6dd2efc92997 100644
--- a/www-client/epiphany/ChangeLog
+++ b/www-client/epiphany/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for www-client/epiphany
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.71 2006/06/30 18:41:49 allanonjl Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.72 2006/07/02 19:28:10 allanonjl Exp $
+
+*epiphany-2.14.2.1-r1 (02 Jul 2006)
+*epiphany-1.8.4.1-r1 (02 Jul 2006)
+
+ 02 Jul 2006; John N. Laliberte <allanonjl@gentoo.org>
+ -files/epiphany-1.6.0-fix_includes.patch,
+ -files/epiphany-1.6.0-view_source.patch,
+ -files/epiphany-1.6.0-wallet_fix.patch,
+ -files/epiphany-1.6.0-wallet_password.patch,
+ -files/epiphany-1.6.3-fix_includes.patch, -epiphany-1.6.0-r3.ebuild,
+ -epiphany-1.6.3.ebuild, -epiphany-1.6.4.ebuild,
+ +epiphany-1.8.4.1-r1.ebuild, -epiphany-2.14.2.1.ebuild,
+ +epiphany-2.14.2.1-r1.ebuild:
+ migrate to using seamonkey instead of mozilla. cleanup old ebuilds.
*epiphany-2.14.2.1 (30 Jun 2006)
diff --git a/www-client/epiphany/epiphany-1.8.4.1-r1.ebuild b/www-client/epiphany/epiphany-1.8.4.1-r1.ebuild
new file mode 100644
index 000000000000..baef2f19d271
--- /dev/null
+++ b/www-client/epiphany/epiphany-1.8.4.1-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-1.8.4.1-r1.ebuild,v 1.1 2006/07/02 19:28:10 allanonjl Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="GNOME webbrowser based on the mozilla rendering engine"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc sparc x86"
+IUSE="dbus doc firefox python"
+
+# Note that there is no libgnomeprint dep, while it is
+# specified in configure.in . This could in some rare
+# situations break portage dep resolution.
+#
+# Marinus <foser@gentoo.org> 14-9-2005
+
+RDEPEND=">=dev-libs/glib-2.8
+ >=x11-libs/gtk+-2.8.3
+ >=dev-libs/libxml2-2.6.12
+ >=dev-libs/libxslt-1.1.7
+ >=gnome-base/libglade-2.3.1
+ >=gnome-base/gnome-vfs-2.9.2
+ >=gnome-base/libgnomeui-2.6
+ >=gnome-base/gnome-desktop-2.9.91
+ >=x11-libs/startup-notification-0.5
+ >=gnome-base/libgnomeprintui-2.4
+ >=gnome-base/libbonobo-2
+ >=gnome-base/orbit-2
+ >=gnome-base/gconf-2
+ >=app-text/iso-codes-0.35
+ sparc? ( >=www-client/mozilla-firefox-1.0.5 )
+ ia64? ( >=www-client/mozilla-firefox-1.0.5 )
+ !sparc? ( !ia64? (
+ !firefox? ( www-client/seamonkey )
+ ) )
+ firefox? ( >=www-client/mozilla-firefox-1.0.5 )
+ dbus? ( >=sys-apps/dbus-0.34 )
+ python? (
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.7.1
+ >=dev-python/gnome-python-2.6 )
+ x11-themes/gnome-icon-theme"
+
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.29
+ >=app-text/gnome-doc-utils-0.3.2
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS COPYING.README ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+USE_DESTDIR="1"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+
+pkg_setup() {
+ G2CONF="--disable-scrollkeeper \
+ $(use_enable dbus) \
+ $(use_enable python)"
+
+ if use firefox || use sparc || use ia64; then
+ G2CONF="${G2CONF} --with-mozilla=firefox"
+ else
+ G2CONF="${G2CONF} --with-mozilla=seamonkey"
+ fi
+}
diff --git a/www-client/epiphany/epiphany-2.14.2.1-r1.ebuild b/www-client/epiphany/epiphany-2.14.2.1-r1.ebuild
new file mode 100644
index 000000000000..d92a225cd6c5
--- /dev/null
+++ b/www-client/epiphany/epiphany-2.14.2.1-r1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-2.14.2.1-r1.ebuild,v 1.1 2006/07/02 19:28:10 allanonjl Exp $
+
+inherit eutils gnome2 multilib autotools
+
+DESCRIPTION="GNOME webbrowser based on the mozilla rendering engine"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc firefox python"
+
+# Note that there is no libgnomeprint dep, while it is
+# specified in configure.in . This could in some rare
+# situations break portage dep resolution.
+#
+# Marinus <foser@gentoo.org> 14-9-2005
+
+# require firefox on sparc and ia64, seamonkey on ppc64
+RDEPEND=">=dev-libs/glib-2.8
+ >=x11-libs/gtk+-2.8.3
+ >=dev-libs/libxml2-2.6.12
+ >=dev-libs/libxslt-1.1.7
+ >=gnome-base/libglade-2.3.1
+ >=gnome-base/gnome-vfs-2.9.2
+ >=gnome-base/libgnomeui-2.6
+ >=gnome-base/gnome-desktop-2.9.91
+ >=x11-libs/startup-notification-0.5
+ >=gnome-base/libgnomeprintui-2.4
+ >=gnome-base/libbonobo-2
+ >=gnome-base/orbit-2
+ >=gnome-base/gconf-2
+ >=app-text/iso-codes-0.35
+ sparc? ( >=www-client/mozilla-firefox-1.0.5 )
+ ia64? ( >=www-client/mozilla-firefox-1.0.5 )
+ ppc64? ( www-client/seamonkey )
+ !sparc? ( !ia64? (
+ !firefox? ( www-client/seamonkey )
+ ) )
+ firefox? ( >=www-client/mozilla-firefox-1.0.5 )
+ >=sys-apps/dbus-0.35
+ python? (
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.7.1
+ >=dev-python/gnome-python-2.6 )
+ x11-themes/gnome-icon-theme"
+
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.29
+ app-text/gnome-doc-utils
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+pkg_setup() {
+ G2CONF="--disable-scrollkeeper \
+ $(use_enable python)"
+
+ if use firefox || use sparc || use ia64; then
+ G2CONF="${G2CONF} --with-mozilla=firefox"
+ elif use ppc64; then
+ G2CONF="${G2CONF} --with-mozilla=seamonkey"
+ else
+ G2CONF="${G2CONF} --with-mozilla=seamonkey"
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ epatch ${FILESDIR}/${PN}-1.9.2-broken-firefox.patch
+
+ cp aclocal.m4 old_macros.m4
+ AT_M4DIR=". ${S}/m4" WANT_AUTOCONF="2.59" \
+ eautoreconf || die "Failed to reconfigure"
+}
+
+src_compile() {
+ addpredict /usr/$(get_libdir)/seamonkey/components/xpti.dat
+ addpredict /usr/$(get_libdir)/seamonkey/components/xpti.dat.tmp
+
+ addpredict /usr/$(get_libdir)/mozilla-firefox/components/xpti.dat
+ addpredict /usr/$(get_libdir)/mozilla-firefox/components/xpti.dat.tmp
+ addpredict /usr/$(get_libdir)/mozilla-firefox/components/compreg.dat.tmp
+
+ addpredict /usr/$(get_libdir)/mozilla/components/xpti.dat
+ addpredict /usr/$(get_libdir)/mozilla/components/xpti.dat.tmp
+
+ gnome2_src_compile
+}
diff --git a/www-client/epiphany/files/digest-epiphany-1.8.4.1-r1 b/www-client/epiphany/files/digest-epiphany-1.8.4.1-r1
new file mode 100644
index 000000000000..55b592a8a8d6
--- /dev/null
+++ b/www-client/epiphany/files/digest-epiphany-1.8.4.1-r1
@@ -0,0 +1,3 @@
+MD5 e34870feff1db2c529568a75be7546b0 epiphany-1.8.4.1.tar.bz2 3360178
+RMD160 de5e4f6bfed1269300145c015fea34b03238a771 epiphany-1.8.4.1.tar.bz2 3360178
+SHA256 ccdcfddbd0dfaa5eeca57e868c3b77c90369bb1126eaa0175efeee823e67f112 epiphany-1.8.4.1.tar.bz2 3360178
diff --git a/www-client/epiphany/files/digest-epiphany-2.14.2.1-r1 b/www-client/epiphany/files/digest-epiphany-2.14.2.1-r1
new file mode 100644
index 000000000000..75cea701965f
--- /dev/null
+++ b/www-client/epiphany/files/digest-epiphany-2.14.2.1-r1
@@ -0,0 +1,3 @@
+MD5 872ef8d5e95cdc359f93b5ded501d98d epiphany-2.14.2.1.tar.bz2 3599395
+RMD160 c25bc2d22fee0eeaa32ce1e1f71b6d5f3de06cbb epiphany-2.14.2.1.tar.bz2 3599395
+SHA256 f5cc3aa382fb9b0eec4117dcbfb5a7744943602d1a76bf260c7e5c66741ee6d0 epiphany-2.14.2.1.tar.bz2 3599395