summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-12-05 17:37:22 +0000
committerAlex Alexander <wired@gentoo.org>2009-12-05 17:37:22 +0000
commit052142fa7109a8e9d508cff7383394e234a5c7c7 (patch)
treecf2bf147b8d34efb3bf517520eace22a172798e4 /www-client/uzbl/uzbl-9999.ebuild
parentAdd "test" USE flag and src_test(). (diff)
downloadgentoo-2-052142fa7109a8e9d508cff7383394e234a5c7c7.tar.gz
gentoo-2-052142fa7109a8e9d508cff7383394e234a5c7c7.tar.bz2
gentoo-2-052142fa7109a8e9d508cff7383394e234a5c7c7.zip
some makefile improvements after talking with upstream
(Portage version: 2.2_rc55/cvs/Linux x86_64)
Diffstat (limited to 'www-client/uzbl/uzbl-9999.ebuild')
-rw-r--r--www-client/uzbl/uzbl-9999.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/www-client/uzbl/uzbl-9999.ebuild b/www-client/uzbl/uzbl-9999.ebuild
index 6bbeb154d382..4834ded6c460 100644
--- a/www-client/uzbl/uzbl-9999.ebuild
+++ b/www-client/uzbl/uzbl-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/uzbl/uzbl-9999.ebuild,v 1.4 2009/12/05 16:19:54 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/uzbl/uzbl-9999.ebuild,v 1.5 2009/12/05 17:37:22 wired Exp $
EAPI="2"
@@ -77,13 +77,12 @@ src_compile() {
}
src_install() {
- if use tabbed; then
- emake DESTDIR="${D}" PREFIX="/usr" install || die "Installation failed"
- else if use browser; then
+ emake DESTDIR="${D}" PREFIX="/usr" install-uzbl-core || die "Installation failed"
+ if use browser || use tabbed; then
emake DESTDIR="${D}" PREFIX="/usr" install-uzbl-browser || die "Installation failed"
- else
- emake DESTDIR="${D}" PREFIX="/usr" install-uzbl-core || die "Installation failed"
- fi
+ fi
+ if use tabbed; then
+ emake DESTDIR="${D}" PREFIX="/usr" install-uzbl-tabbed || die "Installation failed"
fi
# Move the docs to /usr/share/doc instead.