summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-10-19 23:13:03 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-10-19 23:13:03 +0000
commit7103081fff906447e7ebf2fd9a7c7383bc0e102e (patch)
tree4c52d6483f28f6c2ad3756531884aa934fe04491 /www-client/kazehakase
parentfix ChangeLog entries for missing > in email address (diff)
downloadgentoo-2-7103081fff906447e7ebf2fd9a7c7383bc0e102e.tar.gz
gentoo-2-7103081fff906447e7ebf2fd9a7c7383bc0e102e.tar.bz2
gentoo-2-7103081fff906447e7ebf2fd9a7c7383bc0e102e.zip
Version bumped, bug #284181. Cleanup
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'www-client/kazehakase')
-rw-r--r--www-client/kazehakase/ChangeLog10
-rw-r--r--www-client/kazehakase/files/kazehakase-0.5.7-gentoo.patch35
-rw-r--r--www-client/kazehakase/files/kazehakase-0.5.7-gtkentry.patch30
-rw-r--r--www-client/kazehakase/kazehakase-0.5.0.ebuild51
-rw-r--r--www-client/kazehakase/kazehakase-0.5.7.ebuild (renamed from www-client/kazehakase/kazehakase-0.5.5-r1.ebuild)50
5 files changed, 101 insertions, 75 deletions
diff --git a/www-client/kazehakase/ChangeLog b/www-client/kazehakase/ChangeLog
index fbdbbc61348c..4ed78dcf3e20 100644
--- a/www-client/kazehakase/ChangeLog
+++ b/www-client/kazehakase/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-client/kazehakase
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/kazehakase/ChangeLog,v 1.74 2009/10/10 15:53:10 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/kazehakase/ChangeLog,v 1.75 2009/10/19 23:13:03 matsuu Exp $
+
+*kazehakase-0.5.7 (19 Oct 2009)
+
+ 19 Oct 2009; MATSUU Takuto <matsuu@gentoo.org> -kazehakase-0.5.0.ebuild,
+ -kazehakase-0.5.5-r1.ebuild, +kazehakase-0.5.7.ebuild,
+ +files/kazehakase-0.5.7-gentoo.patch,
+ +files/kazehakase-0.5.7-gtkentry.patch:
+ Version bumped, bug #284181. Cleanup.
10 Oct 2009; Raúl Porcel <armin76@gentoo.org> kazehakase-0.5.6-r1.ebuild:
sparc stable wrt #275706
diff --git a/www-client/kazehakase/files/kazehakase-0.5.7-gentoo.patch b/www-client/kazehakase/files/kazehakase-0.5.7-gentoo.patch
new file mode 100644
index 000000000000..2dc6b0f8d0c3
--- /dev/null
+++ b/www-client/kazehakase/files/kazehakase-0.5.7-gentoo.patch
@@ -0,0 +1,35 @@
+diff -Naur kazehakase-0.5.7.orig/configure.ac kazehakase-0.5.7/configure.ac
+--- kazehakase-0.5.7.orig/configure.ac 2009-08-29 07:18:16.000000000 +0900
++++ kazehakase-0.5.7/configure.ac 2009-10-20 02:01:03.000000000 +0900
+@@ -596,7 +596,7 @@
+ GENHTML_OPTIONS="--title 'Kazehakase Code Coverage'"
+
+ KAZEHAKASE_CFLAGS="$GTK_CFLAGS $LIBGNUTLS_CFLAGS $GIO_CFLAGS"
+-KAZEHAKASE_CFLAGS="$KAZEHAKASE_CFLAGS -DGDK_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED"
++KAZEHAKASE_CFLAGS="$KAZEHAKASE_CFLAGS -DGDK_DISABLE_DEPRECATED" dnl -DGTK_DISABLE_DEPRECATED
+ KAZEHAKASE_CFLAGS="$KAZEHAKASE_CFLAGS -DG_DISABLE_DEPRECATED"
+ KAZEHAKASE_CFLAGS="$KAZEHAKASE_CFLAGS -DSYSDATADIR=\\\"\"\$(datadir)\"\\\""
+ KAZEHAKASE_CFLAGS="$KAZEHAKASE_CFLAGS -DLOCALEDIR=\\\"\"\$(localedir)\"\\\""
+diff -Naur kazehakase-0.5.7.orig/module/search/kz-hyper-estraier-search.c kazehakase-0.5.7/module/search/kz-hyper-estraier-search.c
+--- kazehakase-0.5.7.orig/module/search/kz-hyper-estraier-search.c 2009-08-29 07:15:09.000000000 +0900
++++ kazehakase-0.5.7/module/search/kz-hyper-estraier-search.c 2009-10-20 01:17:40.000000000 +0900
+@@ -401,7 +401,7 @@
+ strlen(G_DIR_SEPARATOR_S));
+
+ thumb_filename =
+- egg_pixbuf_get_thumb_filename(uri,
++ egg_pixbuf_get_thumbnail_filename(uri,
+ EGG_PIXBUF_THUMBNAIL_LARGE);
+ thumb_uri = g_strdup_printf("history-search:?image=%s",
+ thumb_filename);
+diff -Naur kazehakase-0.5.7.orig/src/actions/kz-actions.c kazehakase-0.5.7/src/actions/kz-actions.c
+--- kazehakase-0.5.7.orig/src/actions/kz-actions.c 2009-08-29 07:15:13.000000000 +0900
++++ kazehakase-0.5.7/src/actions/kz-actions.c 2009-10-20 01:14:55.000000000 +0900
+@@ -23,6 +23,7 @@
+
+ #include <string.h>
+ #include <glib/gi18n.h>
++#include <gtk/gtkaction.h>
+
+ #include "gtk-utils.h"
+ #include "glib-utils.h"
diff --git a/www-client/kazehakase/files/kazehakase-0.5.7-gtkentry.patch b/www-client/kazehakase/files/kazehakase-0.5.7-gtkentry.patch
new file mode 100644
index 000000000000..133237ec9a2d
--- /dev/null
+++ b/www-client/kazehakase/files/kazehakase-0.5.7-gtkentry.patch
@@ -0,0 +1,30 @@
+diff -urN kazehakase-0.5.7.orig/src/widget/kz-entry.c kazehakase-0.5.7/src/widget/kz-entry.c
+--- kazehakase-0.5.7.orig/src/widget/kz-entry.c 2009-08-29 01:15:11.000000000 +0300
++++ kazehakase-0.5.7/src/widget/kz-entry.c 2009-09-03 22:42:29.000000000 +0300
+@@ -514,7 +514,7 @@
+
+ if (entry->visible)
+ {
+- g_string_prepend_len (tmp_string, entry->text, entry->x_n_bytes);
++ g_string_prepend_len (tmp_string, entry->text, entry->n_bytes);
+ g_string_insert (tmp_string, cursor_index, preedit_string);
+ }
+ else
+@@ -523,7 +523,7 @@
+ gint preedit_len_chars;
+ gunichar invisible_char;
+
+- ch_len = g_utf8_strlen (entry->text, entry->x_n_bytes);
++ ch_len = g_utf8_strlen (entry->text, entry->n_bytes);
+ preedit_len_chars = g_utf8_strlen (preedit_string, -1);
+ ch_len += preedit_len_chars;
+
+@@ -557,7 +557,7 @@
+ {
+ if (entry->visible)
+ {
+- pango_layout_set_text (layout, entry->text, entry->x_n_bytes);
++ pango_layout_set_text (layout, entry->text, entry->n_bytes);
+ }
+ else
+ {
diff --git a/www-client/kazehakase/kazehakase-0.5.0.ebuild b/www-client/kazehakase/kazehakase-0.5.0.ebuild
deleted file mode 100644
index be1ad80bc8f2..000000000000
--- a/www-client/kazehakase/kazehakase-0.5.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/kazehakase/kazehakase-0.5.0.ebuild,v 1.6 2008/03/14 17:31:10 armin76 Exp $
-
-inherit flag-o-matic
-
-IUSE="hyperestraier migemo ruby ssl"
-
-DESCRIPTION="a browser with gecko engine like Epiphany or Galeon."
-SRC_URI="mirror://sourceforge.jp/${PN}/27774/${P}.tar.gz"
-HOMEPAGE="http://kazehakase.sourceforge.jp/"
-
-SLOT="0"
-KEYWORDS="amd64 ppc sparc x86"
-LICENSE="GPL-2"
-
-DEPEND=">=x11-libs/gtk+-2.12
- || (
- =www-client/mozilla-firefox-2*
- =www-client/seamonkey-1*
- =mail-client/mozilla-thunderbird-2*
- =net-libs/xulrunner-1.8*
- )
- ssl? ( >=net-libs/gnutls-1.2.0 )
- ruby? ( dev-ruby/ruby-gtk2 dev-ruby/ruby-gettext )
- hyperestraier? ( >=app-text/hyperestraier-1.2 )"
-
-RDEPEND="${DEPEND}
- migemo? ( app-text/migemo )"
-
-DEPEND="${DEPEND}
- dev-util/pkgconfig"
-
-src_compile(){
- local myconf
-
- # Bug 159949
- replace-flags -Os -O2
-
- myconf="${myconf} $(use_enable migemo)"
- use ruby || myconf="${myconf} --with-ruby=no --with-rgettext=no"
- use ssl || myconf="${myconf} --disable-ssl"
-
- econf ${myconf} || die
- emake || die
-}
-
-src_install(){
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README* TODO*
-}
diff --git a/www-client/kazehakase/kazehakase-0.5.5-r1.ebuild b/www-client/kazehakase/kazehakase-0.5.7.ebuild
index bd7abbc8931c..018486cb2d4a 100644
--- a/www-client/kazehakase/kazehakase-0.5.5-r1.ebuild
+++ b/www-client/kazehakase/kazehakase-0.5.7.ebuild
@@ -1,31 +1,27 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/kazehakase/kazehakase-0.5.5-r1.ebuild,v 1.2 2008/12/16 15:51:23 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/kazehakase/kazehakase-0.5.7.ebuild,v 1.1 2009/10/19 23:13:03 matsuu Exp $
-inherit eutils flag-o-matic
+EAPI="2"
+inherit autotools eutils flag-o-matic
-#IUSE="hyperestraier migemo ruby ssl webkit"
-IUSE="hyperestraier migemo ruby ssl"
+IUSE="hyperestraier migemo ruby ssl webkit"
DESCRIPTION="a browser with gecko engine like Epiphany or Galeon."
-SRC_URI="mirror://sourceforge.jp/${PN}/32341/${P}.tar.gz"
+SRC_URI="mirror://sourceforge.jp/${PN}/43338/${P}.tar.gz"
HOMEPAGE="http://kazehakase.sourceforge.jp/"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
LICENSE="GPL-2"
-DEPEND=">=x11-libs/gtk+-2.12
- || (
- >=www-client/mozilla-firefox-2
- >=www-client/seamonkey-1
- >=mail-client/mozilla-thunderbird-2
- >=net-libs/xulrunner-1.8
- )
+DEPEND=">=x11-libs/gtk+-2.14
+ net-libs/xulrunner:1.9
ssl? ( >=net-libs/gnutls-1.2.0 )
ruby? ( dev-ruby/ruby-gtk2 dev-ruby/ruby-gettext )
- hyperestraier? ( >=app-text/hyperestraier-1.2 )"
-# webkit? ( net-libs/webkit-gtk )
+ hyperestraier? ( >=app-text/hyperestraier-1.2 )
+ webkit? ( >=net-libs/webkit-gtk-1.1.1 )"
+# >=dev-libs/cutter-1.0.6
RDEPEND="${DEPEND}
migemo? ( app-text/migemo )"
@@ -33,24 +29,32 @@ RDEPEND="${DEPEND}
DEPEND="${DEPEND}
dev-util/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-xulrunner19.patch
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gtkentry.patch \
+ "${FILESDIR}"/${P}-gentoo.patch
+ eautoreconf
}
-src_compile() {
+src_configure() {
local myconf
# Bug 159949
replace-flags -Os -O2
- myconf="${myconf} $(use_enable migemo)"
use ruby || myconf="${myconf} --with-ruby=no --with-rgettext=no"
use ssl || myconf="${myconf} --disable-ssl"
- econf ${myconf} || die
- emake || die
+ # The "e" in heyper is not a mistake, it is a typo in the source package
+ econf \
+ --with-gecko-engine=libxul \
+ $(use_enable migemo) \
+ $(use_enable hyperestraier heyper-estraier) \
+ ${myconf} || die
+}
+
+src_compile() {
+ emake -j1 || die
}
src_install() {