summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-04-17 17:45:27 +0000
committerPacho Ramos <pacho@gentoo.org>2013-04-17 17:45:27 +0000
commite92992c9413fb1fe909a1969bf4a589c1b0fb085 (patch)
tree3cda1f9a76f073b9f1dbe921c53305c8c6889846 /www-client/epiphany
parentVersion bump (diff)
downloadgentoo-2-e92992c9413fb1fe909a1969bf4a589c1b0fb085.tar.gz
gentoo-2-e92992c9413fb1fe909a1969bf4a589c1b0fb085.tar.bz2
gentoo-2-e92992c9413fb1fe909a1969bf4a589c1b0fb085.zip
Version bump
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'www-client/epiphany')
-rw-r--r--www-client/epiphany/ChangeLog7
-rw-r--r--www-client/epiphany/epiphany-3.8.1.ebuild95
2 files changed, 101 insertions, 1 deletions
diff --git a/www-client/epiphany/ChangeLog b/www-client/epiphany/ChangeLog
index 6d5bb7587b6a..fd4a0174b731 100644
--- a/www-client/epiphany/ChangeLog
+++ b/www-client/epiphany/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/epiphany
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.294 2013/03/31 19:26:26 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.295 2013/04/17 17:45:27 pacho Exp $
+
+*epiphany-3.8.1 (17 Apr 2013)
+
+ 17 Apr 2013; Pacho Ramos <pacho@gentoo.org> +epiphany-3.8.1.ebuild:
+ Version bump
31 Mar 2013; Pacho Ramos <pacho@gentoo.org> epiphany-3.8.0.ebuild:
Fix libsecret dependency, bug #463904 by Chris Mayo
diff --git a/www-client/epiphany/epiphany-3.8.1.ebuild b/www-client/epiphany/epiphany-3.8.1.ebuild
new file mode 100644
index 000000000000..7ab677ec6ae0
--- /dev/null
+++ b/www-client/epiphany/epiphany-3.8.1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-3.8.1.ebuild,v 1.1 2013/04/17 17:45:27 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 pax-utils versionator virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="http://projects.gnome.org/epiphany/"
+
+# TODO: coverage
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+jit +nss test"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=app-crypt/gcr-3.5.5
+ >=app-crypt/libsecret-0.14
+ >=app-text/iso-codes-0.35
+ >=dev-libs/glib-2.35.6:2
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-libs/libxslt-1.1.7
+ >=gnome-base/gnome-keyring-2.26.0
+ >=gnome-base/gsettings-desktop-schemas-0.0.1
+ >=net-dns/avahi-0.6.22[dbus]
+ >=net-libs/webkit-gtk-1.11.92:3[jit?]
+ >=net-libs/libsoup-2.42.1:2.4
+ >=x11-libs/gtk+-3.7.10:3
+ >=x11-libs/libnotify-0.5.1:=
+ gnome-base/gnome-desktop:3=
+
+ dev-db/sqlite:3
+ x11-libs/libwnck:3
+ x11-libs/libX11
+
+ x11-themes/gnome-icon-theme
+ x11-themes/gnome-icon-theme-symbolic
+
+ nss? ( dev-libs/nss )
+"
+# paxctl needed for bug #407085
+# eautoreconf requires gnome-common-3.5.5
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1
+ >=dev-util/intltool-0.50
+ sys-apps/paxctl
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Fix testsuite, upstream bug #698221
+ # FIXME: patches don't fix above bug, but I cannot then reach
+ # the test they are supposed to solve.
+# epatch "${FILESDIR}/${PN}-3.7.5-test-gwarning.patch"
+# sed -e '/\/do_migration_invalid/,+1 d' \
+# -i tests/ephy-migration-test.c || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-shared \
+ --disable-static \
+ --with-distributor-name=Gentoo \
+ $(use_enable nss) \
+ $(use_enable test tests)
+}
+
+src_compile() {
+ # needed to avoid "Command line `dbus-launch ...' exited with non-zero exit status 1"
+ unset DISPLAY
+ gnome2_src_compile
+}
+
+src_test() {
+ # FIXME: this should be handled at eclass level
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+
+ # FIXME:
+ #use jit && pax-mark m $(list-paxables tests/test*) #415801
+
+ GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+ gnome2_src_install
+ use jit && pax-mark m "${ED}usr/bin/epiphany"
+}