summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2013-05-28 12:51:56 +0000
committerAlfredo Tupone <tupone@gentoo.org>2013-05-28 12:51:56 +0000
commitdd225fa544215080af11b0e841034e9e398be960 (patch)
tree71af4213e4b0f5ffbd45904a5d05b37f3a0abec8 /www-apps
parentUpdate locales list, thanks to Nikoli <nikoli AT lavabit.com> (diff)
downloadgentoo-2-dd225fa544215080af11b0e841034e9e398be960.tar.gz
gentoo-2-dd225fa544215080af11b0e841034e9e398be960.tar.bz2
gentoo-2-dd225fa544215080af11b0e841034e9e398be960.zip
Nuw package
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0145142D)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/liquid_feedback_frontend/ChangeLog12
-rw-r--r--www-apps/liquid_feedback_frontend/files/lqfb-apache.conf41
-rw-r--r--www-apps/liquid_feedback_frontend/files/lqfb.example.com.conf24
-rw-r--r--www-apps/liquid_feedback_frontend/files/myconfig.lua29
-rw-r--r--www-apps/liquid_feedback_frontend/files/postinstall-en.txt52
-rw-r--r--www-apps/liquid_feedback_frontend/liquid_feedback_frontend-2.2.2.ebuild64
-rw-r--r--www-apps/liquid_feedback_frontend/metadata.xml13
7 files changed, 235 insertions, 0 deletions
diff --git a/www-apps/liquid_feedback_frontend/ChangeLog b/www-apps/liquid_feedback_frontend/ChangeLog
new file mode 100644
index 000000000000..d8094d94f265
--- /dev/null
+++ b/www-apps/liquid_feedback_frontend/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for www-apps/liquid_feedback_frontend
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/liquid_feedback_frontend/ChangeLog,v 1.1 2013/05/28 12:51:56 tupone Exp $
+
+*liquid_feedback_frontend-2.2.2 (28 May 2013)
+
+ 28 May 2013; Alfredo Tupone <tupone@gentoo.org>
+ +liquid_feedback_frontend-2.2.2.ebuild, +files/lqfb.example.com.conf,
+ +files/lqfb-apache.conf, +files/myconfig.lua, +files/postinstall-en.txt,
+ +metadata.xml:
+ New package
+
diff --git a/www-apps/liquid_feedback_frontend/files/lqfb-apache.conf b/www-apps/liquid_feedback_frontend/files/lqfb-apache.conf
new file mode 100644
index 000000000000..3f1924b6ae3a
--- /dev/null
+++ b/www-apps/liquid_feedback_frontend/files/lqfb-apache.conf
@@ -0,0 +1,41 @@
+RewriteEngine on
+
+RewriteRule ^/$ /lf/ [R]
+
+RewriteRule ^/lf/static/(.*)$ /lf/static/$1 [L,PT]
+
+RewriteCond %{QUERY_STRING} (.*)?
+RewriteRule ^/lf/$ /lf/webmcp-wrapper.lua?_webmcp_urldepth=0&_webmcp_module=index&_webmcp_view=index&%1 [PT]
+
+RewriteCond %{QUERY_STRING} (.*)?
+RewriteRule ^/lf/([^/]+)/$ /lf/webmcp-wrapper.lua?_webmcp_urldepth=1&_webmcp_module=$1&_webmcp_view=index&%1 [PT]
+
+RewriteCond %{QUERY_STRING} (.*)?
+RewriteRule ^/lf/([^/]+)/([^/\.]+)$ /lf/webmcp-wrapper.lua?_webmcp_urldepth=1&_webmcp_module=$1&_webmcp_action=$2&%1 [PT]
+
+RewriteCond %{QUERY_STRING} (.*)?
+RewriteRule ^/lf/([^/]+)/([^/\.]+)\.([^/]+)$ /lf/webmcp-wrapper.lua?_webmcp_urldepth=1&_webmcp_module=$1&_webmcp_view=$2&_webmcp_suffix=$3&%1 [PT]
+
+RewriteCond %{QUERY_STRING} (.*)?
+RewriteRule ^/lf/([^/]+)/([^/]+)/([^/\.]+)\.([^/]+)$ /lf/webmcp-wrapper.lua?_webmcp_urldepth=2&_webmcp_module=$1&_webmcp_view=$2&_webmcp_id=$3&_webmcp_suffix=$4&%1 [PT]
+
+Alias /lf/static /var/lib/liquid_feedback_frontend/static
+
+ScriptAlias /lf/ /usr/lib/webmcp/framework/cgi-bin/
+
+<Directory "/var/lib/liquid_feedback_frontend/static">
+ AllowOverride None
+ Order allow,deny
+ Allow from all
+</Directory>
+
+<Directory "/usr/lib/webmcp/framework/cgi-bin">
+ AllowOverride None
+ Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
+ Order allow,deny
+ Allow from all
+</Directory>
+
+<Location /lf>
+ SetEnv WEBMCP_APP_BASEPATH '/var/lib/liquid_feedback_frontend'
+</Location>
diff --git a/www-apps/liquid_feedback_frontend/files/lqfb.example.com.conf b/www-apps/liquid_feedback_frontend/files/lqfb.example.com.conf
new file mode 100644
index 000000000000..149084138683
--- /dev/null
+++ b/www-apps/liquid_feedback_frontend/files/lqfb.example.com.conf
@@ -0,0 +1,24 @@
+<VirtualHost *:80>
+ ServerName lqfb.example.com
+
+ RewriteEngine On
+ RewriteRule (.*) https://lqfb.example.com%{REQUEST_URI}
+</VirtualHost>
+
+<VirtualHost *:443>
+ ServerName lqfb.example.com
+
+ SSLEngine on
+ SSLProtocol all -SSLv2
+ SSLCipherSuite ALL:!ADH:!EXPORT:!SSLv2:RC4+RSA:+HIGH:+MEDIUM
+ SSLCertificateFile /etc/ssl/apache2/wildcard/server.crt
+ SSLCertificateKeyFile /etc/ssl/apache2/wildcard/server.key
+
+ include /usr/share/liquid_feedback_frontend/lqfb-apache.conf
+
+ <Location /lf>
+ SetEnv WEBMCP_CONFIG_NAME 'myconfig'
+ </Location>
+
+ ErrorLog /var/log/apache2/lqfb.example.com-error.log
+</VirtualHost>
diff --git a/www-apps/liquid_feedback_frontend/files/myconfig.lua b/www-apps/liquid_feedback_frontend/files/myconfig.lua
new file mode 100644
index 000000000000..19c259cd7cbd
--- /dev/null
+++ b/www-apps/liquid_feedback_frontend/files/myconfig.lua
@@ -0,0 +1,29 @@
+config.absolute_base_url = "https://lqfb.example.com/lf"
+config.instance_name = "lf"
+config.database = { engine='postgresql', dbname='liquid_feedback', user='liquid_feedback', password='xxx'}
+config.enable_debug_trace = true
+
+execute.config("init")
+
+config.formatting_engine_executeables = {
+ rocketwiki= "rocketwiki-lqfb",
+ compat = "rocketwiki-lqfb-compat"
+}
+
+-- Checkbox(es) the user has to accept while registering
+--
+--
+----
+--------------------------------------------------------------------------
+config.use_terms_checkboxes = {
+ {
+ name = "terms_of_use_v1",
+ html = "I accept the terms of use.",
+ not_accepted_error = "You have to accept the terms of use to be able to regi ster."
+ },
+-- {
+-- name = "extra_terms_of_use_v1",
+-- html = "I accept the extra terms of use.",
+-- not_accepted_error = "You have to accept the extra terms of use to be able to register."
+-- }
+}
diff --git a/www-apps/liquid_feedback_frontend/files/postinstall-en.txt b/www-apps/liquid_feedback_frontend/files/postinstall-en.txt
new file mode 100644
index 000000000000..688f693c48cb
--- /dev/null
+++ b/www-apps/liquid_feedback_frontend/files/postinstall-en.txt
@@ -0,0 +1,52 @@
+0. DATABASE SETUP
+
+To use Liquid Feedback you have to follow these
+simple steps, which have to be done as the postgres system user (or
+which ever is the database superuser):
+
+$ createuser liquid_feedback
+and answer the following
+Shall the new role be a superuser? (y/n) n
+Shall the new role be allowed to create databases? (y/n) y
+Shall the new role be allowed to create more new roles? (y/n) n
+
+$ psql
+postgres=# ALTER USER liquid_feedback WITH PASSWORD 'the_new_password';
+
+$ createdb -U liquid_feedback liquid_feedback
+$ psql -U liquid_feedback liquid_feedback
+liquid_feedback=# \i ${MY_INSTALLDIR}/liquid_feedback_core/core.sql
+liquid_feedback=# \i ${MY_INSTALLDIR}/liquid_feedback_core/init.sql
+INSERT INTO system_setting (member_ttl) VALUES ('1 year');
+INSERT INTO contingent (polling, time_frame, text_entry_limit, initiative_limit) VALUES (false, '1 hour', 20, 6);
+INSERT INTO contingent (polling, time_frame, text_entry_limit, initiative_limit) VALUES (false, '1 day', 80, 12);
+INSERT INTO contingent (polling, time_frame, text_entry_limit, initiative_limit) VALUES (true, '1 hour', 200, 60);
+INSERT INTO contingent (polling, time_frame, text_entry_limit, initiative_limit) VALUES (true, '1 day', 800, 120);
+INSERT INTO policy (index, name, admission_time, discussion_time, verification_time, voting_time, issue_quorum_num, issue_quorum_den, initiative_quorum_num, initiative_quorum_den) VALUES (1, 'Default policy', '8 days', '15 days', '8 days', '15 days', 10, 100, 10, 100);
+
+cd /var/liquid_feedback_frontend
+/usr/lib/webmcp/framework/bin/webmcp_shell myconfig
+Lua 5.1.5 Copyright (C) 1994-2012 Lua.org, PUC-Rio
+> member = Member:by_id(1)
+> member:set_password("type-password-here")
+> member:save()
+> os.exit()
+
+Ensure that "lf_update dbname=liquid_feedback" and
+"lf_update_suggestion_order dbname=liquid_feedback" are called
+regularly! It is required to run these commands regularly
+(i.e. every 5 minutes via cron) to update cached supporter counts,
+to change the state of issues when neccessary, to calculate the
+result of votings, etc. If you wish, copy the created lf_update
+and lf_update_suggestion_order files to /usr/local/bin or a
+similar directory.
+
+It is possible to run these two commands in parallel, if a setup
+requires splitting the load to multiple processor cores. In other
+cases it is recommended to run "lf_update" first, and then
+"lf_update_suggestion_order".
+
+To create an export file, which is containing all but private data,
+you may use the lf_export shell-script:
+$ lf_export liquid_feedback export.sql.gz
+
diff --git a/www-apps/liquid_feedback_frontend/liquid_feedback_frontend-2.2.2.ebuild b/www-apps/liquid_feedback_frontend/liquid_feedback_frontend-2.2.2.ebuild
new file mode 100644
index 000000000000..772104cd0dde
--- /dev/null
+++ b/www-apps/liquid_feedback_frontend/liquid_feedback_frontend-2.2.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/liquid_feedback_frontend/liquid_feedback_frontend-2.2.2.ebuild,v 1.1 2013/05/28 12:51:56 tupone Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+PN_F=${PN}
+PV_F=v${PV}
+MY_P=${PN}-v${PV}
+
+DESCRIPTION="Internet platforms for proposition development and decision making"
+HOMEPAGE="http://www.public-software-group.org/liquid_feedback"
+SRC_URI="http://www.public-software-group.org/pub/projects/liquid_feedback/frontend/v${PV}/${MY_P}.tar.gz
+linguas_it? ( mirror://gentoo/${PN}-italian-${PV}.tar.gz )"
+
+LICENSE="HPND CC-BY-2.5"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="linguas_de linguas_el linguas_en linguas_eo linguas_it"
+
+RDEPEND=""
+DEPEND="www-apps/rocketwiki-lqfb
+ ${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare () {
+ for lang in zh-Hans zh-TW ; do
+ rm -f locale/help/*.${lang}.txt
+ done
+ for lang in de el en eo it ; do
+ if ! use linguas_${lang}; then
+ rm -f locale/help/*.${lang}.txt
+ fi
+ done
+}
+
+src_compile() {
+ emake -C locale
+}
+
+src_install() {
+ dodoc README
+ dodoc "${FILESDIR}"/lqfb.example.com.conf
+ dodoc "${FILESDIR}"/postinstall-en.txt
+
+ insinto /var/lib/${PN}
+ doins -r app db env model static tmp utils
+ insinto /var/lib/${PN}/locale
+ doins locale/*.lua
+ insinto /var/lib/${PN}/locale/help
+ doins locale/help/*html
+
+ insinto /etc/${PN}
+ doins "${FILESDIR}"/myconfig.lua config/*
+ dosym /etc/${PN} /var/lib/${PN}/config
+
+ insinto /usr/share/${PN}
+ doins "${FILESDIR}"/lqfb-apache.conf
+
+ fowners apache:apache /var/lib/${PN}/tmp
+}
diff --git a/www-apps/liquid_feedback_frontend/metadata.xml b/www-apps/liquid_feedback_frontend/metadata.xml
new file mode 100644
index 000000000000..1971333113c6
--- /dev/null
+++ b/www-apps/liquid_feedback_frontend/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>tupone@gentoo.org</email>
+<name>Alfredo Tupone</name>
+</maintainer>
+<longdescription lang="en">
+LiquidFeedback is an open-source software, powering internet platforms for proposition development and decision making.
+LiquidFeedback is an independent open source project published under MIT license by the Public Software Group of Berlin, Germany.
+The developers of LiquidFeedback have joined together in the Interaktive Demokratie association to promote the use of electronic media for democratic processes.
+</longdescription>
+</pkgmetadata>